summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/unp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/unp')
-rw-r--r--app-arch/unp/Manifest2
-rw-r--r--app-arch/unp/files/unp-2.0_pre7_p1-remove-deprecated-have.diff10
-rw-r--r--app-arch/unp/metadata.xml5
-rw-r--r--app-arch/unp/unp-2.0_pre7.ebuild42
-rw-r--r--app-arch/unp/unp-2.0_pre7_p1.ebuild48
5 files changed, 107 insertions, 0 deletions
diff --git a/app-arch/unp/Manifest b/app-arch/unp/Manifest
new file mode 100644
index 000000000000..09340e6de478
--- /dev/null
+++ b/app-arch/unp/Manifest
@@ -0,0 +1,2 @@
+DIST unp_2.0~pre7+nmu1.tar.bz2 17537 SHA256 7c2d6f2835a5a59ee2588b66d8015d97accd62e71e38ba90ebd4d71d8fd78227 SHA512 1b30f14c8d17e0a6b149ca4795f2219e9180f814347410e7ff7fa2b9720a9d308190f2ded8fcfd11bac9b5bb7a64ffd93f140bdaffcba1127f0e15e3d2737362 WHIRLPOOL 28fcec4dd271f952bac9313e5f4bff8fc244361831dc7829a5746d0af26c89586744d158a79808c02f3be9b41240b5eb082cfe11cf151e38ac8fd962e72af8bb
+DIST unp_2.0~pre7.tar.bz2 14492 SHA256 dddf23bf81444a876d4dba67c25c934e077f290499ada531ef70a930aa8fd6a7 SHA512 b90238a3e359d45e4b0ec3e5559a682fce3a7a37f74dd5419b005bb7bd3e3e5be03dde2e5d40d1671c0274ff1d795560fa238a572fe6cf3ab12f17dd1e2bcd1d WHIRLPOOL 21b1c7ded3b861739cd5e94d858e98b3ec785c777cd924c41599a36735824faebf845ec40a0bb206c1573aa20f0afb240e0356e4ab25a6547a29905c127217c7
diff --git a/app-arch/unp/files/unp-2.0_pre7_p1-remove-deprecated-have.diff b/app-arch/unp/files/unp-2.0_pre7_p1-remove-deprecated-have.diff
new file mode 100644
index 000000000000..a0838a82559f
--- /dev/null
+++ b/app-arch/unp/files/unp-2.0_pre7_p1-remove-deprecated-have.diff
@@ -0,0 +1,10 @@
+diff -Naur unp-2.0~pre7+nmu1/bash_completion.d/unp unp-2.0~pre7+nmu1-1/bash_completion.d/unp
+--- unp-2.0~pre7+nmu1/bash_completion.d/unp 2012-05-16 22:05:13.000000000 +0200
++++ unp-2.0~pre7+nmu1-1/bash_completion.d/unp 2014-10-22 10:34:20.343233166 +0200
+@@ -1,6 +1,5 @@
+ # bash completion for unp
+
+-have unp &&
+ _unp()
+ {
+ local cur
diff --git a/app-arch/unp/metadata.xml b/app-arch/unp/metadata.xml
new file mode 100644
index 000000000000..8cb548491f4e
--- /dev/null
+++ b/app-arch/unp/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>hanno@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/app-arch/unp/unp-2.0_pre7.ebuild b/app-arch/unp/unp-2.0_pre7.ebuild
new file mode 100644
index 000000000000..85511e36448b
--- /dev/null
+++ b/app-arch/unp/unp-2.0_pre7.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit eutils bash-completion-r1
+
+DESCRIPTION="Script for unpacking various file formats"
+HOMEPAGE="http://packages.qa.debian.org/u/unp.html"
+SRC_URI="mirror://debian/pool/main/u/unp/${PN}_${PV/_/$'\x7e'}.tar.bz2"
+S="${WORKDIR}/${PN}-${PV/_/$'\x7e'}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~hppa ~ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="nls"
+
+DEPEND="nls? ( sys-devel/gettext )"
+
+RDEPEND="${DEPEND}
+ dev-lang/perl"
+
+src_compile() {
+ if use nls; then
+ cd po
+ emake
+ fi
+}
+
+src_install() {
+ dobin unp || die "dobin failed"
+ dosym /usr/bin/unp /usr/bin/ucat
+ doman debian/unp.1 || die "doman failed"
+ dodoc debian/changelog debian/README.Debian
+ dobashcomp bash_completion.d/unp
+
+ if use nls; then
+ cd po
+ emake DESTDIR="${D}" install
+ fi
+}
diff --git a/app-arch/unp/unp-2.0_pre7_p1.ebuild b/app-arch/unp/unp-2.0_pre7_p1.ebuild
new file mode 100644
index 000000000000..06e2e4ef25de
--- /dev/null
+++ b/app-arch/unp/unp-2.0_pre7_p1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils bash-completion-r1
+
+DESCRIPTION="Script for unpacking various file formats"
+HOMEPAGE="http://packages.qa.debian.org/u/unp.html"
+TEMP_PV="${PV/_pre/$'\x7e'pre}"
+MY_PV="${TEMP_PV/_p/+nmu}"
+SRC_URI="mirror://debian/pool/main/u/unp/${PN}_${MY_PV}.tar.bz2"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="nls"
+
+DEPEND="nls? ( sys-devel/gettext )"
+
+RDEPEND="${DEPEND}
+ dev-lang/perl"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-remove-deprecated-have.diff"
+}
+
+src_compile() {
+ if use nls; then
+ cd po
+ emake
+ fi
+}
+
+src_install() {
+ dobin unp || die "dobin failed"
+ dosym /usr/bin/unp /usr/bin/ucat
+ doman debian/unp.1 || die "doman failed"
+ dodoc debian/changelog debian/README.Debian
+ dobashcomp bash_completion.d/unp
+
+ if use nls; then
+ cd po
+ emake DESTDIR="${D}" install
+ fi
+}