summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2016-05-08 00:03:25 +0200
committerMichael Weber <xmw@gentoo.org>2016-05-08 00:03:25 +0200
commit21f7db9006140c7aa28c14aefba92fd30a58cb95 (patch)
treef5c1d3cd2b823c7bdbd751822e41a28e6d1083a9 /app-backup/backintime
parentdev-util/cppcheck: Version bump (thanks Christian Strahl for the hint, bug 57... (diff)
downloadgentoo-21f7db9006140c7aa28c14aefba92fd30a58cb95.tar.gz
gentoo-21f7db9006140c7aa28c14aefba92fd30a58cb95.tar.bz2
gentoo-21f7db9006140c7aa28c14aefba92fd30a58cb95.zip
app-backup/backintime: Version bump (thanks Yanestra for the hint, bug 579560).
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-backup/backintime')
-rw-r--r--app-backup/backintime/Manifest1
-rw-r--r--app-backup/backintime/backintime-1.1.12.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/app-backup/backintime/Manifest b/app-backup/backintime/Manifest
index e377acab465d..eca5319311e9 100644
--- a/app-backup/backintime/Manifest
+++ b/app-backup/backintime/Manifest
@@ -1 +1,2 @@
+DIST backintime-1.1.12.tar.gz 656192 SHA256 a835e4eccb70ea3e8156861750a4c93d33dbc0e8590daf390c5a54dcc6b0ee4c SHA512 e1dc3e3d2bac8b0f390898029978e806128ffd6005471a7e8a697c44f9e271f9902b496b33b037133f9a509f4ca3f8b8f10adf681b670ec9a1a751dfc786cb62 WHIRLPOOL 8ada493d2cbb38879bc7481899eb41fa235b9e4e7d3a003d40b230c32924e568a2fa0b43bbd875c734279f36d63dd678cd7eabf406a18cc4b7c45d716cacfae1
DIST backintime-1.1.8.tar.gz 617754 SHA256 a1f2d210e95633dfe383eb50b3b560d1e09c43de4ce89dd4cb193cab40cb8a1e SHA512 550e270dcf341ec5ad952f4decd836007d19ff9bf60cada834dfb488dbf29954b6fd3ed80a4f8fb4406a0166895a7f7c922e5622d06c43086dd54073e5aabd99 WHIRLPOOL ea9af3c432c61def4214e1d1e2c70e40cb7e50867bb0fa08930740c13133293ad135fd6c97295ab176deaedacb33e72583dc7c34dcfc3cb375a8b6e7fc7ab632
diff --git a/app-backup/backintime/backintime-1.1.12.ebuild b/app-backup/backintime/backintime-1.1.12.ebuild
new file mode 100644
index 000000000000..62e5964ca6be
--- /dev/null
+++ b/app-backup/backintime/backintime-1.1.12.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_3 python3_4 )
+
+inherit eutils python-single-r1
+
+DESCRIPTION="Backup system inspired by TimeVault and FlyBack, with a GUI for GNOME and KDE4"
+HOMEPAGE="http://backintime.le-web.org/"
+SRC_URI="http://${PN}.le-web.org/download/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="qt4"
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ net-misc/openssh
+ net-misc/rsync[xattr,acl]"
+RDEPEND="${DEPEND}
+ qt4? ( dev-python/PyQt4 )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_prepare() {
+ #fix doc install location
+ sed -e "s:/doc/${PN}-common:/doc/${PF}:g" \
+ -i common/configure || die
+ sed -e "s:/doc/${PN}-qt4:/doc/${PF}:g" \
+ -i qt4/configure || die
+ sed -e "/addInstallFile \"..\/VERSION/d" \
+ -e "/addInstallFile \"..\/LICENSE/d" \
+ -e "/addInstallFile \"..\/debian\/copyright/d" \
+ -i {qt4,common}/configure || die
+
+ if [ -n ${LINGUAS+x} ] ; then
+ cd common/po || die
+ for po in *.po ; do
+ if ! has ${po/.po} ${LINGUAS} ; then
+ rm ${po} || die
+ fi
+ done
+ fi
+}
+
+src_configure() {
+ cd "${S}"/common || die
+ ./configure --python3 --no-fuse-group || die
+ if use qt4 ; then
+ cd "${S}"/qt4 || die
+ ./configure --python3 || die
+ fi
+}
+
+src_compile() {
+ cd "${S}"/common || die
+ emake
+ if use qt4 ; then
+ cd "${S}"/qt4 || die
+ emake
+ fi
+}
+
+src_install() {
+ cd "${S}"/common || die
+ emake DESTDIR="${D}" install
+ if use qt4 ; then
+ cd "${S}"/qt4 || die
+ emake DESTDIR="${D}" install
+ fi
+
+ python_optimize "${D}"
+}