summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-benchmarks/pipebench
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-benchmarks/pipebench')
-rw-r--r--app-benchmarks/pipebench/Manifest1
-rw-r--r--app-benchmarks/pipebench/metadata.xml5
-rw-r--r--app-benchmarks/pipebench/pipebench-0.40-r1.ebuild35
-rw-r--r--app-benchmarks/pipebench/pipebench-0.40.ebuild33
4 files changed, 74 insertions, 0 deletions
diff --git a/app-benchmarks/pipebench/Manifest b/app-benchmarks/pipebench/Manifest
new file mode 100644
index 000000000000..6c52bb0b34ab
--- /dev/null
+++ b/app-benchmarks/pipebench/Manifest
@@ -0,0 +1 @@
+DIST pipebench-0.40.tar.gz 11542 SHA256 ca764003446222ad9dbd33bbc7d94cdb96fa72608705299b6cc8734cd3562211 SHA512 bace18d73425cf56bc3fd95eea4db47b3010cc82c16d9b433390d0ee4593046ab10101ce73df451596b34ace89fa92e93a92bb625286edb9cdfb809e630788cd WHIRLPOOL 4f580ac6fac6695d499332f68c09cacdc37d10e7ba2e5b86af35f18d6a0d2faaa002ed9d46390dfb54b7f7febf11df757fa57ba3d80fa111f658b3d00abc4a7a
diff --git a/app-benchmarks/pipebench/metadata.xml b/app-benchmarks/pipebench/metadata.xml
new file mode 100644
index 000000000000..7e5a7f579109
--- /dev/null
+++ b/app-benchmarks/pipebench/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>benchmarks</herd>
+</pkgmetadata>
diff --git a/app-benchmarks/pipebench/pipebench-0.40-r1.ebuild b/app-benchmarks/pipebench/pipebench-0.40-r1.ebuild
new file mode 100644
index 000000000000..b355b853980c
--- /dev/null
+++ b/app-benchmarks/pipebench/pipebench-0.40-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Measures the speed of stdin/stdout communication"
+HOMEPAGE="http://www.habets.pp.se/synscan/programs.php?prog=pipebench"
+SRC_URI="ftp://ftp.habets.pp.se/pub/synscan/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86 ~arm-linux ~x86-linux"
+IUSE=""
+
+src_prepare() {
+ sed -i Makefile \
+ -e 's:CFLAGS=-Wall:CFLAGS+= -Wall:' \
+ -e 's:$(CFLAGS) -o:$(LDFLAGS) &:g' \
+ -e "s:/usr/local/bin/:${ED}/usr/bin:" \
+ -e "s:/usr/local/man/man1/:${ED}/usr/share/man/man1:" \
+ || die "sed Makefile"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) || die
+}
+
+src_install() {
+ dodir /usr/{bin,share/man/man1}
+ emake install || die
+ dodoc README
+}
diff --git a/app-benchmarks/pipebench/pipebench-0.40.ebuild b/app-benchmarks/pipebench/pipebench-0.40.ebuild
new file mode 100644
index 000000000000..7b7b9689688b
--- /dev/null
+++ b/app-benchmarks/pipebench/pipebench-0.40.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Measures the speed of stdin/stdout communication"
+HOMEPAGE="http://www.habets.pp.se/synscan/programs.php?prog=pipebench"
+SRC_URI="ftp://ftp.habets.pp.se/pub/synscan/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}" || die "Manual configure failed"
+ cp Makefile Makefile.orig
+ sed \
+ -e "s:CFLAGS=-Wall:CFLAGS=${CFLAGS} -Wall:" \
+ -e "s:/usr/local/bin/:${D}/usr/bin:" \
+ -e "s:/usr/local/man/man1/:${D}/usr/share/man/man1:" \
+ Makefile.orig > Makefile
+}
+
+src_compile() {
+ make || die
+}
+
+src_install() {
+ dodir /usr/{bin,share/man/man1}
+ make install || die
+ dodoc README
+}