summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-07 10:12:30 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-07 10:14:52 -0500
commit34122da674eca50239424be15d895882407c365a (patch)
treeb25291b70fef1b67797725ab4c58ea1a0c5baa50 /app-crypt
parentapp-crypt/acme: 1.9.0 bump (diff)
downloadgentoo-34122da674eca50239424be15d895882407c365a.tar.gz
gentoo-34122da674eca50239424be15d895882407c365a.tar.bz2
gentoo-34122da674eca50239424be15d895882407c365a.zip
app-crypt/certbot: 1.9.0 bump, pytest removal
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/certbot/Manifest1
-rw-r--r--app-crypt/certbot/certbot-1.9.0.ebuild36
-rw-r--r--app-crypt/certbot/certbot-9999.ebuild12
3 files changed, 38 insertions, 11 deletions
diff --git a/app-crypt/certbot/Manifest b/app-crypt/certbot/Manifest
index 840e9863bf61..78ffc8fd6eae 100644
--- a/app-crypt/certbot/Manifest
+++ b/app-crypt/certbot/Manifest
@@ -1,2 +1,3 @@
DIST certbot-1.7.0.tar.gz 1416764 BLAKE2B de678a222e8c8e3e7834470f87763763671bfae37a5c8320a4c1a2552ec979b5391094713e7e13526f73fdf8cd32f70f8c4350f422505892c4fdd0ae77742c80 SHA512 f81242e68b7e261bbb6294ffe92e47bc1687128344816d71a495a94a2646e209e46c147bc76eedce0c477cc140dc6ae0fba76d2d5d01b828fce78875f5a2886a
DIST certbot-1.8.0.tar.gz 1425620 BLAKE2B 9cc0443fd067bf594f02a79c99defa250e656dbee00cd2717a4a747abfe80511ffcb800b6ac63e484a918192dad9465dc45335f358267fa998af16e966b8e2a6 SHA512 c6559fe1e5db6269942bda3738c00b1b550ec448288eaf911ba9c3967c7e949b34bdd8b77742398f0a512ce07929fa2f227c1202e40900151762f1db6ff9de56
+DIST certbot-1.9.0.tar.gz 1425703 BLAKE2B 9bf78824649870b3e1fc3175aae551cbfaa675a8930a89f35ba2330647d86798e4fc43011c617be2d278ab20c43dd05b02e8e61956dd7f9d10d444181874346e SHA512 098d8c077f5760c1f40f7d673820488ad7643c8b9c12561a58921cd95f60ae76515cefc19f822747f3385a68eba6f49fe5484b20142994ef67a26b0b16293ce8
diff --git a/app-crypt/certbot/certbot-1.9.0.ebuild b/app-crypt/certbot/certbot-1.9.0.ebuild
new file mode 100644
index 000000000000..e54440941505
--- /dev/null
+++ b/app-crypt/certbot/certbot-1.9.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{3_6,3_7,3_8})
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+S=${WORKDIR}/${P}/${PN}
+
+inherit distutils-r1
+
+DESCRIPTION="Let's encrypt client to automate deployment of X.509 certificates"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ >=app-crypt/acme-1.8.0[${PYTHON_USEDEP}]
+ >=dev-python/configargparse-0.9.3[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.8[${PYTHON_USEDEP}]
+ >=dev-python/distro-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/josepy-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/parsedatetime-1.3[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
diff --git a/app-crypt/certbot/certbot-9999.ebuild b/app-crypt/certbot/certbot-9999.ebuild
index 8496941da96c..e54440941505 100644
--- a/app-crypt/certbot/certbot-9999.ebuild
+++ b/app-crypt/certbot/certbot-9999.ebuild
@@ -21,11 +21,9 @@ HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="
- >=app-crypt/acme-1.6.0[${PYTHON_USEDEP}]
+ >=app-crypt/acme-1.8.0[${PYTHON_USEDEP}]
>=dev-python/configargparse-0.9.3[${PYTHON_USEDEP}]
dev-python/configobj[${PYTHON_USEDEP}]
>=dev-python/cryptography-2.8[${PYTHON_USEDEP}]
@@ -36,11 +34,3 @@ RDEPEND="
dev-python/pytz[${PYTHON_USEDEP}]
dev-python/zope-component[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # required as deps of deps can trigger this too...
- echo ' ignore:.*collections\.abc:DeprecationWarning' >> ../pytest.ini
- distutils-r1_python_prepare_all
-}