summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSalah Coronya <salah.coronya@gmail.com>2020-09-09 17:22:52 -0500
committerJoonas Niilola <juippis@gentoo.org>2020-10-08 09:43:49 +0300
commit9eb6f4ebf5710b1979b864e81c8d191b7f113ffd (patch)
treee0739dfc76904cae8fe1cee87354e61a7f94bde9 /app-crypt
parentsys-kernel/dracut-crypt-ssh: drop old (diff)
downloadgentoo-9eb6f4ebf5710b1979b864e81c8d191b7f113ffd.tar.gz
gentoo-9eb6f4ebf5710b1979b864e81c8d191b7f113ffd.tar.bz2
gentoo-9eb6f4ebf5710b1979b864e81c8d191b7f113ffd.zip
app-crypt/tpm2-tools: Bump to 4.3.0
Closes: https://bugs.gentoo.org/744436 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Salah Coronya <salah.coronya@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/tpm2-tools/Manifest1
-rw-r--r--app-crypt/tpm2-tools/files/tpm2-tools-4.3.0-Remove-WError.patch12
-rw-r--r--app-crypt/tpm2-tools/tpm2-tools-4.3.0.ebuild42
3 files changed, 55 insertions, 0 deletions
diff --git a/app-crypt/tpm2-tools/Manifest b/app-crypt/tpm2-tools/Manifest
index bb9cff375869..78b6b400522b 100644
--- a/app-crypt/tpm2-tools/Manifest
+++ b/app-crypt/tpm2-tools/Manifest
@@ -1 +1,2 @@
DIST tpm2-tools-4.2.1.tar.gz 879294 BLAKE2B 7619f72f0fe39360f111822b4ec7a0bb90156f295977115c4612efac33059dd786abfa5d5f46a8fcc134fce11d099b03cb7f9ee01aa3addf5a3bb2455e1eb2d4 SHA512 4da103e70880d72a9aa402dea39ea439a0657729af22f08ac7275022c475ab46cb3dd6123d6846669d9b7f8f9af7b3e3df7c3b1d33cd0149b649b7941c84c339
+DIST tpm2-tools-4.3.0.tar.gz 881544 BLAKE2B 0415f30845658e84e97a964abebc3082e45fb880c10bec405cd89c7bfa373ace10b669c4af78e7e47f2d2bb62fc7cc34b2e54e392a95c8f9b8956b8c92af6aee SHA512 4e622bbc8642ba7fd93a7343900560fe3779cba03e363d16f391fc8929724a11913d238e3986de06982cbced27c3c2ca8c7e73d75796407b8646c101ccf393a8
diff --git a/app-crypt/tpm2-tools/files/tpm2-tools-4.3.0-Remove-WError.patch b/app-crypt/tpm2-tools/files/tpm2-tools-4.3.0-Remove-WError.patch
new file mode 100644
index 000000000000..caa3fac23bf4
--- /dev/null
+++ b/app-crypt/tpm2-tools/files/tpm2-tools-4.3.0-Remove-WError.patch
@@ -0,0 +1,12 @@
+diff --git a/configure.ac b/configure.ac
+index 7b5c2196..d07d5433 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -210,7 +210,6 @@ AS_IF([test x"$enable_hardening" != x"no"], [
+
+ add_hardened_c_flag([-Wall])
+ add_hardened_c_flag([-Wextra])
+- add_hardened_c_flag([-Werror])
+
+ add_hardened_c_flag([-Wformat])
+ add_hardened_c_flag([-Wformat-security])
diff --git a/app-crypt/tpm2-tools/tpm2-tools-4.3.0.ebuild b/app-crypt/tpm2-tools/tpm2-tools-4.3.0.ebuild
new file mode 100644
index 000000000000..7ccea9899c4b
--- /dev/null
+++ b/app-crypt/tpm2-tools/tpm2-tools-4.3.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Tools for the TPM 2.0 TSS"
+HOMEPAGE="https://github.com/tpm2-software/tpm2-tools"
+SRC_URI="https://github.com/tpm2-software/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+fapi libressl"
+
+# Integration test are now run as part of the testing suite, which will fail
+# because none of the supported TPM emulators are in Portage. In a future
+# version of tpm2-tools, swtpm will be supported and the tests can be run.
+RESTRICT="test"
+
+RDEPEND="net-misc/curl:=
+ >=app-crypt/tpm2-tss-2.4.0:=[fapi?]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}/${PN}-4.2.1-libressl.patch"
+ "${FILESDIR}/${PN}-4.3.0-Remove-WError.patch"
+)
+
+src_prepare() {
+ eautoreconf
+ default
+}
+
+src_configure() {
+ econf \
+ $(use_enable fapi) \
+ $(use_enable !libressl hardening)
+}