summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-dicts/dictd-wn
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-dicts/dictd-wn')
-rw-r--r--app-dicts/dictd-wn/Manifest2
-rw-r--r--app-dicts/dictd-wn/dictd-wn-1.5-r1.ebuild22
-rw-r--r--app-dicts/dictd-wn/dictd-wn-2.0.ebuild30
-rw-r--r--app-dicts/dictd-wn/metadata.xml5
4 files changed, 59 insertions, 0 deletions
diff --git a/app-dicts/dictd-wn/Manifest b/app-dicts/dictd-wn/Manifest
new file mode 100644
index 000000000000..aa2796802d04
--- /dev/null
+++ b/app-dicts/dictd-wn/Manifest
@@ -0,0 +1,2 @@
+DIST dict-wn-1.5-pre.tar.gz 8464107 SHA256 5c5fc0e7d82332f5e3f1f23e1ea97ea229d129f765f824d61b67be652bd7ed6d SHA512 729ca258bc08a3ff6f8afaf1b42c6575caaacbaaa8684e840f5957390bc7045da14b2ea3d3fa3e8b0f362a727bd88fde0c5d3ea0210bd472c0ff5b50553ba43d WHIRLPOOL bac0473e2c4778f77a6d2e3509a81b7a0796ee2dccf4375bcd38170ca25ab9165d0b457cfee8a023e38c0d141c47b3b144ead7c9b52d3aab47c130240edf1cde
+DIST dict-wn-2.0.tar.gz 8160961 SHA256 db14005b0ba122c2c5994d59b9d25534d8fe9a89d5b2426cad91fbed2a04c266 SHA512 597c788c8300b6942495042b4f24518d44123506a5a71a48cd55411d42c224d267f25ae1f9edc4fc764a0c5ade3ca1defe5657fc8f3b416a284caa42b5a2fede WHIRLPOOL e88810aa8e0a842698db7fd86676497029be6d71df134e0a38407d2a424462ec6f243be5cf4c71d6e48e27c3c861fd835f703bf03986a8ddd1101b53ba869d79
diff --git a/app-dicts/dictd-wn/dictd-wn-1.5-r1.ebuild b/app-dicts/dictd-wn/dictd-wn-1.5-r1.ebuild
new file mode 100644
index 000000000000..fdb26f3231c2
--- /dev/null
+++ b/app-dicts/dictd-wn/dictd-wn-1.5-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+MY_P=${P/td/t}-pre
+DESCRIPTION="WordNet for dict"
+HOMEPAGE="http://www.dict.org/"
+SRC_URI="ftp://ftp.dict.org/pub/dict/pre/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="x86 ppc sparc amd64 ppc64"
+
+DEPEND=">=app-text/dictd-1.5.5"
+
+S=${WORKDIR}
+
+src_install() {
+ insinto /usr/lib/dict
+ doins wn.dict.dz wn.index || die
+}
diff --git a/app-dicts/dictd-wn/dictd-wn-2.0.ebuild b/app-dicts/dictd-wn/dictd-wn-2.0.ebuild
new file mode 100644
index 000000000000..1b56748ad4e0
--- /dev/null
+++ b/app-dicts/dictd-wn/dictd-wn-2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+MY_P=${P/td/t}
+DESCRIPTION="WordNet for dict"
+HOMEPAGE="http://www.dict.org/"
+SRC_URI="ftp://ftp.dict.org/pub/dict/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND=">=app-text/dictd-1.5.5"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf || die "configure failed"
+ emake || die "compile failed"
+ emake db || die "compile database failed"
+}
+
+src_install() {
+ insinto /usr/lib/dict
+ doins wn.dict.dz wn.index || die
+}
diff --git a/app-dicts/dictd-wn/metadata.xml b/app-dicts/dictd-wn/metadata.xml
new file mode 100644
index 000000000000..4538a68724a6
--- /dev/null
+++ b/app-dicts/dictd-wn/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>