summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-02-05 16:59:18 +0200
committerMart Raudsepp <leio@gentoo.org>2020-02-05 17:00:16 +0200
commit03ec9a96f692009ecce61120e6fe5fe268347f02 (patch)
tree88ae1809e83959e5c18dcb56bd06375e22a98700 /app-editors/gnome-latex
parentdev-util/gnome-builder: re-enable spellcheck plugin option (diff)
downloadgentoo-03ec9a96f692009ecce61120e6fe5fe268347f02.tar.gz
gentoo-03ec9a96f692009ecce61120e6fe5fe268347f02.tar.bz2
gentoo-03ec9a96f692009ecce61120e6fe5fe268347f02.zip
app-editors/gnome-latex: bump to 3.32.0
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'app-editors/gnome-latex')
-rw-r--r--app-editors/gnome-latex/Manifest1
-rw-r--r--app-editors/gnome-latex/gnome-latex-3.32.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/app-editors/gnome-latex/Manifest b/app-editors/gnome-latex/Manifest
index 17ca0b6319df..ee292892a3aa 100644
--- a/app-editors/gnome-latex/Manifest
+++ b/app-editors/gnome-latex/Manifest
@@ -1 +1,2 @@
DIST gnome-latex-3.28.1.tar.xz 1082708 BLAKE2B 3b0a341278838b37fb1a54f4f746af4fc6ccf4dd37f6b919f53523acfdcbeb6a8974217260db4d8186b8acd3ba782cbc1ddf1dce20735d70d01c88ed3c1fb90f SHA512 fe5c2456839757237d422d0f0629f11a43a8ca5b3cd86ce94b37ee26f68165f111940d5c3c47adba7be05532c413a97a867219c498abec3fd064122516e0c470
+DIST gnome-latex-3.32.0.tar.xz 1145836 BLAKE2B 3ea44981b90fe258abd05c91c6f7425c73159ce0d3d108659c6be38a4612d5dbdd699cf20fa63b8dd2b2727a00baf6ae6a2b4504c0124e0a756ee7de6130750f SHA512 6b67302327318ccd9d307f271fd84e4cd550883f322d4b0e47b6425d9dd509c96dddeb0e690cca4fffddc1d5ebbc3dfd3e38cbe9985eda520110d9a768ef83d0
diff --git a/app-editors/gnome-latex/gnome-latex-3.32.0.ebuild b/app-editors/gnome-latex/gnome-latex-3.32.0.ebuild
new file mode 100644
index 000000000000..69da54f2a141
--- /dev/null
+++ b/app-editors/gnome-latex/gnome-latex-3.32.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit gnome2
+
+DESCRIPTION="Integrated LaTeX environment for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/GNOME-LaTeX"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection +latexmk rubber"
+
+COMMON_DEPEND="
+ >=app-text/gspell-1.8:0=
+ >=dev-libs/glib-2.56:2
+ >=dev-libs/libgee-0.10:0.8=
+ gnome-base/gsettings-desktop-schemas
+ >=x11-libs/gtk+-3.22:3
+ >=x11-libs/gtksourceview-4.0:4
+ >=gui-libs/tepl-4.2:4
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+ introspection? ( >=dev-libs/gobject-introspection-1.30.0:= )
+ gnome-base/dconf
+"
+RDEPEND="${COMMON_DEPEND}
+ virtual/latex-base
+ x11-themes/hicolor-icon-theme
+ latexmk? ( dev-tex/latexmk )
+ rubber? ( dev-tex/rubber )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.50.1
+ dev-util/itstool
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ --enable-dconf_migration \
+ APPSTREAM_UTIL="$(type -P true)" # Fails strict validation in 3.32.0
+}