summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Tietz <christian.tietz@mailbox.org>2016-03-15 19:48:19 +0100
committerIan Delaney <idella4@gentoo.org>2016-03-16 14:46:16 +0800
commit172d599517ff60cc8c79fa7c3423d01a8818dc13 (patch)
tree93223570cc8bf830f01884f52e5e313884fa8cf1 /app-editors/gummi
parentapp-vim/snipmate: add missing rdeps on tlib and mw-utils (diff)
downloadgentoo-172d599517ff60cc8c79fa7c3423d01a8818dc13.tar.gz
gentoo-172d599517ff60cc8c79fa7c3423d01a8818dc13.tar.bz2
gentoo-172d599517ff60cc8c79fa7c3423d01a8818dc13.zip
app-editors/gummi: bump live ebuild to EAPI 6
Closes: https://github.com/gentoo/gentoo/pull/1062
Diffstat (limited to 'app-editors/gummi')
-rw-r--r--app-editors/gummi/gummi-9999.ebuild27
1 files changed, 18 insertions, 9 deletions
diff --git a/app-editors/gummi/gummi-9999.ebuild b/app-editors/gummi/gummi-9999.ebuild
index d7501cb9a2ce..786b7007eb3b 100644
--- a/app-editors/gummi/gummi-9999.ebuild
+++ b/app-editors/gummi/gummi-9999.ebuild
@@ -1,30 +1,39 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
-inherit autotools base eutils git-r3
+EAPI=6
-EGIT_REPO_URI="https://github.com/alexandervdm/gummi"
+inherit autotools eutils
DESCRIPTION="Simple LaTeX editor for GTK+ users"
-HOMEPAGE="http://gummi.midnightcoding.org"
+HOMEPAGE="https://github.com/alexandervdm/gummi"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/alexandervdm/gummi.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/alexandervdm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
LICENSE="MIT"
SLOT="0"
-KEYWORDS=""
IUSE=""
LANGS="ar ca cs da de el es fr hu it nl pl pt pt_BR ro ru sv zh_CN zh_TW"
for X in ${LANGS} ; do
- IUSE="${IUSE} linguas_${X}"
+ IUSE="${IUSE} +linguas_${X}"
done
-RDEPEND=">=dev-libs/glib-2.16:2
+RDEPEND="
+ dev-libs/glib:2
dev-texlive/texlive-latex
dev-texlive/texlive-latexextra
- >=x11-libs/gtk+-2.16:2"
+ x11-libs/gtk+:2"
+
DEPEND="${RDEPEND}
app-text/gtkspell:2
app-text/poppler[cairo]