summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-08-21 05:36:54 +0200
committerJeroen Roovers <jer@gentoo.org>2015-08-21 05:38:20 +0200
commitd3d74014759cada63b6ed82ebe2a35e947cd6645 (patch)
tree33656da4c1be570bdc24a6fa8e470fb7d6e30d5c /app-editors/hexedit
parentdev-python/pyside-tools: force CMAKE_MAKEFILE_GENERATOR=emake (diff)
downloadgentoo-d3d74014759cada63b6ed82ebe2a35e947cd6645.tar.gz
gentoo-d3d74014759cada63b6ed82ebe2a35e947cd6645.tar.bz2
gentoo-d3d74014759cada63b6ed82ebe2a35e947cd6645.zip
app-editors/hexedit: Fix building against sys-libs/ncurses[tinfo] (bug #558298 by Zoltan Puskas).
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'app-editors/hexedit')
-rw-r--r--app-editors/hexedit/files/hexedit-1.2.13-tinfo.patch10
-rw-r--r--app-editors/hexedit/hexedit-1.2.13.ebuild14
2 files changed, 21 insertions, 3 deletions
diff --git a/app-editors/hexedit/files/hexedit-1.2.13-tinfo.patch b/app-editors/hexedit/files/hexedit-1.2.13-tinfo.patch
new file mode 100644
index 000000000000..86e7dba4e88e
--- /dev/null
+++ b/app-editors/hexedit/files/hexedit-1.2.13-tinfo.patch
@@ -0,0 +1,10 @@
+--- a/configure.in
++++ b/configure.in
+@@ -37,6 +37,7 @@
+ AC_CHECK_LIB(curses, initscr, LIBS="$LIBS -lcurses",
+ AC_CHECK_LIB(ncurses, initscr, LIBS="$LIBS -lncurses")
+ )
++AC_SEARCH_LIBS(nodelay, tinfo)
+ AC_CHECK_FUNC(use_default_colors,
+ AC_DEFINE(HAVE_COLORS, , "Define if you want colored (fruit salad) display option")
+ )
diff --git a/app-editors/hexedit/hexedit-1.2.13.ebuild b/app-editors/hexedit/hexedit-1.2.13.ebuild
index f7a868c8eb8e..f7363a85fa12 100644
--- a/app-editors/hexedit/hexedit-1.2.13.ebuild
+++ b/app-editors/hexedit/hexedit-1.2.13.ebuild
@@ -2,6 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
+EAPI=5
+inherit autotools eutils
+
DESCRIPTION="View and edit files in hex or ASCII"
HOMEPAGE="http://rigaux.org/hexedit.html"
SRC_URI="http://rigaux.org/${P}.src.tgz"
@@ -9,15 +12,20 @@ SRC_URI="http://rigaux.org/${P}.src.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ~mips ppc ppc64 s390 sh sparc x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE=""
DEPEND="sys-libs/ncurses"
RDEPEND="${DEPEND}"
-S="${WORKDIR}/${PN}"
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.2.13-tinfo.patch
+ mv configure.in configure.ac || die
+ eautoreconf
+}
src_install() {
- dobin hexedit || die "dobin failed"
+ dobin hexedit
doman hexedit.1
dodoc Changes
}