summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-editors/jext
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-editors/jext')
-rw-r--r--app-editors/jext/Manifest1
-rw-r--r--app-editors/jext/files/jext-5.0-enum-as-keyword.patch173
-rw-r--r--app-editors/jext/files/jext-pre91
-rw-r--r--app-editors/jext/jext-5.0-r2.ebuild66
-rw-r--r--app-editors/jext/metadata.xml8
5 files changed, 339 insertions, 0 deletions
diff --git a/app-editors/jext/Manifest b/app-editors/jext/Manifest
new file mode 100644
index 000000000000..742562a5a3db
--- /dev/null
+++ b/app-editors/jext/Manifest
@@ -0,0 +1 @@
+DIST jext-sources-5.0.tar.gz 1029772 SHA256 58a6b9d265f622bddba0a6165d582b7eadb2da5d14fd28e1fa1f4af0eaa70d19 SHA512 ac66babfca05d112541e40b0aa8ebde33a69a3a97f42966be24a28232d3c100b9fe8007e26618909fd78111d3eb4ddecc2258599bff40e0e1959ea6632f43682 WHIRLPOOL 7ed2b3b96d378a3b83f61f323fe25fb737600d02a8e701b711b6451b5009ff1fff5f385e3a11b1b3582424ab062627b8a9315ab378c2a5ed487a64e7353625ea
diff --git a/app-editors/jext/files/jext-5.0-enum-as-keyword.patch b/app-editors/jext/files/jext-5.0-enum-as-keyword.patch
new file mode 100644
index 000000000000..c773e571d182
--- /dev/null
+++ b/app-editors/jext/files/jext-5.0-enum-as-keyword.patch
@@ -0,0 +1,173 @@
+--- src/lib/org/gjt/sp/jedit/textarea/InputHandler.java.orig 2015-07-03 17:52:13.843000000 +0000
++++ src/lib/org/gjt/sp/jedit/textarea/InputHandler.java 2015-07-03 17:52:59.746000000 +0000
+@@ -141,10 +141,10 @@
+ */
+ public static String getActionName(ActionListener listener)
+ {
+- Enumeration enum = getActions();
+- while(enum.hasMoreElements())
++ Enumeration myEnum = getActions();
++ while(myEnum.hasMoreElements())
+ {
+- String name = (String)enum.nextElement();
++ String name = (String)myEnum.nextElement();
+ ActionListener _listener = getAction(name);
+ if(_listener == listener)
+ return name;
+--- src/lib/org/jext/options/OptionsDialog.java.orig 2015-07-03 17:54:19.179000000 +0000
++++ src/lib/org/jext/options/OptionsDialog.java 2015-07-03 17:54:33.377000000 +0000
+@@ -297,11 +297,11 @@
+
+ private void addOptionGroup(OptionGroup child, OptionGroup parent)
+ {
+- ArrayList enum = child.getMembers();
++ ArrayList myEnum = child.getMembers();
+
+- for (int i = 0; i < enum.size(); i++)
++ for (int i = 0; i < myEnum.size(); i++)
+ {
+- Object elem = enum.get(i);
++ Object elem = myEnum.get(i);
+
+ if (elem instanceof OptionPane)
+ {
+@@ -669,4 +669,4 @@
+
+ }
+
+-// End of OptionsDialog.java
+\ No newline at end of file
++// End of OptionsDialog.java
+--- src/lib/org/jext/misc/VirtualFolders.java.orig 2015-07-03 17:49:57.731000000 +0000
++++ src/lib/org/jext/misc/VirtualFolders.java 2015-07-03 17:51:11.418000000 +0000
+@@ -233,10 +233,10 @@
+ ret.append(crlf).append("<folderlist>");
+ }
+
+- Enumeration enum = parent.children();
+- while (enum.hasMoreElements())
++ Enumeration myEnum = parent.children();
++ while (myEnum.hasMoreElements())
+ {
+- VirtualFolderNode child = (VirtualFolderNode) enum.nextElement();
++ VirtualFolderNode child = (VirtualFolderNode) myEnum.nextElement();
+ ret.append(toXML(child, depth + 1));
+ }
+
+@@ -317,20 +317,20 @@
+
+ private void fixVisible()
+ {
+- Enumeration enum = root.depthFirstEnumeration();
++ Enumeration myEnum = root.depthFirstEnumeration();
+ VirtualFolderNode node = null;
+- while (enum.hasMoreElements())
++ while (myEnum.hasMoreElements())
+ {
+
+- node = (VirtualFolderNode)enum.nextElement();
++ node = (VirtualFolderNode)myEnum.nextElement();
+ TreePath path = new TreePath(node.getPath());
+ tree.collapsePath(path);
+ }
+
+- enum = root.depthFirstEnumeration();
+- while (enum.hasMoreElements())
++ myEnum = root.depthFirstEnumeration();
++ while (myEnum.hasMoreElements())
+ {
+- node = (VirtualFolderNode)enum.nextElement();
++ node = (VirtualFolderNode)myEnum.nextElement();
+ if (node.shouldBeVisible())
+ {
+ TreePath path = new TreePath(((VirtualFolderNode)node.getParent()).getPath());
+@@ -392,10 +392,10 @@
+ public static boolean folderExists(VirtualFolderNode parent, String name)
+ {
+ boolean exists = false;
+- Enumeration enum = parent.children();
+- while ((enum.hasMoreElements()) && !exists)
++ Enumeration myEnum = parent.children();
++ while ((myEnum.hasMoreElements()) && !exists)
+ {
+- VirtualFolderNode child = (VirtualFolderNode) enum.nextElement();
++ VirtualFolderNode child = (VirtualFolderNode) myEnum.nextElement();
+ exists = child.toString().equals(name);
+ }
+ return exists;
+@@ -526,10 +526,10 @@
+ } else {
+ if (fromMenu)
+ {
+- Enumeration enum = node.children();
+- while (enum.hasMoreElements())
++ Enumeration myEnum = node.children();
++ while (myEnum.hasMoreElements())
+ {
+- VirtualFolderNode child = (VirtualFolderNode) enum.nextElement();
++ VirtualFolderNode child = (VirtualFolderNode) myEnum.nextElement();
+ openNode(child, fromMenu);
+ }
+ }
+--- src/lib/com/microstar/xml/XmlParser.java.orig 2015-07-03 17:41:23.209000000 +0000
++++ src/lib/com/microstar/xml/XmlParser.java 2015-07-03 17:46:30.296000000 +0000
+@@ -1346,7 +1346,7 @@
+ {
+ String name;
+ int type;
+- String enum = null;
++ String myEnum = null;
+
+ // Read the attribute name.
+ name = readNmtoken(true);
+@@ -1358,12 +1358,12 @@
+ // Get the string of enumerated values
+ // if necessary.
+ if (type == ATTRIBUTE_ENUMERATED || type == ATTRIBUTE_NOTATION) {
+- enum = dataBufferToString();
++ myEnum = dataBufferToString();
+ }
+
+ // Read the default value.
+ requireWhitespace();
+- parseDefault(elementName, name, type, enum);
++ parseDefault(elementName, name, type, myEnum);
+ }
+
+
+@@ -1451,7 +1451,7 @@
+ * Parse the default value for an attribute.
+ * [62] Default ::= '#REQUIRED' | '#IMPLIED' | ((%'#FIXED' S)? %AttValue
+ */
+- void parseDefault (String elementName, String name, int type, String enum)
++ void parseDefault (String elementName, String name, int type, String myEnum)
+ throws java.lang.Exception
+ {
+ int valueType = ATTRIBUTE_DEFAULT_SPECIFIED;
+@@ -1477,7 +1477,7 @@
+ value = readLiteral(LIT_CHAR_REF);
+ context = CONTEXT_DTD;
+ }
+- setAttribute(elementName, name, type, enum, value, valueType);
++ setAttribute(elementName, name, type, myEnum, value, valueType);
+ }
+
+
+@@ -2714,7 +2714,7 @@
+ * - int value type
+ * *TODO: do something with attribute types.
+ */
+- void setAttribute (String elName, String name, int type, String enumeration,
++ void setAttribute (String elName, String name, int type, String myEnum,
+ String value, int valueType)
+ throws java.lang.Exception
+ {
+@@ -2736,7 +2736,7 @@
+ attribute[0] = new Integer(type);
+ attribute[1] = value;
+ attribute[2] = new Integer(valueType);
+- attribute[3] = enumeration;
++ attribute[3] = myEnum;
+ attribute[4] = null;
+ attlist.put(name.intern(), attribute);
+
diff --git a/app-editors/jext/files/jext-pre b/app-editors/jext/files/jext-pre
new file mode 100644
index 000000000000..5a02d4b71db8
--- /dev/null
+++ b/app-editors/jext/files/jext-pre
@@ -0,0 +1,91 @@
+# This script launches Jext, the Java text editor.
+# It checks for a $HOME/.jext directory and eventually creates it.
+# Next it checks for a /etc/jextrc and $JEXT_CONFFILE (~/.jext/variables) files which define the JEXT_HOME JAVA_CMD JAVA_OPT CLASSPATH and ToShow variables. The first is system wide(used in RPM install mainly), the second is per user.
+# If this file doesn't exist the script creates it by asking the options to the user.
+
+# Sharpshooter 23/02/2002
+# Blaisorblade 18/11/2002
+
+#For special cases about different config files(for developers with working
+#copy and an unstable one to be tested).
+if [ "$JEXT_CONFFILE" = "" ]
+then
+ JEXT_CONFFILE=~/.jext/variables
+fi
+
+# Help
+if [ "$1" = "--help" -o "$1" = "-h" ]
+then
+ echo "This script launch Jext the Java text editor."
+ echo "Usage : $0 [--reconf] [files]"
+ echo "--reconf doesn't start jext but clears the"
+ echo " $JEXT_CONFFILE file with the settings to start jext"
+ echo " (jext & java location and jext options)."
+ exit 0
+fi
+
+if [ "$1" = "--reconf" ]
+then
+ echo "Clearing $JEXT_CONFFILE, you'll have to reenter jext & java \
+interpreter location"
+ rm -f "$JEXT_CONFFILE"
+ exit 0
+fi
+
+
+# Check for the user's ~/.jext directory.
+if ! [ -d ~/.jext ]
+then
+ echo "It seems you don't have a .jext directory in your home dir."
+ echo "I create it."
+ echo
+ mkdir -p ~/.jext/xinsert
+fi
+
+
+
+# Check for the $HOME/.jext/variables file.
+if ! [ -f $JEXT_CONFFILE -o -f /etc/jextrc ]
+then
+ #Let's add some explaination in the config file.
+ cat >$JEXT_CONFFILE <<EOM
+#This is included when launching Jext. It is a normal shell script \
+used to define env vars
+#Meanings of settings:
+#JEXT_HOME The home dir of jext(under which it finds the lib and so on dirs)
+#JAVA_CMD The complete path for the java command
+#JAVA_OPT The options to be passed to the java command(not to Jext itself!)
+#CLASSPATH The extra classpath to be specified(for cases such as AntWork plugin)
+#ToShow If this is set to y the output is not redirected to /dev/null;
+# Mainly for developers who want to trace Jext output(you could also use
+# the DickTracy plugin).
+EOM
+#----
+ JEXT_HOME="/usr/share/jext/lib"
+ echo "JEXT_HOME="$JEXT_HOME >> $JEXT_CONFFILE
+#----
+ ToShow=
+ echo "ToShow="$ToShow>>$JEXT_CONFFILE
+fi
+
+# Extract the contents of the $JEXT_CONFFILE file.
+[ -f /etc/jextrc ] && source /etc/jextrc
+[ -f $JEXT_CONFFILE ] && source $JEXT_CONFFILE
+
+#Needed to make Jext find his plugins(it searches them in `pwd`/plugins)
+for i in $@
+do
+ if [ "${i:0:1}" != "/" -a "${i:0:1}" != "-" ]; then #If the first char of $i is not a / then
+ files="$files `pwd`/$i" #it is a relative path so we must make it absolute.
+ elif [ "$i" != "-" ]; then
+ files="$files $i"
+ else
+ case "$i" in
+ --reconf|--help|-h)
+ ;;
+ *)
+ files="$files $i"
+ ;;
+ esac
+ fi
+done
diff --git a/app-editors/jext/jext-5.0-r2.ebuild b/app-editors/jext/jext-5.0-r2.ebuild
new file mode 100644
index 000000000000..2b334c4fea92
--- /dev/null
+++ b/app-editors/jext/jext-5.0-r2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc"
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A text editor written in Java"
+HOMEPAGE="http://sourceforge.net/projects/jext/"
+MY_PV="${PV/_}"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-sources-${MY_PV}.tar.gz"
+LICENSE="|| ( GPL-2 JPython )"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+CDEPEND="dev-java/jython:2.7
+ dev-java/jgoodies-looks:1.2
+ dev-java/gnu-regexp:1"
+DEPEND=">=virtual/jdk-1.6
+ ${CDEPEND}"
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+
+S="${WORKDIR}/${PN}-src-${MY_PV}"
+
+# Necessary otherwise it chokes on compiling with jdk-1.8
+# due to unmappable characters.
+JAVA_ANT_ENCODING="ISO-8859-1"
+
+java_prepare() {
+ # bundles some com.microstar.xml who knows what's that
+ # also com.jgoodies.uif_lite which is apparently some jgoodies-looks
+ # example code which we don't package and there is probably no point
+ rm -v "${S}"/extplugins/Admin/*.jar || die
+ rm -rf src/lib/gnu || die
+
+ # Fix "enum as a keyword" error.
+ epatch "${FILESDIR}"/"${P}"-enum-as-keyword.patch
+}
+
+src_compile() {
+ cd "${S}/src" || die
+ eant jar $(use_doc javadocs) \
+ -Dclasspath="$(java-pkg_getjars jython-2.7,jgoodies-looks-1.2,gnu-regexp-1)"
+}
+
+src_install () {
+ java-pkg_newjar lib/${P}.jar
+ java-pkg_dojar lib/dawn*.jar
+
+ java-pkg_dolauncher ${PN} \
+ --main org.jext.Jext \
+ --java_args '-Dpython.path=$(java-config --classpath=jython-2.7)' \
+ -pre "${FILESDIR}/${PN}-pre"
+
+ if use doc; then
+ java-pkg_dohtml -r docs/api
+ fi
+}
+
+pkg_postinst() {
+ elog "Plugins are currently not built/installed. Patches welcome."
+}
diff --git a/app-editors/jext/metadata.xml b/app-editors/jext/metadata.xml
new file mode 100644
index 000000000000..bf4c75acc9b5
--- /dev/null
+++ b/app-editors/jext/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="sourceforge">jext</remote-id>
+ </upstream>
+</pkgmetadata>