summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2020-03-22 12:58:39 +0100
committerAmy Liffey <amynka@gentoo.org>2020-03-22 13:24:16 +0100
commit1d2ca24f2e6b5fa3844e4aac809026f5966ca4fa (patch)
tree925bee3400de310b24be97414c591ae0f1751cf3 /app-editors
parentdev-python/stripe: Version bumps (diff)
downloadgentoo-1d2ca24f2e6b5fa3844e4aac809026f5966ca4fa.tar.gz
gentoo-1d2ca24f2e6b5fa3844e4aac809026f5966ca4fa.tar.bz2
gentoo-1d2ca24f2e6b5fa3844e4aac809026f5966ca4fa.zip
app-editors/nedit: fix sed to use pipes
Closes: https://bugs.gentoo.org/711408 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Amy Liffey <amynka@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/nedit/nedit-5.7.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/app-editors/nedit/nedit-5.7.ebuild b/app-editors/nedit/nedit-5.7.ebuild
index 69f74a487102..25f9ab97f1db 100644
--- a/app-editors/nedit/nedit-5.7.ebuild
+++ b/app-editors/nedit/nedit-5.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -35,16 +35,16 @@ src_prepare() {
#respecting LDFLAGS, bug #208189
default
sed \
- -e "s:bin/:${EPREFIX}/bin/:g" \
+ -e "s|bin/|${EPREFIX}/bin/|g" \
-i Makefile source/preferences.c source/help_data.h source/nedit.c Xlt/Makefile || die
sed \
- -e "s:nc:neditc:g" -i doc/nc.pod || die
- sed -i -e "s:CFLAGS=-O:CFLAGS=${CFLAGS}:" -e "s:check_tif_rule::" \
+ -e "s|nc|neditc|g" -i doc/nc.pod || die
+ sed -i -e "s|CFLAGS=-O|CFLAGS=${CFLAGS}|" -e "s|check_tif_rule||" \
makefiles/Makefile.linux || die
- sed -i -e "s:CFLAGS=-O:CFLAGS=${CFLAGS}:" \
- -e "s:MOTIFDIR=/usr/local:MOTIFDIR=${EPREFIX}/usr:" \
- -e "s:-lX11:-lX11 -lXmu -liconv:" \
- -e "s:check_tif_rule::" \
+ sed -i -e "s|CFLAGS=-O|CFLAGS=${CFLAGS}|" \
+ -e "s|MOTIFDIR=/usr/local|MOTIFDIR=${EPREFIX}/usr|" \
+ -e "s|-lX11|-lX11 -lXmu -liconv|" \
+ -e "s|check_tif_rule||" \
makefiles/Makefile.macosx || die
}