summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-11-23 18:23:55 +0100
committerUlrich Müller <ulm@gentoo.org>2018-11-23 18:25:12 +0100
commit91028af7c0b3f200076ab579f798c5826513eae4 (patch)
tree2a16d763d6f8b7fb92f3097e1e796ea549bcbc53 /app-editors
parentnet-misc/olsrd: Fix configuration warning in init script (diff)
downloadgentoo-91028af7c0b3f200076ab579f798c5826513eae4.tar.gz
gentoo-91028af7c0b3f200076ab579f798c5826513eae4.tar.bz2
gentoo-91028af7c0b3f200076ab579f798c5826513eae4.zip
app-editors/fe: Fix compilation with ncurses[tinfo].
Closes: https://bugs.gentoo.org/671714 Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/fe/fe-2.0.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/app-editors/fe/fe-2.0.ebuild b/app-editors/fe/fe-2.0.ebuild
index 9e1866c107ce..ca6658d94079 100644
--- a/app-editors/fe/fe-2.0.ebuild
+++ b/app-editors/fe/fe-2.0.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit toolchain-funcs
+
DESCRIPTION="A small and easy to use folding editor"
HOMEPAGE="http://www.moria.de/~michael/fe/"
SRC_URI="http://www.moria.de/~michael/fe/${P}.tar.gz"
@@ -15,11 +17,14 @@ IUSE="sendmail"
RDEPEND="sys-libs/ncurses:0=
sendmail? ( virtual/mta )"
DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
PATCHES=("${FILESDIR}"/${PN}-1.8-makefile.patch)
src_configure() {
- econf $(use_enable sendmail)
+ econf \
+ $(use_enable sendmail) \
+ LIBS="$("$(tc-getPKG_CONFIG)" --libs ncurses)"
}
src_install() {