summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-11-24 11:17:03 +0100
committerUlrich Müller <ulm@gentoo.org>2018-11-24 11:18:09 +0100
commita65a65fe4cac854ecfbf5fcbd6591459810e4cda (patch)
treeb92b7ef45256179844876275d3127fec062f7faa /app-emacs/auto-complete
parentapp-emacs/popup: Initial import. (diff)
downloadgentoo-a65a65fe4cac854ecfbf5fcbd6591459810e4cda.tar.gz
gentoo-a65a65fe4cac854ecfbf5fcbd6591459810e4cda.tar.bz2
gentoo-a65a65fe4cac854ecfbf5fcbd6591459810e4cda.zip
app-emacs/auto-complete: Version bump.
Thanks to <thomas@famsim.de>. Closes: https://bugs.gentoo.org/670926 Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/auto-complete')
-rw-r--r--app-emacs/auto-complete/Manifest1
-rw-r--r--app-emacs/auto-complete/auto-complete-1.5.1.ebuild40
-rw-r--r--app-emacs/auto-complete/metadata.xml7
3 files changed, 47 insertions, 1 deletions
diff --git a/app-emacs/auto-complete/Manifest b/app-emacs/auto-complete/Manifest
index 598b1d8345d3..d6358929d63d 100644
--- a/app-emacs/auto-complete/Manifest
+++ b/app-emacs/auto-complete/Manifest
@@ -1 +1,2 @@
DIST auto-complete-1.3.1.tar.bz2 155081 BLAKE2B 7ceedcececcd80b7d8207cb2ff88f2bbfeee892d56a96f44c6929323ca974206b6d977830a8593ba9f7c87ba86914bf9a0771f5e11a284d7bb42fdd9e9985b48 SHA512 5b82120f8faf1ee4ff139f4fbacb894fa0bf617b9a0aaebb5a0d672a6f90cb01bc35f0c99cebe2bef55cb7a6af6ce03936a7226c89e3c79248aacf4ae554fb7b
+DIST auto-complete-1.5.1.tar.gz 196709 BLAKE2B 1593a6c0b60d9cb25a9597b7283d741042f79d0227c3865386a5d74e03d216a7e96ba7304e23148ac6bd18deb30f36777b88c4b3227b7482f28a224fd027b7b9 SHA512 e01a99d5e393d1d2309d6c616b4af34e8f3f2c585eaefad602ba5b6cf1890a18e851fd58804c4a6669c8131e9e7a5470c7aa650583a0bc1a2298875f7181614e
diff --git a/app-emacs/auto-complete/auto-complete-1.5.1.ebuild b/app-emacs/auto-complete/auto-complete-1.5.1.ebuild
new file mode 100644
index 000000000000..e6e662ea615f
--- /dev/null
+++ b/app-emacs/auto-complete/auto-complete-1.5.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp
+
+DESCRIPTION="Auto-complete package"
+HOMEPAGE="https://github.com/auto-complete/auto-complete/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+ FDL-1.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="app-emacs/popup"
+BDEPEND="${RDEPEND}
+ doc? ( app-text/pandoc )"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ use doc && emake -C doc
+}
+
+src_install() {
+ elisp_src_install
+
+ # install dictionaries
+ insinto "${SITEETC}/${PN}"
+ doins -r dict
+
+ dodoc README.md TODO.md etc/test.txt
+ if use doc; then
+ docinto html
+ dodoc doc/manual.html doc/changes.html doc/style.css doc/*.png
+ fi
+}
diff --git a/app-emacs/auto-complete/metadata.xml b/app-emacs/auto-complete/metadata.xml
index c09261b152ee..e4ba41af832e 100644
--- a/app-emacs/auto-complete/metadata.xml
+++ b/app-emacs/auto-complete/metadata.xml
@@ -5,8 +5,13 @@
<email>gnu-emacs@gentoo.org</email>
<name>Gentoo GNU Emacs project</name>
</maintainer>
+<longdescription>
+ Auto-Complete is an intelligent auto-completion extension for Emacs.
+ It extends the standard Emacs completion interface and provides an
+ environment that allows users to concentrate more on their own work.
+</longdescription>
<stabilize-allarches/>
<upstream>
- <remote-id type="github">m2ym/auto-complete</remote-id>
+ <remote-id type="github">auto-complete/auto-complete</remote-id>
</upstream>
</pkgmetadata>