summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/ecb
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/ecb')
-rw-r--r--app-emacs/ecb/Manifest1
-rw-r--r--app-emacs/ecb/ecb-2.41_pre20140215-r1.ebuild52
-rw-r--r--app-emacs/ecb/files/70ecb-gentoo.el2
-rw-r--r--app-emacs/ecb/files/ecb-2.32-gentoo.patch73
-rw-r--r--app-emacs/ecb/metadata.xml32
5 files changed, 160 insertions, 0 deletions
diff --git a/app-emacs/ecb/Manifest b/app-emacs/ecb/Manifest
new file mode 100644
index 000000000000..77fe417c4b4d
--- /dev/null
+++ b/app-emacs/ecb/Manifest
@@ -0,0 +1 @@
+DIST ecb-2.41_pre20140215.tar.xz 565404 SHA256 f3103afd4324cfd1c50bf4c1d6a6d52d94af192b1f4c8665a91c87929b0635a2 SHA512 bf87bdd38e7ddaeec044fc56d56f7c456ef0a1922f50b962f932bf739895f046387bab7a934439e749fd7e838d9f742938408f4f9cb47079440abd8c1ba181b6 WHIRLPOOL a1906bc4cad119959d76a5e3d79c97fba9d302eeea67e86bc597af449a6b6b2efb7053c4a9251502f35f571b7d69e557b6b9d7a52a11f4e69348e83649d2433c
diff --git a/app-emacs/ecb/ecb-2.41_pre20140215-r1.ebuild b/app-emacs/ecb/ecb-2.41_pre20140215-r1.ebuild
new file mode 100644
index 000000000000..0247192d61d5
--- /dev/null
+++ b/app-emacs/ecb/ecb-2.41_pre20140215-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit readme.gentoo elisp eutils
+
+DESCRIPTION="Source code browser for Emacs"
+HOMEPAGE="http://ecb.sourceforge.net/"
+# snapshot of https://github.com/alexott/ecb.git, created with "make distrib"
+SRC_URI="http://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="java"
+
+DEPEND="!!<app-emacs/cedet-2.0
+ java? ( app-emacs/jde )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-${PV%_*}"
+SITEFILE="70${PN}-gentoo.el"
+DOC_CONTENTS="ECB is autoloaded in site-gentoo.el. Add the line
+ \n\t(require 'ecb)
+ \nto your ~/.emacs file to enable all features on Emacs startup."
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.32-gentoo.patch"
+ sed -i -e "s:@PF@:${PF}:" ecb-help.el || die "sed failed"
+}
+
+src_compile() {
+ local loadpath="" sl=${EPREFIX}${SITELISP}
+ if use java; then
+ loadpath="${sl}/elib ${sl}/jde ${sl}/jde/lisp"
+ fi
+
+ emake LOADPATH="${loadpath}"
+}
+
+src_install() {
+ elisp_src_install
+
+ insinto "${SITEETC}/${PN}"
+ doins -r ecb-images
+
+ doinfo info-help/ecb.info*
+ dohtml html-help/*.html
+ dodoc NEWS README RELEASE_NOTES
+}
diff --git a/app-emacs/ecb/files/70ecb-gentoo.el b/app-emacs/ecb/files/70ecb-gentoo.el
new file mode 100644
index 000000000000..bc71f7c18e94
--- /dev/null
+++ b/app-emacs/ecb/files/70ecb-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(require 'ecb-autoloads)
diff --git a/app-emacs/ecb/files/ecb-2.32-gentoo.patch b/app-emacs/ecb/files/ecb-2.32-gentoo.patch
new file mode 100644
index 000000000000..09d3d86afdcd
--- /dev/null
+++ b/app-emacs/ecb/files/ecb-2.32-gentoo.patch
@@ -0,0 +1,73 @@
+Change default paths to Gentoo install locations.
+Allow for compressed Info files.
+
+--- ecb-2.32-orig/ecb-common-browser.el 2005-07-11 16:16:01.000000000 +0200
++++ ecb-2.32/ecb-common-browser.el 2009-03-03 09:42:51.000000000 +0100
+@@ -261,10 +261,7 @@
+ ;; additonal images are necessary - but currently i don't think we need
+ ;; special images for this analyse-stuff.
+ (defcustom ecb-tree-image-icons-directories
+- (let ((base (concat (if ecb-regular-xemacs-package-p
+- (format "%s" (locate-data-directory "ecb"))
+- ecb-ecb-dir)
+- "ecb-images/")))
++ (let ((base "/usr/share/emacs/etc/ecb/ecb-images/"))
+ (cons (concat base "default/height-17")
+ (mapcar (function (lambda (i)
+ (cons (car i) (concat base (cdr i)))))
+--- ecb-2.32-orig/ecb-help.el 2005-07-11 16:16:00.000000000 +0200
++++ ecb-2.32/ecb-help.el 2009-03-03 09:47:49.000000000 +0100
+@@ -81,16 +81,8 @@
+ (const :tag "Html" :value html)))
+
+
+-(defcustom ecb-help-info-path (concat
+- (if ecb-running-xemacs
+- (if (file-exists-p
+- (concat ecb-ecb-dir
+- ecb-help-info-subdir
+- ecb-help-info-start-file))
+- ecb-help-info-subdir
+- "../../info/")
+- ecb-help-info-subdir)
+- ecb-help-info-start-file)
++(defcustom ecb-help-info-path
++ (concat "/usr/share/info/" ecb-help-info-start-file)
+ "*Path where the ECB online help in info format resides.
+ This must be the location of the file \"ecb.info\" which comes with the ECB
+ distribution. If is installed by unpacking the archive available on the ECB
+@@ -107,24 +99,7 @@
+ :type 'file)
+
+ (defcustom ecb-help-html-path
+- (if (not ecb-running-xemacs)
+- (concat ecb-help-html-subdir ecb-help-html-start-file)
+- (cond ((file-exists-p
+- (concat ecb-ecb-dir
+- ecb-help-html-subdir
+- ecb-help-html-start-file))
+- (concat ecb-help-html-subdir ecb-help-html-start-file))
+- ((file-exists-p
+- (concat ecb-ecb-dir
+- "../../html/"
+- ecb-help-html-start-file))
+- (concat "../../html/" ecb-help-html-start-file))
+- ((file-exists-p
+- (concat ecb-ecb-dir
+- "../../html/ecb/index.html"))
+- "../../html/ecb/index.html")
+- (t
+- (concat "../../etc/ecb/html/" ecb-help-html-start-file))))
++ (concat "/usr/share/doc/@PF@/html/" ecb-help-html-start-file)
+ "*Path where the ECB online help in HTML format resides.
+ This must be the location of the file \"index.html\" which comes with the ECB
+ distribution. If is installed by unpacking the archive available on the ECB
+@@ -145,7 +120,7 @@
+ "Starts `info' with INFO-FILE. If INFO-FILE does not exists then nil is
+ returned otherwise true. If NO-FILE-NOT-EXIST-ERR is not nil then just nil is
+ returned if INFO-FILE does not exist otherwise an error is reported."
+- (if (file-exists-p info-file)
++ (if (file-expand-wildcards (concat info-file "*"))
+ (prog1 t
+ (info info-file))
+ (unless no-file-not-exist-err
diff --git a/app-emacs/ecb/metadata.xml b/app-emacs/ecb/metadata.xml
new file mode 100644
index 000000000000..4858374f9d5b
--- /dev/null
+++ b/app-emacs/ecb/metadata.xml
@@ -0,0 +1,32 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<longdescription>
+ ECB stands for "Emacs Code Browser". While Emacs already has good editing
+ support for many modes, its browsing support is somewhat lacking. That's
+ where ECB comes in: it displays a number of informational windows that allow
+ for easy source code navigation and overview.
+
+ The informational windows can contain:
+
+ * A directory tree,
+ * a list of source files in the current directory,
+ * a list of functions/classes/methods/... in the current file, (ECB uses
+ the Semantic Bovinator, or Imenu, or etags, for getting this list so all
+ languages supported by any of these tools are automatically supported by
+ ECB too),
+ * a history of recently visited files,
+ * the Speedbar and
+ * output from compilation (the compilation window) and other modes like
+ help, grep etc. or whatever a user defines to be displayed in this
+ window.
+
+ As an added bonus, ECB makes sure to keep these informational windows
+ visible, even when you use C-x 1 and similar commands.
+
+ It goes without saying that you can configure the layout, ie. which
+ informational windows should be displayed where. ECB comes with a number of
+ ready-made window layouts to choose from.
+</longdescription>
+</pkgmetadata>