summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-10-16 18:58:22 +0200
committerUlrich Müller <ulm@gentoo.org>2019-10-16 18:58:50 +0200
commit9c97c4736da82746a53d21840cda5de48bd7f294 (patch)
tree2b8e8914aec4c56316a6c6b7e834d9b70d28d4ee /app-emacs/psgml
parentapp-emacs/pymacs: Bump to version 0.26. (diff)
downloadgentoo-9c97c4736da82746a53d21840cda5de48bd7f294.tar.gz
gentoo-9c97c4736da82746a53d21840cda5de48bd7f294.tar.bz2
gentoo-9c97c4736da82746a53d21840cda5de48bd7f294.zip
app-emacs/psgml: Bump to version 1.4.1.
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/psgml')
-rw-r--r--app-emacs/psgml/Manifest1
-rw-r--r--app-emacs/psgml/metadata.xml3
-rw-r--r--app-emacs/psgml/psgml-1.4.1.ebuild32
3 files changed, 33 insertions, 3 deletions
diff --git a/app-emacs/psgml/Manifest b/app-emacs/psgml/Manifest
index 982ef25d8889..c026b891c580 100644
--- a/app-emacs/psgml/Manifest
+++ b/app-emacs/psgml/Manifest
@@ -1 +1,2 @@
DIST psgml-1.4.0.tar.gz 262246 BLAKE2B e888e7e13b39108efd19bbce41f3630015556ca9e5250665456866173302b5388add506694f28a6fa7e4e4572ce4596eec66762650f7203a14d84fcfbcd8ac7f SHA512 99bab6440a0f437009edff6371412c16f47d48c6b1eaa5b894523130e3a8d604ea79dc81f1895ceecd4283d0c7fd908d4e5bdeace63e54b9ac048a80fc0f6f44
+DIST psgml-1.4.1.tar.xz 200512 BLAKE2B d2bad3e5e1d9e45f6327c064806a5c9eddc49d513bf04a0017ea3de865c3acbaec8b0b188860b4a6b435097f69e445ac92250b00b339212530cf0a7c8762b907 SHA512 bd73668341fc27dc1cecb67e4114bdb728512a35b6c834c5ad57efe4e6f3c5e0f83f9d87c55bb959cd0d9e2ec74d15d0e0ea786095bc834246e0cee646761681
diff --git a/app-emacs/psgml/metadata.xml b/app-emacs/psgml/metadata.xml
index e3cf9243cef1..c918cdef9591 100644
--- a/app-emacs/psgml/metadata.xml
+++ b/app-emacs/psgml/metadata.xml
@@ -6,7 +6,4 @@
<name>Gentoo GNU Emacs project</name>
</maintainer>
<stabilize-allarches/>
-<upstream>
- <remote-id type="sourceforge">psgml</remote-id>
-</upstream>
</pkgmetadata>
diff --git a/app-emacs/psgml/psgml-1.4.1.ebuild b/app-emacs/psgml/psgml-1.4.1.ebuild
new file mode 100644
index 000000000000..465c0edee1d9
--- /dev/null
+++ b/app-emacs/psgml/psgml-1.4.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp
+
+DESCRIPTION="A GNU Emacs Major Mode for editing SGML and XML coded documents"
+HOMEPAGE="https://www.emacswiki.org/emacs/PsgmlMode"
+# taken from https://marmalade-repo.org/packages/${P}.tar
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2+ Texinfo-manual"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="app-text/openjade"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ ${EMACS} ${EMACSFLAGS} --load psgml-maint.el -f psgml-compile-files || die
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ insinto "${SITEETC}/${PN}"
+ doins *.map
+ doinfo psgml.info psgml-api.info
+ dodoc ChangeLog INSTALL README.psgml psgml.ps
+}