summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <william.hubbs@sony.com>2020-02-12 15:32:33 -0600
committerWilliam Hubbs <williamh@gentoo.org>2020-02-12 15:34:46 -0600
commit4aaeab90759e78c4c79b8ee4d04557033c00c465 (patch)
treeaf01378a3ecbba69f78323d34352f9642fb9191c /app-emulation/cri-o
parentapp-emulation/cri-o: 1.16.3 bump (diff)
downloadgentoo-4aaeab90759e78c4c79b8ee4d04557033c00c465.tar.gz
gentoo-4aaeab90759e78c4c79b8ee4d04557033c00c465.tar.bz2
gentoo-4aaeab90759e78c4c79b8ee4d04557033c00c465.zip
app-emulation/cry-o: 1.17.0 bump
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-emulation/cri-o')
-rw-r--r--app-emulation/cri-o/Manifest1
-rw-r--r--app-emulation/cri-o/cri-o-1.17.0.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/app-emulation/cri-o/Manifest b/app-emulation/cri-o/Manifest
index 26a040d9ef62..09b553029755 100644
--- a/app-emulation/cri-o/Manifest
+++ b/app-emulation/cri-o/Manifest
@@ -3,3 +3,4 @@ DIST cri-o-1.13.9.tar.gz 6685519 BLAKE2B 5d9e68c7a0ae532e2406e5e47562693cddbc34a
DIST cri-o-1.15.1.tar.gz 11811389 BLAKE2B 2f6e223e2d3964f480e9739ee4808101ae2ca8c0a16eb589d2e3501d370c60694843309b602a4a4b8e16ed97094f97c81ff4f23b542a9536b38f9fe9a97bcd97 SHA512 2b9122692d84e8a6832d7172782c41d354185809cd3fa999951485f8df8fd1750dd15b2005fbb3bc422f5199daeb32a768e824402c9e95f25593e250bd7ecc07
DIST cri-o-1.15.2.tar.gz 11861335 BLAKE2B 159bdf322540c3d49f44b1fc1106d1717706f7817e4621743078dfbb5d9088318d7dda5da54ff94ed43ea58204413d496ffda424ea94ed6fd0c6e090bbba37f0 SHA512 d30a27d98537cd73bf341267922b94434958bf5e5d3a26de3af2b7899fd9d860be12a194531f81fb704abed79eac1c5139271fab1e52b994b939dafab00f1cfd
DIST cri-o-1.16.3.tar.gz 12274620 BLAKE2B e297996184e765a89cc68adbb531eb249ad74804b05d233b4730fe56cb530e2d6d7f44ecf6939730a055acff43b0bdec13fd40583fcf003740e6dacc9770d868 SHA512 cf3d8748696e14a9fe7bb1f4e4ed5532a84367e1de42da89e1c85c33f249525a42000c74445b1f6859099a43d4076c4078efe5990a7e663795121d54d1ee1354
+DIST cri-o-1.17.0.tar.gz 10528650 BLAKE2B ba1240e602be576eb74bd9dd0c7b5d0ae3c78172902c74725ce3b85b90c739a79cf260b9ab441bc632eba85951ff1968a946824dd20849bb9ccae268b76e3fec SHA512 08b1ede35d44dd72f7a20ef02e3d27198d349d05b3fd41fc319bfba44dafdaf1843c1a6b04cd4d07ad80b5d2022376a8173b7459658a3c22011970561a1af308
diff --git a/app-emulation/cri-o/cri-o-1.17.0.ebuild b/app-emulation/cri-o/cri-o-1.17.0.ebuild
new file mode 100644
index 000000000000..e5cd2811c967
--- /dev/null
+++ b/app-emulation/cri-o/cri-o-1.17.0.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_COMMIT=6d0ffae63b9b7d8f07e7f9cf50736a67fb31faf3
+
+inherit go-module
+
+DESCRIPTION="OCI-based implementation of Kubernetes Container Runtime Interface"
+HOMEPAGE="https://cri-o.io/"
+SRC_URI="https://github.com/cri-o/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="btrfs +device-mapper selinux systemd"
+
+COMMON_DEPEND="
+ app-crypt/gpgme:=
+ app-emulation/conmon
+ app-emulation/runc
+ dev-libs/glib:=
+ dev-libs/libassuan:=
+ dev-libs/libgpg-error:=
+ net-firewall/conntrack-tools
+ net-firewall/iptables
+ net-misc/cni-plugins
+ net-misc/socat
+ sys-apps/iproute2
+ sys-libs/libseccomp:=
+ btrfs? ( sys-fs/btrfs-progs )
+ device-mapper? ( sys-fs/lvm2:= )
+ selinux? ( sys-libs/libselinux:= )
+ systemd? ( sys-apps/systemd:= )"
+DEPEND="
+ ${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}
+ !<app-emulation/libpod-1.3.2-r1"
+
+src_prepare() {
+ default
+
+ sed -e '/^GIT_.*/d' \
+ -e '/ git diff --exit-code/d' \
+ -e 's/$(GO) build -i/$(GO) build -v -work -x/' \
+ -e 's/\${GIT_COMMIT}/'${EGIT_COMMIT}'/' \
+ -e "s|^GIT_COMMIT := .*|GIT_COMMIT := ${EGIT_COMMIT}|" \
+ -e "s|^COMMIT_NO := .*|COMMIT_NO := ${EGIT_COMMIT}|" \
+ -i Makefile || die
+
+ echo ".NOTPARALLEL: binaries docs" >> Makefile || die
+
+ sed -e 's:/usr/local/bin:/usr/bin:' \
+ -i contrib/systemd/* || die
+}
+
+src_compile() {
+ [[ -f hack/btrfs_installed_tag.sh ]] || die
+ use btrfs || { echo -e "#!/bin/sh\necho exclude_graphdriver_btrfs" > \
+ hack/btrfs_installed_tag.sh || die; }
+
+ [[ -f hack/libdm_installed.sh ]] || die
+ use device-mapper || { echo -e "#!/bin/sh\necho exclude_graphdriver_devicemapper" > \
+ hack/libdm_installed.sh || die; }
+
+ [[ -f hack/selinux_tag.sh ]] || die
+ use selinux || { echo -e "#!/bin/sh\ntrue" > \
+ hack/selinux_tag.sh || die; }
+
+ mkdir -p bin || die
+ GOBIN="${S}/bin" \
+ emake all
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${D}${EPREFIX}/usr" install install.config install.systemd
+
+ keepdir /etc/crio
+ mv "${ED}/etc/crio/crio.conf"{,.example} || die
+
+ newinitd "${FILESDIR}/crio.initd" crio
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotated" "${PN}"
+
+ # Suppress crio log error messages triggered if these don't exist.
+ keepdir /etc/containers/oci/hooks.d
+ keepdir /usr/share/containers/oci/hooks.d
+
+ # Suppress crio "Missing CNI default network" log message.
+ keepdir /etc/cni/net.d
+ insinto /etc/cni/net.d
+ doins contrib/cni/99-loopback.conf
+}