summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2019-05-01 15:24:12 -0700
committerZac Medico <zmedico@gentoo.org>2019-05-01 15:27:12 -0700
commit69a0e83bf709b07c170da026e1f4cf5ee09d950d (patch)
tree8c576a353d01347ffc1d52a5ce06a0d0971edf21 /app-emulation/cri-o
parentwww-apps/netbox: remove 2.5.10 (diff)
downloadgentoo-69a0e83bf709b07c170da026e1f4cf5ee09d950d.tar.gz
gentoo-69a0e83bf709b07c170da026e1f4cf5ee09d950d.tar.bz2
gentoo-69a0e83bf709b07c170da026e1f4cf5ee09d950d.zip
app-emulation/cri-o: version bump to 1.13.7
Reported-by: Bruce Guenter <bruce@untroubled.org> Closes: https://bugs.gentoo.org/684898 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-emulation/cri-o')
-rw-r--r--app-emulation/cri-o/Manifest1
-rw-r--r--app-emulation/cri-o/cri-o-1.13.7.ebuild112
2 files changed, 113 insertions, 0 deletions
diff --git a/app-emulation/cri-o/Manifest b/app-emulation/cri-o/Manifest
index cb7d987023a3..fd856a5b0ce7 100644
--- a/app-emulation/cri-o/Manifest
+++ b/app-emulation/cri-o/Manifest
@@ -1,2 +1,3 @@
DIST cri-o-1.10.6.tar.gz 5161858 BLAKE2B bbfaf60c92dee3a9f42e9d4fc9b5482057a7a0ff2de36d74d434e2e60b53f92f70980c83825c18089c4a48bfa01c164b77aa01506c68c763f00265796e07d367 SHA512 b6a412cf5859dab79095732c2528e2ba373b3c21740203441fd3646862e2458e78e71f1895a5def05207964ef96a354c04395356e426600994bb39d3adfd0894
DIST cri-o-1.13.5.tar.gz 6683259 BLAKE2B 982de5590411ad618401a2909dcd4f0404d5bfc49667027e29fd266e3e2d15bbf0d7716db570d433eec7f2baacbb33f7e9e0f347aa2ef964a06b8b883f76404c SHA512 116e51e9b31fca66b4edd9aac5d1f0c8929ba9a740af8b611fb7fa0e675e37facd4114d0848090b32f72f58d17c85060c15e07bee82098d83a0bd5b563f4c875
+DIST cri-o-1.13.7.tar.gz 6657183 BLAKE2B 8073211bb188bf6a03615fe5d3f931d45dee09bb506316e80c6b0914d3b798e77e194d6f31e74e314406af28c4a882e45250f8c6792c82d9b0e3cceb0750cf1a SHA512 5056f26decc96798738aa67350b0d7353ac025518c82e2591f4541284bbc3620976a97dcc805429adc748131f38d13edcdb77c3b6f1ba6b93f672637437acb10
diff --git a/app-emulation/cri-o/cri-o-1.13.7.ebuild b/app-emulation/cri-o/cri-o-1.13.7.ebuild
new file mode 100644
index 000000000000..a032de19c999
--- /dev/null
+++ b/app-emulation/cri-o/cri-o-1.13.7.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_COMMIT="42585737f5eb59273e791e47ab1643e10862d67f"
+EGO_PN="github.com/kubernetes-sigs/${PN}"
+
+inherit golang-vcs-snapshot systemd
+
+DESCRIPTION="OCI-based implementation of Kubernetes Container Runtime Interface"
+HOMEPAGE="https://cri-o.io/"
+SRC_URI="https://github.com/kubernetes-sigs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="btrfs +device-mapper ostree seccomp selinux"
+
+COMMON_DEPEND="
+ app-crypt/gpgme:=
+ app-emulation/runc
+ dev-libs/glib:=
+ dev-libs/libassuan:=
+ dev-libs/libgpg-error:=
+ net-firewall/conntrack-tools
+ net-firewall/iptables
+ net-misc/cni-plugins
+ net-misc/socat
+ sys-apps/iproute2
+ btrfs? ( sys-fs/btrfs-progs )
+ device-mapper? ( sys-fs/lvm2:= )
+ ostree? ( dev-util/ostree )
+ seccomp? ( sys-libs/libseccomp:= )
+ selinux? ( sys-libs/libselinux:= )"
+DEPEND="
+ ${COMMON_DEPEND}
+ dev-go/go-md2man"
+RDEPEND="${COMMON_DEPEND}"
+S="${WORKDIR}/${P}/src/${EGO_PN}"
+
+src_prepare() {
+ default
+
+ sed -e '/^GIT_.*/d' \
+ -e '/ git diff --exit-code/d' \
+ -e 's/$(GO) build -i/$(GO) build -v -work -x/' \
+ -e 's/\${GIT_COMMIT}/'${EGIT_COMMIT}'/' \
+ -i Makefile || die
+
+ echo ".NOTPARALLEL: binaries docs" >> Makefile || die
+
+ sed -e "s|^COMMIT_NO := .*|COMMIT_NO := ${EGIT_COMMIT}|" \
+ -e "s|^GIT_COMMIT := .*|GIT_COMMIT := ${EGIT_COMMIT}|" \
+ -i Makefile.inc || die
+
+ sed -e 's:/usr/local/bin:/usr/bin:' \
+ -i contrib/systemd/* || die
+}
+
+src_compile() {
+ [[ -f hack/btrfs_installed_tag.sh ]] || die
+ use btrfs || { echo -e "#!/bin/sh\necho exclude_graphdriver_btrfs" > \
+ hack/btrfs_installed_tag.sh || die; }
+
+ [[ -f hack/libdm_installed.sh ]] || die
+ use device-mapper || { echo -e "#!/bin/sh\necho exclude_graphdriver_devicemapper" > \
+ hack/libdm_installed.sh || die; }
+
+ [[ -f hack/ostree_tag.sh ]] || die
+ use ostree || { echo -e "#!/bin/sh\necho containers_image_ostree_stub" > \
+ hack/ostree_tag.sh || die; }
+
+ [[ -f hack/seccomp_tag.sh ]] || die
+ use seccomp || { echo -e "#!/bin/sh\ntrue" > \
+ hack/seccomp_tag.sh || die; }
+
+ [[ -f hack/selinux_tag.sh ]] || die
+ use selinux || { echo -e "#!/bin/sh\ntrue" > \
+ hack/selinux_tag.sh || die; }
+
+ mkdir -p bin || die
+ GOPATH="${WORKDIR}/${P}" GOBIN="${WORKDIR}/${P}/bin" \
+ emake binaries docs
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${D}${EPREFIX}/usr" install.bin install.man
+
+ keepdir /etc/crio
+ insinto /etc/crio
+ use seccomp && doins seccomp.json
+
+ "${ED}"/usr/bin/crio --config="" config --default > "${T}"/crio.conf.example || die
+ doins "${T}/crio.conf.example"
+
+ newinitd "${FILESDIR}/crio.initd" crio
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotated" "${PN}"
+
+ # Suppress crio log error messages triggered if these don't exist.
+ keepdir /etc/containers/oci/hooks.d
+ keepdir /usr/share/containers/oci/hooks.d
+
+ # Suppress crio "Missing CNI default network" log message.
+ keepdir /etc/cni/net.d
+ insinto /etc/cni/net.d
+ doins contrib/cni/99-loopback.conf
+
+ systemd_dounit contrib/systemd/*
+}