summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-05-12 17:54:56 +0200
committerMichał Górny <mgorny@gentoo.org>2018-05-12 17:55:27 +0200
commit0814e8ae9ef04cc5c3217c801b012d681454437e (patch)
treec654309cb4bb037deb72ef8b4b914a7b4c88fc91 /app-emulation/libspectrum
parentapp-emulation/fuse: Fix src_test to use 'test' target (diff)
downloadgentoo-0814e8ae9ef04cc5c3217c801b012d681454437e.tar.gz
gentoo-0814e8ae9ef04cc5c3217c801b012d681454437e.tar.bz2
gentoo-0814e8ae9ef04cc5c3217c801b012d681454437e.zip
app-emulation/libspectrum: Fix running tests
The 'check' target builds test executable but does not run it. Update the ebuild to run it manually afterwards.
Diffstat (limited to 'app-emulation/libspectrum')
-rw-r--r--app-emulation/libspectrum/libspectrum-1.4.2.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/app-emulation/libspectrum/libspectrum-1.4.2.ebuild b/app-emulation/libspectrum/libspectrum-1.4.2.ebuild
index 66ae4677a64f..75e11f4bc844 100644
--- a/app-emulation/libspectrum/libspectrum-1.4.2.ebuild
+++ b/app-emulation/libspectrum/libspectrum-1.4.2.ebuild
@@ -31,6 +31,12 @@ src_configure() {
econf "${myconf[@]}"
}
+src_test() {
+ # check only builds test executable but doesn't run it
+ emake check
+ ./test/test || die
+}
+
src_install() {
default
dodoc doc/*.txt *.txt