summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2018-08-16 20:00:47 -0700
committerZac Medico <zmedico@gentoo.org>2018-08-16 20:03:09 -0700
commit659aac64d1c58458d69351b979ae8199b23d3d84 (patch)
tree6e14f7c09d33b7e3b99028e81c16c0944ea58702 /app-emulation/skopeo/skopeo-0.1.31.ebuild
parentnet-wireless/soapyrtlsdr: bump (diff)
downloadgentoo-659aac64d1c58458d69351b979ae8199b23d3d84.tar.gz
gentoo-659aac64d1c58458d69351b979ae8199b23d3d84.tar.bz2
gentoo-659aac64d1c58458d69351b979ae8199b23d3d84.zip
app-emulation/skopeo: version bump to 0.1.31
Package-Manager: Portage-2.3.46, Repoman-2.3.10
Diffstat (limited to 'app-emulation/skopeo/skopeo-0.1.31.ebuild')
-rw-r--r--app-emulation/skopeo/skopeo-0.1.31.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/app-emulation/skopeo/skopeo-0.1.31.ebuild b/app-emulation/skopeo/skopeo-0.1.31.ebuild
new file mode 100644
index 000000000000..435c19e79825
--- /dev/null
+++ b/app-emulation/skopeo/skopeo-0.1.31.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN=github.com/projectatomic/skopeo
+COMMIT=b0b750d
+inherit golang-vcs-snapshot
+
+DESCRIPTION="Command line utility foroperations on container images and image repositories"
+HOMEPAGE="https://github.com/projectatomic/skopeo"
+SRC_URI="https://github.com/projectatomic/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+COMMON_DEPEND=">=app-crypt/gpgme-1.5.5:=
+ >=dev-libs/libassuan-2.4.3
+ >=sys-fs/btrfs-progs-4.0.1
+ >=sys-fs/lvm2-2.02.145"
+DEPEND="${COMMON_DEPEND}
+ dev-go/go-md2man"
+RDEPEND="${COMMON_DEPEND}"
+
+S="${WORKDIR}/${P}/src/${EGO_PN}"
+
+RESTRICT="test"
+
+src_compile() {
+ local BUILDTAGS="containers_image_ostree_stub"
+ set -- env GOPATH="${WORKDIR}/${P}" \
+ go build -ldflags "-X main.gitCommit=${COMMIT}" \
+ -gcflags "${GOGCFLAGS}" -tags "${BUILDTAGS}" \
+ -o skopeo ./cmd/skopeo
+ echo "$@"
+ "$@" || die
+ cd docs || die
+ for f in *.1.md; do
+ go-md2man -in ${f} -out ${f%%.md} || die
+ done
+}
+
+src_install() {
+ dobin skopeo
+ doman docs/*.1
+ insinto /etc/containers
+ newins default-policy.json policy.json
+ insinto /etc/containers/registries.d
+ doins default.yaml
+ keepdir /var/lib/atomic/sigstore
+ einstalldocs
+}