summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <tmozes@sygic.com>2017-10-16 14:29:04 +0200
committerYixun Lan <dlan@gentoo.org>2017-10-17 15:24:31 +0800
commitc225f1b9c8379dd0c166a5a5acd471c0146b28b8 (patch)
treece9bd313ac71d694414976629713a91aabe63369 /app-emulation/xen-tools
parentapp-emulation/xen-tools: fix building with gcc 7 (diff)
downloadgentoo-c225f1b9c8379dd0c166a5a5acd471c0146b28b8.tar.gz
gentoo-c225f1b9c8379dd0c166a5a5acd471c0146b28b8.tar.bz2
gentoo-c225f1b9c8379dd0c166a5a5acd471c0146b28b8.zip
app-emulation/xen-tools: improve documentation building
Closes: https://github.com/gentoo/gentoo/pull/5962 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'app-emulation/xen-tools')
-rw-r--r--app-emulation/xen-tools/xen-tools-4.8.2-r2.ebuild33
1 files changed, 10 insertions, 23 deletions
diff --git a/app-emulation/xen-tools/xen-tools-4.8.2-r2.ebuild b/app-emulation/xen-tools/xen-tools-4.8.2-r2.ebuild
index ed261704df2d..235f97cb4932 100644
--- a/app-emulation/xen-tools/xen-tools-4.8.2-r2.ebuild
+++ b/app-emulation/xen-tools/xen-tools-4.8.2-r2.ebuild
@@ -101,18 +101,10 @@ DEPEND="${COMMON_DEPEND}
dev-lang/perl
app-misc/pax-utils
doc? (
- app-doc/doxygen
+ app-text/pandoc
dev-python/markdown[${PYTHON_USEDEP}]
- dev-tex/latex2html[png,gif]
- media-gfx/graphviz
- dev-tex/xcolor
- media-gfx/transfig
dev-texlive/texlive-latexextra
- virtual/latex-base
- dev-tex/latexmk
- dev-texlive/texlive-latex
- dev-texlive/texlive-pictures
- dev-texlive/texlive-latexrecommended
+ media-gfx/transfig
)
hvm? ( x11-proto/xproto
!net-libs/libiscsi )
@@ -383,8 +375,11 @@ src_compile() {
emake V=1 CC="$(tc-getCC)" LD="$(tc-getLD)" AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)" -C tools ${myopt}
- use doc && emake -C docs txt html
- emake -C docs man-pages
+ if use doc; then
+ emake -C docs build
+ else
+ emake -C docs man-pages
+ fi
}
src_install() {
@@ -408,17 +403,9 @@ src_install() {
# Remove RedHat-specific stuff
rm -rf "${D}"tmp || die
- if use doc; then
- emake DESTDIR="${D}" DOCDIR="/usr/share/doc/${PF}" install-docs
-
- dohtml -r docs/
- docinto pdf
- dodoc ${DOCS[@]}
- [ -d "${D}"/usr/share/doc/xen ] && mv "${D}"/usr/share/doc/xen/* "${D}"/usr/share/doc/${PF}/html
- fi
-
- rm -rf "${D}"/usr/share/doc/xen/
- doman docs/man?/*
+ emake DESTDIR="${D}" DOCDIR="/usr/share/doc/${PF}" install-docs
+ use doc && dodoc -r docs/{pdf,txt}
+ dodoc ${DOCS[@]}
newconfd "${FILESDIR}"/xendomains.confd xendomains
newconfd "${FILESDIR}"/xenstored.confd xenstored