summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-01-23 10:29:03 -0500
committerMichael Orlitzky <mjo@gentoo.org>2020-01-23 10:34:01 -0500
commit941b473afc3f5e96a83c12113454e9d1467e2203 (patch)
tree7e67b41cbb8fdad31534c02451847030e5e4dff6 /app-eselect/eselect-php
parentapp-text/mandoc: Fixed build with make-4.3 (diff)
downloadgentoo-941b473afc3f5e96a83c12113454e9d1467e2203.tar.gz
gentoo-941b473afc3f5e96a83c12113454e9d1467e2203.tar.bz2
gentoo-941b473afc3f5e96a83c12113454e9d1467e2203.zip
app-eselect/eselect-php: tweak the live ebuild for upstream changes.
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'app-eselect/eselect-php')
-rw-r--r--app-eselect/eselect-php/eselect-php-9999.ebuild19
1 files changed, 4 insertions, 15 deletions
diff --git a/app-eselect/eselect-php/eselect-php-9999.ebuild b/app-eselect/eselect-php/eselect-php-9999.ebuild
index e6b5ef3d8804..013fabe6fdd3 100644
--- a/app-eselect/eselect-php/eselect-php-9999.ebuild
+++ b/app-eselect/eselect-php/eselect-php-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit systemd git-r3 autotools
+inherit git-r3 autotools
DESCRIPTION="PHP eselect module"
HOMEPAGE="https://gitweb.gentoo.org/proj/eselect-php.git/"
@@ -19,7 +19,7 @@ RDEPEND="app-admin/eselect
apache2? ( www-servers/apache[apache2_modules_dir] )"
src_prepare() {
- eapply_user
+ default
eautoreconf
}
@@ -36,14 +36,3 @@ src_configure(){
$(use_enable apache2) \
$(use_enable fpm)
}
-
-src_install() {
- default
-
- if use fpm ; then
- systemd_dotmpfilesd "${FILESDIR}/php-fpm.conf"
- sed -e "s,@libdir@,$(get_libdir),g" "${FILESDIR}/php-fpm-launcher-r3" > "${T}"/php-fpm-launcher || die
- exeinto /usr/libexec
- doexe "${T}"/php-fpm-launcher
- fi
-}