summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-eselect/eselect-unison
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-eselect/eselect-unison')
-rw-r--r--app-eselect/eselect-unison/eselect-unison-0.1.ebuild25
-rw-r--r--app-eselect/eselect-unison/eselect-unison-0.2.ebuild26
-rw-r--r--app-eselect/eselect-unison/eselect-unison-0.3.ebuild26
-rw-r--r--app-eselect/eselect-unison/files/unison.eselect-0.1152
-rw-r--r--app-eselect/eselect-unison/files/unison.eselect-0.2147
-rw-r--r--app-eselect/eselect-unison/files/unison.eselect-0.3146
-rw-r--r--app-eselect/eselect-unison/metadata.xml5
7 files changed, 527 insertions, 0 deletions
diff --git a/app-eselect/eselect-unison/eselect-unison-0.1.ebuild b/app-eselect/eselect-unison/eselect-unison-0.1.ebuild
new file mode 100644
index 000000000000..338b89e4bcc7
--- /dev/null
+++ b/app-eselect/eselect-unison/eselect-unison-0.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="unison module for eselect"
+HOMEPAGE="http://www.gentoo.org/proj/en/eselect/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+IUSE=""
+DEPEND=""
+RDEPEND=">=app-admin/eselect-1.0.5"
+
+src_install() {
+ local MODULEDIR="/usr/share/eselect/modules"
+ local MODULE="unison"
+ dodir ${MODULEDIR}
+ insinto ${MODULEDIR}
+ newins "${FILESDIR}/${MODULE}.eselect-${PVR}" ${MODULE}.eselect || die "failed to install"
+}
diff --git a/app-eselect/eselect-unison/eselect-unison-0.2.ebuild b/app-eselect/eselect-unison/eselect-unison-0.2.ebuild
new file mode 100644
index 000000000000..502a2bd5715b
--- /dev/null
+++ b/app-eselect/eselect-unison/eselect-unison-0.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="unison module for eselect"
+HOMEPAGE="http://www.gentoo.org/proj/en/eselect/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=app-admin/eselect-1.2.3"
+
+src_install() {
+ local MODULEDIR="/usr/share/eselect/modules"
+ local MODULE="unison"
+ dodir ${MODULEDIR}
+ insinto ${MODULEDIR}
+ newins "${FILESDIR}/${MODULE}.eselect-${PVR}" ${MODULE}.eselect \
+ || die "failed to install"
+}
diff --git a/app-eselect/eselect-unison/eselect-unison-0.3.ebuild b/app-eselect/eselect-unison/eselect-unison-0.3.ebuild
new file mode 100644
index 000000000000..5a31933733ae
--- /dev/null
+++ b/app-eselect/eselect-unison/eselect-unison-0.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="unison module for eselect"
+HOMEPAGE="http://www.gentoo.org/proj/en/eselect/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=app-admin/eselect-1.2.3"
+
+src_install() {
+ local MODULEDIR="/usr/share/eselect/modules"
+ local MODULE="unison"
+ dodir ${MODULEDIR}
+ insinto ${MODULEDIR}
+ newins "${FILESDIR}/${MODULE}.eselect-${PVR}" ${MODULE}.eselect \
+ || die "failed to install"
+}
diff --git a/app-eselect/eselect-unison/files/unison.eselect-0.1 b/app-eselect/eselect-unison/files/unison.eselect-0.1
new file mode 100644
index 000000000000..6baa01264da4
--- /dev/null
+++ b/app-eselect/eselect-unison/files/unison.eselect-0.1
@@ -0,0 +1,152 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Manage /usr/bin/unison versions"
+MAINTAINER="ml@gentoo.org"
+SVN_DATE='$Date: 2015/03/31 16:57:32 $'
+VERSION=$(svn_date_to_version "${SVN_DATE}" )
+
+# find a list of unison symlink targets, best first
+find_targets() {
+ local f
+ for f in "${ROOT}"/usr/bin/unison-[0-9]*; do
+ if [[ -f ${f} ]] ; then
+ echo "${f##*/unison-}"
+ fi
+ done | tac
+}
+
+# find version number of currently symlinked version
+identify_target() {
+ local f
+ f="$(canonicalise "${ROOT}"/usr/bin/unison)"
+ echo "${f##*/unison-}"
+}
+
+# try to remove the unison symlink
+remove_symlinks() {
+ rm -f "${ROOT}"/usr/bin/unison &>/dev/null
+}
+
+# set the unison symlink
+set_symlinks() {
+ local target="${1}" targets
+ if is_number "${target}" && [[ ${target} -ge 1 ]] ; then
+ targets=( $(find_targets ) )
+ target=${targets[$(( ${target} - 1 ))]}
+ fi
+ if [[ -f "${ROOT}/usr/bin/unison-${target}" ]] ; then
+ remove_symlinks
+ ln -s "unison-${target}" "${ROOT}/usr/bin/unison" || \
+ die "Could not set ${target} /usr/bin/unison symlink"
+ else
+ die -q "Target \"${target}\" doesn't appear to be valid!"
+ fi
+}
+
+### show action ###
+
+describe_show() {
+ echo "Show the current unison version"
+}
+
+do_show() {
+ [[ -z "${@}" ]] || die -q "Too many parameters"
+
+ write_list_start "Current unison verson:"
+ if [[ -L "${ROOT}/usr/bin/unison" ]] ; then
+ write_kv_list_entry "$(identify_target)" ""
+ elif [[ -e "${ROOT}/usr/bin/unison" ]] ; then
+ write_kv_list_entry "(not a symlink)" ""
+ else
+ write_kv_list_entry "(unset)" ""
+ fi
+}
+
+### list action ###
+
+describe_list() {
+ echo "List available unison versions"
+}
+
+do_list() {
+ [[ -z "${@}" ]] || die -q "Too many parameters"
+
+ local i targets current
+ targets=( $(find_targets ) )
+ current=$(identify_target)
+ if [[ -n ${targets[@]} ]] ; then
+ for (( i = 0 ; i < ${#targets[@]} ; i = i + 1 )) ; do
+ [[ ${targets[${i}]} == ${current} ]] && \
+ targets[${i}]="${targets[${i}]} $(highlight '*' )"
+ done
+ write_list_start "Available unison versions:"
+ write_numbered_list "${targets[@]}"
+ else
+ write_kv_list_entry "(none found)" ""
+ fi
+}
+
+### set action ###
+
+describe_set() {
+ echo "Set a new unison version"
+}
+
+describe_set_options() {
+ echo "target : Target version number or index from 'list' action"
+}
+
+describe_set_parameters() {
+ echo "<target>"
+}
+
+do_set() {
+ if [[ -z "${1}" ]] ; then
+ die -q "You didn't give me a version number"
+
+ elif [[ -n "${2}" ]] ; then
+ die -q "Too many parameters"
+
+ elif [[ -L "${ROOT}/usr/bin/unison" ]] ; then
+ if ! remove_symlinks ; then
+ die -q "Can't remove existing version symlink"
+ elif ! set_symlinks "${1}" ; then
+ die -q "Can't set new version"
+ fi
+
+ elif [[ -e "${ROOT}/usr/bin/unison" ]] ; then
+ die -q "${ROOT}/usr/bin/unison seems to be from an old ebuild, please remove manually"
+
+ else
+ set_symlinks "${1}" || die -q "Can't set new version"
+ fi
+}
+
+### update action ###
+
+describe_update() {
+ echo "Automatically update the unison version number"
+}
+
+describe_update_options() {
+ echo "--if-unset : Do not override currently selected version"
+}
+
+do_update() {
+ [[ -z "${1}" ]] || ( [[ -z "${2}" ]] && [[ "${1}" == "--if-unset" ]] ) || \
+ die -q "Usage error"
+
+ if [[ -L "${ROOT}/usr/bin/unison" ]] ; then
+ [[ ${1} == "--if-unset" ]] && return
+ remove_symlinks || die -q "Can't remove existing symlink"
+ fi
+ if [[ -e "${ROOT}/usr/bin/unison" ]] ; then
+ die -q "${ROOT}/usr/bin/unison seems to be from an old ebuild, please remove manually"
+ elif ! [[ -z $(find_targets ) ]] ; then
+ set_symlinks 1 || die -q "Can't set a new version"
+ fi
+}
+
+# vim: set ft=eselect :
diff --git a/app-eselect/eselect-unison/files/unison.eselect-0.2 b/app-eselect/eselect-unison/files/unison.eselect-0.2
new file mode 100644
index 000000000000..62cc128c0ec7
--- /dev/null
+++ b/app-eselect/eselect-unison/files/unison.eselect-0.2
@@ -0,0 +1,147 @@
+# -*-eselect-*- vim: ft=eselect
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Manage /usr/bin/unison versions"
+MAINTAINER="ml@gentoo.org"
+SVN_DATE='$Date: 2015/03/31 16:57:32 $'
+VERSION=$(svn_date_to_version "${SVN_DATE}" )
+
+# find a list of unison symlink targets, best first
+find_targets() {
+ local f
+ for f in "${ROOT}"/usr/bin/unison-[0-9]*; do
+ if [[ -f ${f} ]] ; then
+ echo "${f##*/unison-}"
+ fi
+ done | tac
+}
+
+# find version number of currently symlinked version
+identify_target() {
+ local f
+ f="$(canonicalise "${ROOT}"/usr/bin/unison)"
+ echo "${f##*/unison-}"
+}
+
+# try to remove the unison symlink
+remove_symlinks() {
+ rm -f "${ROOT}"/usr/bin/unison &>/dev/null
+}
+
+# set the unison symlink
+set_symlinks() {
+ local target="${1}" targets
+ if is_number "${target}" && [[ ${target} -ge 1 ]] ; then
+ targets=( $(find_targets ) )
+ target=${targets[$(( ${target} - 1 ))]}
+ fi
+ if [[ -f "${ROOT}/usr/bin/unison-${target}" ]] ; then
+ remove_symlinks
+ ln -s "unison-${target}" "${ROOT}/usr/bin/unison" || \
+ die "Could not set ${target} /usr/bin/unison symlink"
+ else
+ die -q "Target \"${target}\" doesn't appear to be valid!"
+ fi
+}
+
+### show action ###
+
+describe_show() {
+ echo "Show the current unison version"
+}
+
+do_show() {
+ [[ -z "${@}" ]] || die -q "Too many parameters"
+
+ write_list_start "Current unison verson:"
+ if [[ -L "${ROOT}/usr/bin/unison" ]] ; then
+ write_kv_list_entry "$(identify_target)" ""
+ elif [[ -e "${ROOT}/usr/bin/unison" ]] ; then
+ write_kv_list_entry "(not a symlink)" ""
+ else
+ write_kv_list_entry "(unset)" ""
+ fi
+}
+
+### list action ###
+
+describe_list() {
+ echo "List available unison versions"
+}
+
+do_list() {
+ [[ $# -eq 0 ]] || die -q "Too many parameters"
+
+ local i targets current
+ targets=( $(find_targets ) )
+ current=$(identify_target)
+ for (( i = 0; i < ${#targets[@]}; i++ )); do
+ [[ ${targets[i]} = ${current} ]] \
+ && targets[i]=$(highlight_marker "${targets[i]}")
+ done
+ write_list_start "Available unison versions:"
+ write_numbered_list -m "(none found)" "${targets[@]}"
+}
+
+### set action ###
+
+describe_set() {
+ echo "Set a new unison version"
+}
+
+describe_set_options() {
+ echo "target : Target version number or index from 'list' action"
+}
+
+describe_set_parameters() {
+ echo "<target>"
+}
+
+do_set() {
+ if [[ -z "${1}" ]] ; then
+ die -q "You didn't give me a version number"
+
+ elif [[ -n "${2}" ]] ; then
+ die -q "Too many parameters"
+
+ elif [[ -L "${ROOT}/usr/bin/unison" ]] ; then
+ if ! remove_symlinks ; then
+ die -q "Can't remove existing version symlink"
+ elif ! set_symlinks "${1}" ; then
+ die -q "Can't set new version"
+ fi
+
+ elif [[ -e "${ROOT}/usr/bin/unison" ]] ; then
+ die -q "${ROOT}/usr/bin/unison seems to be from an old ebuild, please remove manually"
+
+ else
+ set_symlinks "${1}" || die -q "Can't set new version"
+ fi
+}
+
+### update action ###
+
+describe_update() {
+ echo "Automatically update the unison version number"
+}
+
+describe_update_options() {
+ echo "--if-unset : Do not override currently selected version"
+}
+
+do_update() {
+ [[ -z "${1}" ]] || ( [[ -z "${2}" ]] && [[ "${1}" == "--if-unset" ]] ) || \
+ die -q "Usage error"
+
+ if [[ -L "${ROOT}/usr/bin/unison" ]] ; then
+ [[ ${1} == "--if-unset" ]] && return
+ remove_symlinks || die -q "Can't remove existing symlink"
+ fi
+ if [[ -e "${ROOT}/usr/bin/unison" ]] ; then
+ die -q "${ROOT}/usr/bin/unison seems to be from an old ebuild, please remove manually"
+ elif ! [[ -z $(find_targets ) ]] ; then
+ set_symlinks 1 || die -q "Can't set a new version"
+ fi
+}
diff --git a/app-eselect/eselect-unison/files/unison.eselect-0.3 b/app-eselect/eselect-unison/files/unison.eselect-0.3
new file mode 100644
index 000000000000..99190ebcbef0
--- /dev/null
+++ b/app-eselect/eselect-unison/files/unison.eselect-0.3
@@ -0,0 +1,146 @@
+# -*-eselect-*- vim: ft=eselect
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Manage /usr/bin/unison versions"
+MAINTAINER="ml@gentoo.org"
+VERSION="0.3"
+
+# find a list of unison symlink targets, best first
+find_targets() {
+ local f
+ for f in "${EROOT}"/usr/bin/unison-[0-9]*; do
+ if [[ -f ${f} ]] ; then
+ echo "${f##*/unison-}"
+ fi
+ done | tac
+}
+
+# find version number of currently symlinked version
+identify_target() {
+ local f
+ f="$(canonicalise "${EROOT}"/usr/bin/unison)"
+ echo "${f##*/unison-}"
+}
+
+# try to remove the unison symlink
+remove_symlinks() {
+ rm -f "${EROOT}"/usr/bin/unison &>/dev/null
+}
+
+# set the unison symlink
+set_symlinks() {
+ local target="${1}" targets
+ if is_number "${target}" && [[ ${target} -ge 1 ]] ; then
+ targets=( $(find_targets) )
+ target=${targets[target - 1]}
+ fi
+ if [[ -f "${EROOT}/usr/bin/unison-${target}" ]] ; then
+ remove_symlinks
+ ln -s "unison-${target}" "${EROOT}/usr/bin/unison" || \
+ die "Could not set ${target} /usr/bin/unison symlink"
+ else
+ die -q "Target \"${target}\" doesn't appear to be valid!"
+ fi
+}
+
+### show action ###
+
+describe_show() {
+ echo "Show the current unison version"
+}
+
+do_show() {
+ [[ -z "${@}" ]] || die -q "Too many parameters"
+
+ write_list_start "Current unison verson:"
+ if [[ -L "${EROOT}/usr/bin/unison" ]] ; then
+ write_kv_list_entry "$(identify_target)" ""
+ elif [[ -e "${EROOT}/usr/bin/unison" ]] ; then
+ write_kv_list_entry "(not a symlink)" ""
+ else
+ write_kv_list_entry "(unset)" ""
+ fi
+}
+
+### list action ###
+
+describe_list() {
+ echo "List available unison versions"
+}
+
+do_list() {
+ [[ $# -eq 0 ]] || die -q "Too many parameters"
+
+ local i targets current
+ targets=( $(find_targets ) )
+ current=$(identify_target)
+ for (( i = 0; i < ${#targets[@]}; i++ )); do
+ [[ ${targets[i]} = ${current} ]] \
+ && targets[i]=$(highlight_marker "${targets[i]}")
+ done
+ write_list_start "Available unison versions:"
+ write_numbered_list -m "(none found)" "${targets[@]}"
+}
+
+### set action ###
+
+describe_set() {
+ echo "Set a new unison version"
+}
+
+describe_set_options() {
+ echo "target : Target version number or index from 'list' action"
+}
+
+describe_set_parameters() {
+ echo "<target>"
+}
+
+do_set() {
+ if [[ -z "${1}" ]] ; then
+ die -q "You didn't give me a version number"
+
+ elif [[ -n "${2}" ]] ; then
+ die -q "Too many parameters"
+
+ elif [[ -L "${EROOT}/usr/bin/unison" ]] ; then
+ if ! remove_symlinks ; then
+ die -q "Can't remove existing version symlink"
+ elif ! set_symlinks "${1}" ; then
+ die -q "Can't set new version"
+ fi
+
+ elif [[ -e "${EROOT}/usr/bin/unison" ]] ; then
+ die -q "${EROOT}/usr/bin/unison seems to be from an old ebuild, please remove manually"
+
+ else
+ set_symlinks "${1}" || die -q "Can't set new version"
+ fi
+}
+
+### update action ###
+
+describe_update() {
+ echo "Automatically update the unison version number"
+}
+
+describe_update_options() {
+ echo "--if-unset : Do not override currently selected version"
+}
+
+do_update() {
+ [[ -z "${1}" ]] || ( [[ -z "${2}" ]] && [[ "${1}" == "--if-unset" ]] ) || \
+ die -q "Usage error"
+
+ if [[ -L "${EROOT}/usr/bin/unison" ]] ; then
+ [[ ${1} == "--if-unset" ]] && return
+ remove_symlinks || die -q "Can't remove existing symlink"
+ fi
+ if [[ -e "${EROOT}/usr/bin/unison" ]] ; then
+ die -q "${EROOT}/usr/bin/unison seems to be from an old ebuild, please remove manually"
+ elif ! [[ -z $(find_targets ) ]] ; then
+ set_symlinks 1 || die -q "Can't set a new version"
+ fi
+}
diff --git a/app-eselect/eselect-unison/metadata.xml b/app-eselect/eselect-unison/metadata.xml
new file mode 100644
index 000000000000..2193d772e351
--- /dev/null
+++ b/app-eselect/eselect-unison/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>