summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2015-12-17 23:58:42 -0500
committerBrian Evans <grknight@gentoo.org>2015-12-18 00:13:17 -0500
commit6176d888b522b2b89fce83eba04c51e116a4e88a (patch)
tree5a481621b0245ed2b2d9250609d3cd95f3d3eba0 /app-eselect
parentx11-misc/openbox-menu: Version bump. (diff)
downloadgentoo-6176d888b522b2b89fce83eba04c51e116a4e88a.tar.gz
gentoo-6176d888b522b2b89fce83eba04c51e116a4e88a.tar.bz2
gentoo-6176d888b522b2b89fce83eba04c51e116a4e88a.zip
app-eselect/eselect-php: Version bump to add phpdbg support
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-eselect')
-rw-r--r--app-eselect/eselect-php/Manifest1
-rw-r--r--app-eselect/eselect-php/eselect-php-0.8.2.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/app-eselect/eselect-php/Manifest b/app-eselect/eselect-php/Manifest
index 249fc20c0feb..158f9cbc675b 100644
--- a/app-eselect/eselect-php/Manifest
+++ b/app-eselect/eselect-php/Manifest
@@ -1,3 +1,4 @@
DIST eselect-php-0.7.1.bz2 2251 SHA256 10aa400e2d08bc71989366993f12ddb546a0ea29f191c40e37beba1d11d7abd7 SHA512 a6b4c1475dda9f368d799db7658c50cef7d6f71482a53a186fb1394e7ea1fff3c0ef123c82b7ca4d1e45aadb0a034d36f213fc9450766878a60d28639761cb3d WHIRLPOOL a4e45492068616ff30fd888b0cc64441a6eb6e6656e0107d00bd2cf15360dce15052d4d62089ab89d43e6bb36e126529aa101c70e8bd94a9fc916a5369463e3b
DIST eselect-php-0.8.0.tar.xz 43932 SHA256 1ddc6aafe269ebbf3006737701403bd2c7b324b9eea0fcbdc91e85a856f8a10d SHA512 53c735275264742542d3909ae2994d0720bc961533a3df5373dbc7a7a1f04e91591f4e8356c268954420487d3ead4006cc5d6f361ef0ac2836f7f126556e960d WHIRLPOOL 94deba4a5bd4d0d85c8f3afc96ac30a69cca5db95014b2fd8701495cc83488389302f640065e923cabd40c95f97f792dd173337cc33c7d38441956049fb90cda
DIST eselect-php-0.8.1.tar.xz 44412 SHA256 aa118e936bff176fe64911d68bb72e6e9e03d33c106674169396826a3063a962 SHA512 3679c8ac4d980424a108d93c8e2e575b93196d7140f31f900e7f925ab26cf821233d12b9083fd7bdd7bd596c3b59544e972660be8ffce7c24d4a7980fbe5f770 WHIRLPOOL 19c6f05a02aa1a40586f352822679f7e655200374a100834d4370678b35856d5e255b0d83f07eafd69481ee3ee72cb976665e6c2b2df990be00b54bfa53a5a92
+DIST eselect-php-0.8.2.tar.xz 51832 SHA256 3601d0612a19ccc1c5146be2c8cd7df955a37c517817ae4f59bb3ead446f5355 SHA512 da1d71affe275d07db7a76fd98fd89ffdea6f671262a615bf4dda5a1bba8d19e5d1a3c8afe3f1eb1e70fd71298476a6f0d4e73eba7aafe7555f018f89005bc3d WHIRLPOOL dcc75d93eeaaa85f63f5329491d010debd83ed2a82af0051d59ab4aff639703a6f4c1baa5388ed2a8867d6ab610740d5a1ac86d28cddb0de5be47872ada040b4
diff --git a/app-eselect/eselect-php/eselect-php-0.8.2.ebuild b/app-eselect/eselect-php/eselect-php-0.8.2.ebuild
new file mode 100644
index 000000000000..e52f00465d16
--- /dev/null
+++ b/app-eselect/eselect-php/eselect-php-0.8.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit depend.apache systemd
+
+DESCRIPTION="PHP eselect module"
+HOMEPAGE="https://gitweb.gentoo.org/proj/eselect-php.git/"
+SRC_URI="
+ https://dev.gentoo.org/~mjo/distfiles/${P}.tar.xz
+ https://dev.gentoo.org/~grknight/distfiles/${P}.tar.xz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="fpm apache2"
+
+# The "DirectoryIndex" line in 70_mod_php.conf requires mod_dir.
+RDEPEND="app-admin/eselect
+ apache2? ( www-servers/apache[apache2_modules_dir] )"
+
+want_apache
+
+src_install() {
+ default
+
+ if use apache2 ; then
+ insinto "${APACHE_MODULES_CONFDIR#${EPREFIX}}"
+ doins "${FILESDIR}/70_mod_php.conf"
+ fi
+
+ if use fpm ; then
+ newinitd "${FILESDIR}/php-fpm.init-r4" "php-fpm"
+ systemd_dotmpfilesd "${FILESDIR}/php-fpm.conf"
+ exeinto /usr/libexec
+ doexe "${FILESDIR}/php-fpm-launcher"
+ fi
+}
+
+pkg_postinst() {
+ if use apache2 ; then
+ elog
+ elog "If you are upgrading, be warned that our mod_php configuration"
+ elog "file has changed! You should now define -DPHP for the apache2"
+ elog "daemon, and inspect the new 70_mod_php.conf which has been"
+ elog "installed. Module loading involves eselect as of this version."
+ elog
+ elog "You must run eselect at least once to choose your apache2 target"
+ elog "before the new configuration will work. Afterwards, and after you"
+ elog "have reviewed your new configuration, you are advised to remove"
+ elog "the obsolete 70_mod_php5.conf file."
+ elog
+ fi
+}