summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2017-07-23 23:46:37 +0900
committerAkinori Hattori <hattya@gentoo.org>2017-07-23 23:50:13 +0900
commit3f9f1b3a0745bab3887e86c8a8dae2b6c7b70d91 (patch)
tree0cee79ee1ec0fbb9edca88423ead56fd6a7af56b /app-i18n/anthy
parentapp-i18n/anthy: update HOMEPAGE (diff)
downloadgentoo-3f9f1b3a0745bab3887e86c8a8dae2b6c7b70d91.tar.gz
gentoo-3f9f1b3a0745bab3887e86c8a8dae2b6c7b70d91.tar.bz2
gentoo-3f9f1b3a0745bab3887e86c8a8dae2b6c7b70d91.zip
app-i18n/anthy: inherit ltprune
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-i18n/anthy')
-rw-r--r--app-i18n/anthy/anthy-9100h-r2.ebuild24
-rw-r--r--app-i18n/anthy/files/50anthy-gentoo.el3
-rw-r--r--app-i18n/anthy/metadata.xml12
3 files changed, 16 insertions, 23 deletions
diff --git a/app-i18n/anthy/anthy-9100h-r2.ebuild b/app-i18n/anthy/anthy-9100h-r2.ebuild
index c3788f57ab53..1d96fbfc15cb 100644
--- a/app-i18n/anthy/anthy-9100h-r2.ebuild
+++ b/app-i18n/anthy/anthy-9100h-r2.ebuild
@@ -3,7 +3,7 @@
EAPI="6"
-inherit elisp-common
+inherit elisp-common ltprune
DESCRIPTION="Anthy -- free and secure Japanese input system"
HOMEPAGE="http://anthy.osdn.jp/"
@@ -18,40 +18,36 @@ RDEPEND="canna-2ch? ( app-dicts/canna-2ch )
emacs? ( virtual/emacs )"
DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/${P}-anthy_context_t.patch" )
-DOCS=( AUTHORS DIARY NEWS README ChangeLog )
+PATCHES=( "${FILESDIR}"/${P}-anthy_context_t.patch )
+DOCS=( AUTHORS ChangeLog DIARY NEWS README )
+
+SITEFILE="50${PN}-gentoo.el"
src_prepare() {
default
if use canna-2ch; then
einfo "Adding nichan.ctd to anthy.dic."
- sed -i \
- -e "/set_input_encoding eucjp/aread ${EPREFIX}/var/lib/canna/dic/canna/nichan.ctd" \
- mkworddic/dict.args.in || die
+ sed -i "/set_input_encoding eucjp/aread ${EPREFIX}/var/lib/canna/dic/canna/nichan.ctd" mkworddic/dict.args.in
fi
}
src_configure() {
- local myconf
-
- use emacs || myconf="EMACS=no"
-
econf \
$(use_enable static-libs static) \
- ${myconf}
+ EMACS=$(usex emacs "${EMACS}")
}
src_install() {
default
+ prune_libtool_files
if use emacs; then
- elisp-site-file-install "${FILESDIR}"/50anthy-gentoo.el || die
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
fi
rm -f doc/Makefile*
- docinto doc
- dodoc doc/*
+ dodoc -r doc
}
pkg_postinst() {
diff --git a/app-i18n/anthy/files/50anthy-gentoo.el b/app-i18n/anthy/files/50anthy-gentoo.el
index a166df146539..ab154f8d4eff 100644
--- a/app-i18n/anthy/files/50anthy-gentoo.el
+++ b/app-i18n/anthy/files/50anthy-gentoo.el
@@ -1,5 +1,2 @@
-
-;;; anthy site-lisp configuration
-
(set-language-info "Japanese" 'input-method "japanese-anthy")
diff --git a/app-i18n/anthy/metadata.xml b/app-i18n/anthy/metadata.xml
index 4d598476e9ed..0b8350b78af9 100644
--- a/app-i18n/anthy/metadata.xml
+++ b/app-i18n/anthy/metadata.xml
@@ -9,12 +9,12 @@
<name>Cjk</name>
</maintainer>
<longdescription>
- Anthy is a free and secure Japanese kana-kanji server. This ebuild includes
- cannadic as a server-side dictionary, so you don't need any extra package to
- run it. You can use anthy with <pkg>app-i18n/uim</pkg> (XIM, GTK+ immodule)
- and <pkg>virtual/emacs</pkg> (to enable Anthy support for emacs, build this
- package with emacs USE flag).
-</longdescription>
+ Anthy is a free and secure Japanese kana-kanji server. This ebuild includes
+ cannadic as a server-side dictionary, so you don't need any extra package to
+ run it. You can use anthy with <pkg>app-i18n/uim</pkg> (XIM, GTK+ immodule)
+ and <pkg>virtual/emacs</pkg> (to enable Anthy support for emacs, build this
+ package with emacs USE flag).
+ </longdescription>
<use>
<flag name="canna-2ch">Enable support for <pkg>app-dicts/canna-2ch</pkg></flag>
</use>