summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/canna
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/canna')
-rw-r--r--app-i18n/canna/Manifest1
-rw-r--r--app-i18n/canna/canna-3.7_p3-r1.ebuild144
-rw-r--r--app-i18n/canna/canna-3.7_p3-r2.ebuild167
-rw-r--r--app-i18n/canna/files/canna-3.7-gentoo.diff.in144
-rw-r--r--app-i18n/canna/files/canna-3.7_p3-strip.patch142
-rw-r--r--app-i18n/canna/files/canna-3.7_p3.confd7
-rw-r--r--app-i18n/canna/files/canna-3.7_p3.initd42
-rw-r--r--app-i18n/canna/files/canna-kpdef-gentoo.diff18
-rw-r--r--app-i18n/canna/files/canna.confd8
-rw-r--r--app-i18n/canna/files/canna.hosts1
-rw-r--r--app-i18n/canna/files/canna.initd37
-rw-r--r--app-i18n/canna/files/update-canna-dics_dir36
-rw-r--r--app-i18n/canna/metadata.xml8
13 files changed, 755 insertions, 0 deletions
diff --git a/app-i18n/canna/Manifest b/app-i18n/canna/Manifest
new file mode 100644
index 000000000000..151560d8dfa4
--- /dev/null
+++ b/app-i18n/canna/Manifest
@@ -0,0 +1 @@
+DIST Canna37p3.tar.bz2 1263065 SHA256 7d98d925043d3af24f99a8a2a09e3b4d6dfe881efc1303ef4a7f495a0f4542a7 SHA512 82846f2393aa2654dd2c97a93178098b8bd11e5409b584447f1b6fdf303adacc9802e2293cafd98b68af8b69622625ed00aa9712bf270feaa119adfdf4211158 WHIRLPOOL 14433083257ab705bc55b0be5972b9dcce2476209a5c48cdfc53d1f4af6bc739fac2d5fd2f42e7a6e94951a35e1a3e6ca21dd0ec7db6ef307f7d285dc881fbc5
diff --git a/app-i18n/canna/canna-3.7_p3-r1.ebuild b/app-i18n/canna/canna-3.7_p3-r1.ebuild
new file mode 100644
index 000000000000..3855a8522d7f
--- /dev/null
+++ b/app-i18n/canna/canna-3.7_p3-r1.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit cannadic eutils multilib
+
+MY_P="Canna${PV//./}"
+MY_P="${MY_P/_/}"
+
+DESCRIPTION="A client-server based Kana-Kanji conversion system"
+HOMEPAGE="http://canna.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/canna/9565/${MY_P}.tar.bz2"
+
+LICENSE="MIT GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+DEPEND=">=sys-apps/sed-4
+ x11-misc/gccmakedep
+ x11-misc/imake"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ find . -name '*.man' -o -name '*.jmn' | xargs sed -i.bak -e 's/1M/8/g' || die
+ sed -e "s%@cannapkgver@%${PF}%" \
+ "${FILESDIR}"/${PN}-3.7-gentoo.diff.in > "${T}"/${PF}-gentoo.diff || die
+ epatch "${T}"/${PF}-gentoo.diff
+
+ # bug #248723
+ epatch "${FILESDIR}"/${P}-strip.patch
+
+ # Multilib-strict fix for amd64
+ sed -i -e "s:\(DefLibCannaDir.*\)/lib:\1/$(get_libdir):g" Canna.conf* || die
+ # fix deprecated sort syntax
+ sed -e 's:^\(sortcmd=\".* -s\).*$:\1 -k 1,1\":' \
+ -i cmd/mkbindic/mkbindic.cpp || die
+
+ cd "${S}"/dic/phono
+ epatch "${FILESDIR}"/${PN}-kpdef-gentoo.diff
+
+}
+
+src_compile() {
+ xmkmf || die
+
+ #make libCannaDir=../lib/canna canna || die
+ # bug #279706
+ emake -j1 CDEBUGFLAGS="${CFLAGS}" canna || die
+
+ #if use doc ; then
+ # einfo "Compiling DVI, PS (and PDF) document"
+ # cd doc/man/guide/tex
+ # xmkmf || die
+ # emake -j1 JLATEXCMD=platex \
+ # DVI2PSCMD="dvips -f" \
+ # canna.dvi canna.ps || die
+ # if has_version 'app-text/dvipdfmx' && \
+ # ( has_version 'app-text/acroread' \
+ # || has_version 'app-text/xpdf-japanese' ); then
+ # emake -j1 JLATEXCMD=platex \
+ # DVI2PSCMD="dvips -f" \
+ # canna.pdf || die
+ # fi
+ #fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" install.man || die
+
+ # install default.canna (removed from Canna36p4)
+ insinto /usr/share/canna
+ newins misc/initfiles/verbose.canna default.canna
+
+ # cannakill should link to /usr/bin/catdic
+ dosym ../bin/catdic /usr/sbin/cannakill
+
+ dodir /usr/share/man/man8 /usr/share/man/ja/man8
+ for man in cannaserver cannakill ; do
+ for mandir in "${D}"/usr/share/man "${D}"/usr/share/man/ja ; do
+ mv ${mandir}/man1/${man}.1 ${mandir}/man8/${man}.8
+ done
+ done
+
+ dodoc CHANGES.jp ChangeLog INSTALL* README* WHATIS*
+
+ #if use doc ; then
+ # insinto /usr/share/doc/${PF}
+ # doins doc/man/guide/tex/canna.{dvi,ps,pdf}
+ #fi
+
+ newinitd "${FILESDIR}"/${P}.initd canna || die
+ newconfd "${FILESDIR}"/${P}.confd canna || die
+ insinto /etc/ ; newins "${FILESDIR}"/canna.hosts hosts.canna || die
+ keepdir /var/log/canna/ || die
+
+ # for backward compatibility
+ dosbin "${FILESDIR}"/update-canna-dics_dir
+
+ insinto /var/lib/canna/dic/dics.d/
+ newins "${D}"/var/lib/canna/dic/canna/dics.dir 00canna.dics.dir
+
+ # fix permission for user dictionary
+ keepdir /var/lib/canna/dic/{user,group}
+ fowners root:bin /var/lib/canna/dic/{user,group}
+ fperms 775 /var/lib/canna/dic/{user,group}
+}
+
+pkg_postinst() {
+ update-cannadic-dir
+ elog
+ elog "Canna dictionary format has been changed."
+ elog "You should rebuild app-dict/canna-* after emerge."
+ elog
+}
+
+pkg_prerm() {
+ if [ -S /tmp/.iroha_unix/IROHA ] ; then
+ # make sure cannaserver get stopped because otherwise
+ # we cannot stop it with /etc/init.d after emerge -C canna
+ einfo
+ einfo "Stopping Canna for safe unmerge"
+ einfo
+ /etc/init.d/canna stop
+ touch "${T}"/canna.cookie
+ fi
+}
+
+pkg_postrm() {
+ if [ -f /usr/sbin/cannaserver -a -e "${T}"/canna.cookie ] ; then
+ #update-cannadic-dir
+ einfo
+ einfo "Restarting Canna"
+ einfo
+ /etc/init.d/canna start
+ rm -f "${T}"/canna.cookie
+ fi
+}
diff --git a/app-i18n/canna/canna-3.7_p3-r2.ebuild b/app-i18n/canna/canna-3.7_p3-r2.ebuild
new file mode 100644
index 000000000000..533560ade4f1
--- /dev/null
+++ b/app-i18n/canna/canna-3.7_p3-r2.ebuild
@@ -0,0 +1,167 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit cannadic eutils multilib
+
+MY_P="Canna${PV//./}"
+MY_P="${MY_P/_/}"
+
+DESCRIPTION="A client-server based Kana-Kanji conversion system"
+HOMEPAGE="http://canna.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/canna/9565/${MY_P}.tar.bz2"
+
+LICENSE="MIT GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DEPEND=">=sys-apps/sed-4
+ x11-misc/gccmakedep
+ x11-misc/imake
+ doc? (
+ app-text/ghostscript-gpl
+ >=dev-texlive/texlive-langcjk-2010
+ dev-texlive/texlive-fontsextra
+ dev-texlive/texlive-genericrecommended
+ dev-texlive/texlive-latexrecommended
+ )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ find . -name '*.man' -o -name '*.jmn' | xargs sed -i.bak -e 's/1M/8/g' || die
+ sed -e "s%@cannapkgver@%${PF}%" \
+ "${FILESDIR}"/${PN}-3.7-gentoo.diff.in > "${T}"/${PF}-gentoo.diff || die
+ epatch "${T}"/${PF}-gentoo.diff
+
+ # bug #248723
+ epatch "${FILESDIR}"/${P}-strip.patch
+
+ # Multilib-strict fix for amd64
+ sed -i -e "s:\(DefLibCannaDir.*\)/lib:\1/$(get_libdir):g" Canna.conf* || die
+ # fix deprecated sort syntax
+ sed -e 's:^\(sortcmd=\".* -s\).*$:\1 -k 1,1\":' \
+ -i cmd/mkbindic/mkbindic.cpp || die
+
+ cd "${S}"/dic/phono
+ epatch "${FILESDIR}"/${PN}-kpdef-gentoo.diff
+
+}
+
+src_compile() {
+ xmkmf || die
+
+ #make libCannaDir=../lib/canna canna || die
+ # bug #279706
+ emake -j1 CC="$(tc-getCC)" CDEBUGFLAGS="${CFLAGS}" \
+ LOCAL_LDFLAGS="${LDFLAGS}" SHLIBGLOBALSFLAGS="${LDFLAGS}" canna || die
+
+ if use doc ; then
+ einfo "Compiling DVI, PS (and PDF) document"
+ cd doc/man/guide/tex
+ xmkmf || die
+ emake -j1 CC="$(tc-getCC)" CDEBUGFLAGS="${CFLAGS}" \
+ LOCAL_LDFLAGS="${LDFLAGS}" SHLIBGLOBALSFLAGS="${LDFLAGS}" \
+ JLATEXCMD=platex \
+ DVI2PSCMD="dvips -f" VARTEXFONTS=${T}/fonts \
+ canna.dvi canna.ps || die
+ if has_version 'app-text/dvipdfmx' && \
+ ( has_version 'app-text/acroread' \
+ || has_version 'app-text/xpdf-japanese' ); then
+ emake -j1 CC="$(tc-getCC)" CDEBUGFLAGS="${CFLAGS}" \
+ LOCAL_LDFLAGS="${LDFLAGS}" SHLIBGLOBALSFLAGS="${LDFLAGS}" \
+ JLATEXCMD=platex \
+ DVI2PSCMD="dvips -f" VARTEXFONTS=${T}/fonts \
+ canna.pdf || die
+ fi
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" install.man || die
+
+ # install default.canna (removed from Canna36p4)
+ insinto /usr/share/canna
+ newins misc/initfiles/verbose.canna default.canna
+
+ # cannakill should link to /usr/bin/catdic
+ dosym ../bin/catdic /usr/sbin/cannakill
+
+ dodir /usr/share/man/man8 /usr/share/man/ja/man8
+ for man in cannaserver cannakill ; do
+ for mandir in "${D}"/usr/share/man "${D}"/usr/share/man/ja ; do
+ mv ${mandir}/man1/${man}.1 ${mandir}/man8/${man}.8
+ done
+ done
+
+ dodoc CHANGES.jp ChangeLog INSTALL* README* WHATIS*
+
+ if use doc ; then
+ insinto /usr/share/doc/${PF}
+ doins doc/man/guide/tex/canna.{dvi,ps,pdf}
+ fi
+
+ newinitd "${FILESDIR}"/${P}.initd canna || die
+ newconfd "${FILESDIR}"/${P}.confd canna || die
+ insinto /etc/ ; newins "${FILESDIR}"/canna.hosts hosts.canna || die
+ keepdir /var/log/canna/ || die
+
+ # for backward compatibility
+ dosbin "${FILESDIR}"/update-canna-dics_dir
+
+ insinto /var/lib/canna/dic/dics.d/
+ newins "${D}"/var/lib/canna/dic/canna/dics.dir 00canna.dics.dir
+
+ # fix permission for user dictionary
+ keepdir /var/lib/canna/dic/{user,group}
+ fowners root:bin /var/lib/canna/dic/{user,group}
+ fperms 775 /var/lib/canna/dic/{user,group}
+}
+
+pkg_postinst() {
+ update-cannadic-dir
+ elog
+ elog "Canna dictionary format has been changed."
+ elog "You should rebuild app-dict/canna-* after emerge."
+ elog
+
+ local localearchive="${ROOT}usr/$(get_libdir)/locale/locale-archive"
+ if [ -f "${localearchive}" -a -x /usr/bin/localedef ] && \
+ ! /usr/bin/localedef --list-archive "${localearchive}" | grep -i 'ja_JP.eucjp' >/dev/null 2>&1 ; then
+ elog "Some dictionary tools in this package require ja_JP.eucJP locale."
+ elog "Please add ja_JP.eucJP locale to /etc/locale.gen:"
+ elog
+ elog "# echo 'ja_JP.EUC-JP EUC-JP' >> /etc/locale.gen"
+ elog "# locale-gen"
+ elog
+ fi
+}
+
+pkg_prerm() {
+ if [ -S /tmp/.iroha_unix/IROHA ] ; then
+ # make sure cannaserver get stopped because otherwise
+ # we cannot stop it with /etc/init.d after emerge -C canna
+ einfo
+ einfo "Stopping Canna for safe unmerge"
+ einfo
+ /etc/init.d/canna stop
+ touch "${T}"/canna.cookie
+ fi
+}
+
+pkg_postrm() {
+ if [ -f /usr/sbin/cannaserver -a -e "${T}"/canna.cookie ] ; then
+ #update-cannadic-dir
+ einfo
+ einfo "Restarting Canna"
+ einfo
+ /etc/init.d/canna start
+ rm -f "${T}"/canna.cookie
+ fi
+}
diff --git a/app-i18n/canna/files/canna-3.7-gentoo.diff.in b/app-i18n/canna/files/canna-3.7-gentoo.diff.in
new file mode 100644
index 000000000000..940c97f6dcaa
--- /dev/null
+++ b/app-i18n/canna/files/canna-3.7-gentoo.diff.in
@@ -0,0 +1,144 @@
+diff -urN Canna37b1.ORIG/Canna.conf Canna37b1/Canna.conf
+--- Canna37b1.ORIG/Canna.conf 2003-09-27 15:23:08.000000000 +0900
++++ Canna37b1/Canna.conf 2003-09-27 19:09:13.000000000 +0900
+@@ -114,7 +114,7 @@
+ # define DefErrDir /usr/spool/canna
+ # define DefLibCannaDir /usr/lib
+ # else
+-# define DefErrDir /var/log
++# define DefErrDir /var/log/canna
+ # define DefLibCannaDir $(cannaExecPrefix)/lib
+ # endif
+ #endif
+@@ -140,16 +140,18 @@
+ # define ModernElfLinkAvailable NO
+ #endif
+
+-cannaPrefix = DefCannaPrefix
++cannaPrefix = /usr
+ cannaExecPrefix = $(cannaPrefix)
+ cannaBinDir = $(cannaExecPrefix)/bin
+ cannaSrvDir = DefCannaSrvDir
+ XCOMM cannaLibDir = /var/lib/canna
+ XCOMM cannaLibDir = /var/db/canna
+ cannaLibDir = DefCannaLibDir
+-XCOMM cannaManDir = $(cannaPrefix)/share/man
+-cannaManDir = $(cannaPrefix)/man
++cannaManDir = $(cannaPrefix)/share/man
++XCOMM cannaManDir = $(cannaPrefix)/man
+ cannaIncDir = $(cannaPrefix)/include/canna
++cannaDocDir = $(cannaPrefix)/share/doc/@cannapkgver@
++cannaShareDir = $(cannaPrefix)/share/canna
+
+ libCannaDir = DefLibCannaDir
+ ErrDir = DefErrDir
+@@ -158,7 +160,7 @@
+ #define SupportOldWchar 1
+
+ /* IPv6¤òÍѤ¤¤ë¾ì¹ç¤Ï1¤ÈÄêµÁ¤·¤Æ¤¯¤À¤µ¤¤ */
+-#define UseInet6 0 /* requires newer IPv6 implementation */
++/* #define UseInet6 0 /* requires newer IPv6 implementation */
+
+ /* 3.2·Ï¤«¤é3.6·Ï¤Þ¤Ç¤Î·Á¼°¤Î¼­½ñ¤òºî¤ë¾ì¹ç¤Ï¤³¤ì¤òÄêµÁ¤·¤Æ¤¯¤À¤µ¤¤ */
+ /* #define DIC_3_6_COMPAT */
+@@ -237,7 +239,7 @@
+ /* #define UseInstalledLibCanna YES */
+ #define UseInstalledLibCanna NO
+
+-DicDir = $(cannaLibDir)/dic
++DicDir = /var/lib/canna/dic
+
+ /* ¤³¤³¤«¤é²¼¤ÏÊѹ¹ÉÔÍפǤ¹ */
+
+diff -urN Canna37b1.ORIG/Imakefile Canna37b1/Imakefile
+--- Canna37b1.ORIG/Imakefile 2003-09-25 15:30:20.000000000 +0900
++++ Canna37b1/Imakefile 2003-09-27 19:09:00.000000000 +0900
+@@ -55,6 +55,7 @@
+ @echo "#define CANNAHOSTFILE '$(cannaLibDir)/cannahost'" >> junkjunk
+ @echo "/* for lib/canna */" >> junkjunk
+ @echo "#define CANNALIBDIR '$(cannaLibDir)'" >> junkjunk
++ @echo "#define CANNASHAREDIR '$(cannaShareDir)'" >> junkjunk
+ @echo "#define SUPPORT_OLD_WCHAR '$(supportOldWchar)'" >> junkjunk
+ @echo "/* for scripts */" >> junkjunk
+ @echo "#define CANNABINDIR $(cannaBinDir)" >> junkjunk
+@@ -83,6 +84,7 @@
+ echo "#define CANNAHOSTFILE \"$(cannaLibDir)/cannahost\"";\
+ echo "/* for lib/canna */";\
+ echo "#define CANNALIBDIR \"$(cannaLibDir)\""; \
++ echo "#define CANNASHAREDIR \"$(cannaShareDir)\""; \
+ echo "#define SUPPORT_OLD_WCHAR $(supportOldWchar)"; \
+ echo "/* for scripts */";\
+ echo "#define CANNABINDIR $(cannaBinDir)"; \
+diff -urN Canna37b1.ORIG/dic/phono/Imakefile Canna37b1/dic/phono/Imakefile
+--- Canna37b1.ORIG/dic/phono/Imakefile 2002-10-19 17:27:40.000000000 +0900
++++ Canna37b1/dic/phono/Imakefile 2003-09-27 19:09:00.000000000 +0900
+@@ -27,9 +27,10 @@
+
+ ROMAJI_DIC_DEF = -DSHIFT
+
+- DICDIR = $(cannaLibDir)/dic
+- SAMPLEDIR = $(cannaLibDir)/sample
+- SAMPLESRCDIR = $(cannaLibDir)/sample/src
++ DICDIR = $(DicDir)
++ CANNASHAREDIR = $(cannaShareDir)
++ SAMPLEDIR = $(cannaDocDir)/sample
++ SAMPLESRCDIR = $(cannaDocDir)/sample/src
+
+ KPDEF = default.kpdef jdaemon.kpdef just.kpdef kaisoku.kpdef kana.kpdef \
+ lan5.kpdef matsu.kpdef newjis.kpdef romaji.kpdef sokuon.kpdef \
+@@ -69,7 +70,7 @@
+ MakeDirectories(install,$(DICDIR))
+ MakeDirectories(install,$(SAMPLESRCDIR))
+
+-InstallMultiple($(ROMKANA_TABLES),$(DICDIR))
++InstallMultiple($(ROMKANA_TABLES),$(CANNASHAREDIR))
+
+ #ifdef USE_OBSOLETE_STYLE_FILENAME
+ InstallNonExec(default.kpdef,$(SAMPLESRCDIR))
+diff -urN Canna37b1.ORIG/lib/canna/romaji.c Canna37b1/lib/canna/romaji.c
+--- Canna37b1.ORIG/lib/canna/romaji.c 2003-09-17 17:50:53.000000000 +0900
++++ Canna37b1/lib/canna/romaji.c 2003-09-27 19:09:00.000000000 +0900
+@@ -427,7 +427,7 @@
+ }
+ }
+
+-#if 0 /* currently CANNASHAREDDIR is not defined */
++#if 1 /* currently CANNASHAREDDIR is defined */
+ if (retval == (struct RkRxDic *)NULL) { /* added for Debian by ISHIKAWA Mutsumi <ishikawa@linux.or.jp> */
+ extern jrUserInfoStruct *uinfo;
+
+diff -urN Canna37b1.ORIG/misc/Imakefile Canna37b1/misc/Imakefile
+--- Canna37b1.ORIG/misc/Imakefile 2003-03-05 04:23:53.000000000 +0900
++++ Canna37b1/misc/Imakefile 2003-09-27 19:09:00.000000000 +0900
+@@ -48,7 +48,7 @@
+ MakeLintLibSubdirs($(SUBDIRS))
+ MakeLintSubdirs($(SUBDIRS),install.ln,install.ln)
+
+-MakeDirectories(install,$(cannaLibDir)/sample/src)
++MakeDirectories(install,$(cannaDocDir)/sample/src)
+
+ #ifdef USE_OBSOLETE_STYLE_FILENAME
+ default.canna: default.ca
+@@ -58,8 +58,8 @@
+ $(CP) default.ca default.canna
+ #endif
+
+-InstallNonExec(default.canna,$(cannaLibDir))
+-InstallNonExec(is.c,$(cannaLibDir)/sample/src)
++InstallNonExec(default.canna,$(cannaDocDir))
++InstallNonExec(is.c,$(cannaDocDir)/sample/src)
+
+ clean::
+ $(RM) $(PROGRAMS)
+diff -urN Canna37b1.ORIG/misc/initfiles/Imakefile Canna37b1/misc/initfiles/Imakefile
+--- Canna37b1.ORIG/misc/initfiles/Imakefile 2003-02-04 05:13:01.000000000 +0900
++++ Canna37b1/misc/initfiles/Imakefile 2003-09-27 19:09:00.000000000 +0900
+@@ -6,7 +6,7 @@
+ #endif
+
+ CANNAROOT = ../..
+- SAMPLEDIR = $(cannaLibDir)/sample
++ SAMPLEDIR = $(cannaShareDir)
+
+ all::
+
diff --git a/app-i18n/canna/files/canna-3.7_p3-strip.patch b/app-i18n/canna/files/canna-3.7_p3-strip.patch
new file mode 100644
index 000000000000..ebcde1ef733a
--- /dev/null
+++ b/app-i18n/canna/files/canna-3.7_p3-strip.patch
@@ -0,0 +1,142 @@
+diff -Naur Canna37p3.orig/config.log Canna37p3/config.log
+--- Canna37p3.orig/config.log 1970-01-01 09:00:00.000000000 +0900
++++ Canna37p3/config.log 2009-09-21 10:25:33.000000000 +0900
+@@ -0,0 +1,126 @@
++This file contains any messages produced by compilers while
++running configure, to aid debugging if configure makes a mistake.
++
++It was created by canna configure 3.7p3, which was
++generated by GNU Autoconf 2.59. Invocation command line was
++
++ $ ./configure
++
++## --------- ##
++## Platform. ##
++## --------- ##
++
++hostname = lets
++uname -m = x86_64
++uname -r = 2.6.31-gentoo
++uname -s = Linux
++uname -v = #1 SMP PREEMPT Fri Sep 11 17:39:06 JST 2009
++
++/usr/bin/uname -p = Intel(R) Core(TM)2 Duo CPU L7300 @ 1.40GHz
++/bin/uname -X = unknown
++
++/bin/arch = unknown
++/usr/bin/arch -k = unknown
++/usr/convex/getsysinfo = unknown
++hostinfo = unknown
++/bin/machine = unknown
++/usr/bin/oslevel = unknown
++/bin/universe = unknown
++
++PATH: /usr/local/bin
++PATH: /usr/bin
++PATH: /bin
++PATH: /opt/bin
++PATH: /usr/x86_64-pc-linux-gnu/i686-pc-linux-gnu/gcc-bin/4.3.3
++PATH: /usr/x86_64-pc-linux-gnu/gcc-bin/4.4.1
++PATH: /usr/kde/3.5/bin
++PATH: /usr/qt/3/bin
++PATH: /opt/android-sdk-1.5/tools
++PATH: /opt/android-sdk-1.5/platforms/android-1.5/tools
++PATH: /usr/games/bin
++
++
++## ----------- ##
++## Core tests. ##
++## ----------- ##
++
++configure:1307: error: You cannot invloke configure directly.
++
++## ---------------- ##
++## Cache variables. ##
++## ---------------- ##
++
++ac_cv_env_CC_set=
++ac_cv_env_CC_value=
++ac_cv_env_CFLAGS_set=
++ac_cv_env_CFLAGS_value=
++ac_cv_env_CPPFLAGS_set=
++ac_cv_env_CPPFLAGS_value=
++ac_cv_env_CPP_set=
++ac_cv_env_CPP_value=
++ac_cv_env_LDFLAGS_set=
++ac_cv_env_LDFLAGS_value=
++ac_cv_env_build_alias_set=
++ac_cv_env_build_alias_value=
++ac_cv_env_host_alias_set=
++ac_cv_env_host_alias_value=
++ac_cv_env_target_alias_set=
++ac_cv_env_target_alias_value=
++
++## ----------------- ##
++## Output variables. ##
++## ----------------- ##
++
++CC=''
++CFLAGS=''
++CPP=''
++CPPFLAGS=''
++DEFS=''
++ECHO_C=''
++ECHO_N='-n'
++ECHO_T=''
++EGREP=''
++EXEEXT=''
++LDFLAGS=''
++LIBOBJS=''
++LIBS=''
++LTLIBOBJS=''
++OBJEXT=''
++PACKAGE_BUGREPORT='canna-dev@lists.sourceforge.jp'
++PACKAGE_NAME='canna'
++PACKAGE_STRING='canna 3.7p3'
++PACKAGE_TARNAME='canna'
++PACKAGE_VERSION='3.7p3'
++PATH_SEPARATOR=':'
++SHELL='/bin/sh'
++ac_ct_CC=''
++bindir='${exec_prefix}/bin'
++build_alias=''
++datadir='${prefix}/share'
++exec_prefix='NONE'
++host_alias=''
++includedir='${prefix}/include'
++infodir='${prefix}/info'
++libdir='${exec_prefix}/lib'
++libexecdir='${exec_prefix}/libexec'
++localstatedir='${prefix}/var'
++mandir='${prefix}/man'
++oldincludedir='/usr/include'
++prefix='NONE'
++program_transform_name='s,x,x,'
++sbindir='${exec_prefix}/sbin'
++sharedstatedir='${prefix}/com'
++sysconfdir='${prefix}/etc'
++target_alias=''
++
++## ----------- ##
++## confdefs.h. ##
++## ----------- ##
++
++#define PACKAGE_BUGREPORT "canna-dev@lists.sourceforge.jp"
++#define PACKAGE_NAME "canna"
++#define PACKAGE_STRING "canna 3.7p3"
++#define PACKAGE_TARNAME "canna"
++#define PACKAGE_VERSION "3.7p3"
++
++configure: exit 1
+diff -Naur Canna37p3.orig/server/Imakefile Canna37p3/server/Imakefile
+--- Canna37p3.orig/server/Imakefile 2004-04-27 06:48:37.000000000 +0900
++++ Canna37p3/server/Imakefile 2009-09-21 10:28:48.000000000 +0900
+@@ -6,7 +6,7 @@
+ #ifdef __EMX__
+ INSTFLAGS = $(INSTUGIDFLAGS)
+ #else
+- INSTFLAGS = -s $(INSTUGIDFLAGS)
++ INSTFLAGS = $(INSTUGIDFLAGS)
+ #endif
+ DEFINES = $(CANNASERVER_DEFINES) $(SIGNAL_DEFINES) ConnectionFlags
+ INCLUDES = -I$(CANNAROOT)/include
diff --git a/app-i18n/canna/files/canna-3.7_p3.confd b/app-i18n/canna/files/canna-3.7_p3.confd
new file mode 100644
index 000000000000..d3fdce5425a2
--- /dev/null
+++ b/app-i18n/canna/files/canna-3.7_p3.confd
@@ -0,0 +1,7 @@
+CANNASERVER_ENABLE_SYSLOG="yes"
+
+# Specify user to run as
+CANNASERVER_OWNER="bin"
+
+# Options for cannaserver
+CANNASERVER_OPTS=""
diff --git a/app-i18n/canna/files/canna-3.7_p3.initd b/app-i18n/canna/files/canna-3.7_p3.initd
new file mode 100644
index 000000000000..d6445626b24d
--- /dev/null
+++ b/app-i18n/canna/files/canna-3.7_p3.initd
@@ -0,0 +1,42 @@
+#!/sbin/runscript
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# CANNASERVER_OPTS and CANNASERVER_OWNER is defined in /etc/conf.d/canna
+CANNASERVER_LOGFILE="/var/log/canna/CANNA0msgs"
+
+depend() {
+ after logger
+}
+
+start() {
+ if [ -S /tmp/.iroha_unix/IROHA ] ; then
+ /usr/sbin/cannakill >/dev/null 2>&1
+ fi
+ rm -f /tmp/.iroha_unix/IROHA
+
+ if [ "${CANNASERVER_ENABLE_SYSLOG}" = "yes" ] ; then
+ CANNASERVER_OPTS="${CANNASERVER_OPTS} -syslog"
+ else
+ touch "${CANNASERVER_LOGFILE}"
+ chmod u+w "${CANNASERVER_LOGFILEj}"
+ fi
+
+ if [ ! -z "${CANNASERVER_OWNER}" ] ; then
+ if [ -f "${CANNASERVER_LOGFILE}" ] ; then
+ chown "${CANNASERVER_OWNER}" "${CANNASERVER_LOGFILE}"
+ fi
+ CANNASERVER_OPTS="${CANNASERVER_OPTS} -u ${CANNASERVER_OWNER}"
+ fi
+
+ ebegin "Starting canna"
+ /usr/sbin/cannaserver ${CANNASERVER_OPTS}
+ eend $? "Failed to start canna"
+}
+
+stop() {
+ ebegin "Stopping canna"
+ /usr/sbin/cannakill
+ eend $? "Failed to stop canna"
+}
diff --git a/app-i18n/canna/files/canna-kpdef-gentoo.diff b/app-i18n/canna/files/canna-kpdef-gentoo.diff
new file mode 100644
index 000000000000..f458c53efdd7
--- /dev/null
+++ b/app-i18n/canna/files/canna-kpdef-gentoo.diff
@@ -0,0 +1,18 @@
+--- default.kpdef.orig 2002-10-19 17:27:40.000000000 +0900
++++ default.kpdef 2003-12-13 00:54:51.000000000 +0900
+@@ -350,3 +350,15 @@
+ _ ¡²
+ / ¡¿
+ \\ ¡ï
++
++# some useful romkan symbols
++z, ¡Å
++z- ¡Á
++z. ¡Ä
++z/ ¡¦
++z[ ¡Ø
++z] ¡Ù
++zh ¢«
++zj ¢­
++zk ¢¬
++zl ¢ª
diff --git a/app-i18n/canna/files/canna.confd b/app-i18n/canna/files/canna.confd
new file mode 100644
index 000000000000..1cb421388735
--- /dev/null
+++ b/app-i18n/canna/files/canna.confd
@@ -0,0 +1,8 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# Config file for /etc/init.d/canna
+
+# Specify user to run as
+CANNASERVER_OPTS=""
diff --git a/app-i18n/canna/files/canna.hosts b/app-i18n/canna/files/canna.hosts
new file mode 100644
index 000000000000..509143d86315
--- /dev/null
+++ b/app-i18n/canna/files/canna.hosts
@@ -0,0 +1 @@
+unix
diff --git a/app-i18n/canna/files/canna.initd b/app-i18n/canna/files/canna.initd
new file mode 100644
index 000000000000..d26393b179a4
--- /dev/null
+++ b/app-i18n/canna/files/canna.initd
@@ -0,0 +1,37 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# CANNASERVER_OPTS is defined in /etc/conf.d/canna
+
+depend() {
+ after logger
+}
+
+start() {
+ if [ -S /tmp/.iroha_unix/IROHA ] ; then
+ /usr/sbin/cannakill >/dev/null 2>&1
+ fi
+ rm -f /tmp/.iroha_unix/IROHA
+
+ if [ "${CANNASERVER_OPTS}" = "${CANNASERVER_OPTS/-syslog/}" ] ; then
+ if [ ! -f /var/log/canna/CANNA0msgs ] ; then
+ touch /var/log/canna/CANNA0msgs
+ fi
+ if [ "${CANNASERVER_OPTS}" != "${CANNASERVER_OPTS/-u/}" ] ; then
+ chown `echo ${CANNASERVER_OPTS} | sed -e 's/.*-u *\(\w*\).*/\1/'` /var/log/canna/CANNA0msgs
+ fi
+ chmod u+w /var/log/canna/CANNA0msgs
+ fi
+
+ ebegin "Starting canna"
+ /usr/sbin/cannaserver ${CANNASERVER_OPTS}
+ eend $? "Failed to start canna"
+}
+
+stop() {
+ ebegin "Stopping canna"
+ /usr/sbin/cannakill
+ eend $? "Failed to stop canna"
+}
diff --git a/app-i18n/canna/files/update-canna-dics_dir b/app-i18n/canna/files/update-canna-dics_dir
new file mode 100644
index 000000000000..a57290ec3bad
--- /dev/null
+++ b/app-i18n/canna/files/update-canna-dics_dir
@@ -0,0 +1,36 @@
+#!/bin/sh
+# update-canna-dics_dir
+# compiles dics.dir files for Canna Server
+# Copyright 2001 ISHIKAWA Mutsumi
+# Licensed under the GNU General Public License, version 2. See the file
+# /usr/share/common-licenses/GPL or <http://www.gnu.org/copyleft/gpl.txt>.
+
+SRC=/var/lib/canna/dic/dics.d
+DEST=/var/lib/canna/dic/canna
+
+for DIR in $SRC $DEST; do
+ VALID=yes
+ if [ ! -d $DIR ]; then
+ echo "$0: $DIR does not exist or is not a directory." >&2
+ VALID=
+ fi
+done
+
+if [ -n "$VALID" ]; then
+ # write new dics.dir file in case we are interrupted
+ echo '# dics.dir -- automatically generated file. DO NOT EDIT.' > $DEST/dics.dir.update-new
+# echo '# To modify, see update-canna-dics_dir(8). >> $DEST/dics.dir.update-new
+ # are there any files to process?
+ if [ "$(echo $SRC/*.dics.dir)" != "$SRC/*.dics.dir" ]; then
+ for file in $SRC/*.dics.dir; do
+ echo "# $file" >> $DEST/dics.dir.update-new
+ cat $file >> $DEST/dics.dir.update-new
+ done
+ mv $DEST/dics.dir.update-new $DEST/dics.dir
+ else
+ # no files to process, remove the one
+ rm -f $DEST/dics.dir
+ fi
+fi
+
+exit
diff --git a/app-i18n/canna/metadata.xml b/app-i18n/canna/metadata.xml
new file mode 100644
index 000000000000..12ed83cf199d
--- /dev/null
+++ b/app-i18n/canna/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cjk</herd>
+ <upstream>
+ <remote-id type="sourceforge-jp">canna</remote-id>
+ </upstream>
+</pkgmetadata>