summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2017-10-23 21:20:20 +0200
committerMike Gilbert <floppym@gentoo.org>2017-10-23 15:27:05 -0400
commite764c7c465df99e25f8c44202407b9d1d5e60533 (patch)
tree06cf1a781a5232b6c549fc243b03194babf5f986 /app-i18n/fcitx-table-extra
parentapp-i18n/fcitx-table-extra: Version bump (0.3.8). (diff)
downloadgentoo-e764c7c465df99e25f8c44202407b9d1d5e60533.tar.gz
gentoo-e764c7c465df99e25f8c44202407b9d1d5e60533.tar.bz2
gentoo-e764c7c465df99e25f8c44202407b9d1d5e60533.zip
app-i18n/fcitx-table-extra: Add live ebuild.
Diffstat (limited to 'app-i18n/fcitx-table-extra')
-rw-r--r--app-i18n/fcitx-table-extra/fcitx-table-extra-4.9999.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-i18n/fcitx-table-extra/fcitx-table-extra-4.9999.ebuild b/app-i18n/fcitx-table-extra/fcitx-table-extra-4.9999.ebuild
new file mode 100644
index 000000000000..e1797eacb82b
--- /dev/null
+++ b/app-i18n/fcitx-table-extra/fcitx-table-extra-4.9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils gnome2-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/fcitx-table-extra"
+fi
+
+DESCRIPTION="Extra Chinese table input methods for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx-table-extra"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+"
+SLOT="4"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4[table]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=(AUTHORS)
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}