summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-04-30 12:56:23 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-04-30 20:18:16 +0200
commit967fc550f9441189e7f8d6eb5415e3460195c5fe (patch)
tree8c3796ad7fd88d8e3dd52a91bf5420d94a1b7f0c /app-i18n
parentgnome-extra/gnome-shell-extensions-topicons-plus: Bump to v27 (diff)
downloadgentoo-967fc550f9441189e7f8d6eb5415e3460195c5fe.tar.gz
gentoo-967fc550f9441189e7f8d6eb5415e3460195c5fe.tar.bz2
gentoo-967fc550f9441189e7f8d6eb5415e3460195c5fe.zip
app-i18n/tomoe-gtk: Drop USE python
Bug: https://bugs.gentoo.org/695012 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/tomoe-gtk/tomoe-gtk-0.6.0-r6.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-i18n/tomoe-gtk/tomoe-gtk-0.6.0-r6.ebuild b/app-i18n/tomoe-gtk/tomoe-gtk-0.6.0-r6.ebuild
new file mode 100644
index 000000000000..d5d63f1ff2b1
--- /dev/null
+++ b/app-i18n/tomoe-gtk/tomoe-gtk-0.6.0-r6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+DESCRIPTION="Tomoe GTK+ interface widget library"
+HOMEPAGE="http://tomoe.osdn.jp/"
+SRC_URI="mirror://sourceforge/tomoe/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="static-libs"
+
+RDEPEND="app-i18n/tomoe
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --without-python \
+ --without-gucharmap
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+}