summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
commit398a42634f34afa1979d88ae1d8b38194e911c2d (patch)
treed6a45bdf7b35b71c192602a46e8d98d12a88cb02 /app-laptop
parentdev-ros/geometric_shapes: Remove old (diff)
downloadgentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.gz
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.bz2
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.zip
*/*: [QA] Remove redundant `|| die` guards
* Since all ebuilds in the tree are EAPI>=4, `|| die` on builtin commands is redundant and dead code. Closes: https://github.com/gentoo/gentoo/pull/13940 Reviewed-by: Ulrich Müller <ulm@gentoo.org> Reviewed-by: Michał Górny <mgorny@gentoo.org> Reviewed-by: Andreas K. Hüttel <dilfridge@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/hdaps-gl/hdaps-gl-0.0.5.ebuild3
-rw-r--r--app-laptop/pommed/pommed-1.39-r1.ebuild6
2 files changed, 4 insertions, 5 deletions
diff --git a/app-laptop/hdaps-gl/hdaps-gl-0.0.5.ebuild b/app-laptop/hdaps-gl/hdaps-gl-0.0.5.ebuild
index 7bc369635dc7..a4c362d093ee 100644
--- a/app-laptop/hdaps-gl/hdaps-gl-0.0.5.ebuild
+++ b/app-laptop/hdaps-gl/hdaps-gl-0.0.5.ebuild
@@ -24,8 +24,7 @@ src_prepare() {
src_compile() {
emake CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS} ${LDFLAGS}" \
- || die "emake failed"
+ CFLAGS="${CFLAGS} ${LDFLAGS}"
}
src_install() {
diff --git a/app-laptop/pommed/pommed-1.39-r1.ebuild b/app-laptop/pommed/pommed-1.39-r1.ebuild
index e915f399b70d..f1350763190b 100644
--- a/app-laptop/pommed/pommed-1.39-r1.ebuild
+++ b/app-laptop/pommed/pommed-1.39-r1.ebuild
@@ -47,7 +47,7 @@ src_prepare() {
src_compile() {
cd "${S}"/pommed
- emake CC="$(tc-getCC)" OFLIB=1 || die "emake pommed failed"
+ emake CC="$(tc-getCC)" OFLIB=1
if use gtk; then
cd "${S}"/gpomme
@@ -57,11 +57,11 @@ src_compile() {
POFILES="${POFILES} po/${LANG}.po"
fi
done
- emake CC="$(tc-getCC)" POFILES="${POFILES}" || die "emake gpomme failed"
+ emake CC="$(tc-getCC)" POFILES="${POFILES}"
fi
if use X; then
cd "${S}"/wmpomme
- emake CC="$(tc-getCC)" || die "emake wmpomme failed"
+ emake CC="$(tc-getCC)"
fi
}