summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-15 00:53:23 +0000
committerSam James <sam@gentoo.org>2020-09-15 00:53:23 +0000
commite92fcd14a2d76daa9ae9ec7980c77ad17551abc0 (patch)
tree20e3656941a35549a7503f4e3e8321dce3df55f0 /app-misc/glastree
parentnet-mail/ripmime: port to EAPI 7 (diff)
downloadgentoo-e92fcd14a2d76daa9ae9ec7980c77ad17551abc0.tar.gz
gentoo-e92fcd14a2d76daa9ae9ec7980c77ad17551abc0.tar.bz2
gentoo-e92fcd14a2d76daa9ae9ec7980c77ad17551abc0.zip
app-misc/glastree: bump to 20150525 snapshot
Closes: https://bugs.gentoo.org/623466 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc/glastree')
-rw-r--r--app-misc/glastree/Manifest1
-rw-r--r--app-misc/glastree/glastree-1.04_p20150525.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-misc/glastree/Manifest b/app-misc/glastree/Manifest
index 52afda376f2e..a1675a5cacaa 100644
--- a/app-misc/glastree/Manifest
+++ b/app-misc/glastree/Manifest
@@ -1 +1,2 @@
DIST glastree-1.04.tar.gz 5846 BLAKE2B b380b577a712f08b0a3ec89627d9f8bd20c76244ab19c8e76d27ac2fa08b0242381c280430fafe8a43bef78de8954d4660051d7648550c4ecd789a8941b55a4d SHA512 81b819bc91780f42f945db13efc97faadd661c3272007dc0b90ed998776d3fc0fbe406249f069f0065271208c9f6ccd0488021d384e05d5b9da39311bec8f94d
+DIST glastree-1.04_p20150525.tar.gz 5716 BLAKE2B e248d607ce87f4e78d880c67415c8eb15325a15dca222d14bc9fbafbcfd30c356f71a73fcfc4c8df80c645741e8b0edeca71cfdd0d66b284facad23b5322d64b SHA512 cff2fc671265f7be62b098f9c0a6f8c7711f86c014b64bd0bc1dde4c1570e7707de735d2a421e78d15ff126bcd6cbf18c90ba96bf7a5b30c5f6135c2e4a03179
diff --git a/app-misc/glastree/glastree-1.04_p20150525.ebuild b/app-misc/glastree/glastree-1.04_p20150525.ebuild
new file mode 100644
index 000000000000..8e8a41a96311
--- /dev/null
+++ b/app-misc/glastree/glastree-1.04_p20150525.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+COMMIT="1dc111308356d999f2a32aa50b6a0737ec5e6b09"
+DESCRIPTION="glastree is a poor mans snapshot utility using hardlinks written in perl"
+HOMEPAGE="http://www.igmus.org/code/"
+SRC_URI="https://github.com/jeremywohl/glastree/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Date-Calc
+"
+BDEPEND="test? ( ${RDEPEND} )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-posix-make.patch
+)
+
+src_compile() { :; }
+
+src_install() {
+ dodir /usr/share/man/man1
+ emake INSTROOT="${ED}"/usr INSTMAN=share/man install
+ dodoc README CHANGES THANKS
+}