summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-mobilephone/past
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-mobilephone/past')
-rw-r--r--app-mobilephone/past/Manifest1
-rw-r--r--app-mobilephone/past/files/past-0.0.4-gcc-4.7.patch10
-rw-r--r--app-mobilephone/past/metadata.xml7
-rw-r--r--app-mobilephone/past/past-0.0.4.ebuild24
4 files changed, 42 insertions, 0 deletions
diff --git a/app-mobilephone/past/Manifest b/app-mobilephone/past/Manifest
new file mode 100644
index 000000000000..ee522f9fc0da
--- /dev/null
+++ b/app-mobilephone/past/Manifest
@@ -0,0 +1 @@
+DIST 74036-past-0.0.4.tar.bz2 166745 SHA256 2b1b0eda11249360b9df70bbd7d4b8f3fe993ca30524138463df6ac587247cb1 SHA512 5ebce95f501e057cbfceb4019041e1dd844a464e656396c107ac9750e280dd544d0175d43bad53c94e10b587229cc5cc16e9d6f57401cdba6c539557daf3b0b0 WHIRLPOOL d0ca8e917f475fce0d0b7f1a0fd821178d8960286b967d8fb632e94c567de834e34bfa61144843ac608ff2633ef5f3a7466cac0ff73ba450f450fcf29e5dfaea
diff --git a/app-mobilephone/past/files/past-0.0.4-gcc-4.7.patch b/app-mobilephone/past/files/past-0.0.4-gcc-4.7.patch
new file mode 100644
index 000000000000..d2a82e025688
--- /dev/null
+++ b/app-mobilephone/past/files/past-0.0.4-gcc-4.7.patch
@@ -0,0 +1,10 @@
+--- src/device.cpp
++++ src/device.cpp
+@@ -22,6 +22,7 @@
+
+ extern "C" {
+ #include <gnokii.h>
++#include <unistd.h>
+ }
+
+ #include "device.h"
diff --git a/app-mobilephone/past/metadata.xml b/app-mobilephone/past/metadata.xml
new file mode 100644
index 000000000000..a40624fba8f0
--- /dev/null
+++ b/app-mobilephone/past/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/app-mobilephone/past/past-0.0.4.ebuild b/app-mobilephone/past/past-0.0.4.ebuild
new file mode 100644
index 000000000000..8966954ef363
--- /dev/null
+++ b/app-mobilephone/past/past-0.0.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit cmake-utils
+
+DESCRIPTION="A simple SMS tool"
+HOMEPAGE="http://www.kde-apps.org/content/show.php/past+-+SMS+Tool?content=74036"
+SRC_URI="http://www.kde-apps.org/CONTENT/content-files/74036-${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ app-mobilephone/gnokii[sms]"
+RDEPEND="${DEPEND}"
+
+DOCS=( ChangeLog TODO )
+PATCHES=( "${FILESDIR}/${P}-gcc-4.7.patch" )