summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-05-25 18:46:45 +0200
committerPacho Ramos <pacho@gentoo.org>2018-05-25 19:35:12 +0200
commit46a8352d8951ae456266280d50c50d4477cfda91 (patch)
tree36c2917ab6e14ce78eb415cc231f51940f659ee0 /app-pda
parentwww-plugins/freshplayerplugin: libva is always needed (#644936) (diff)
downloadgentoo-46a8352d8951ae456266280d50c50d4477cfda91.tar.gz
gentoo-46a8352d8951ae456266280d50c50d4477cfda91.tar.bz2
gentoo-46a8352d8951ae456266280d50c50d4477cfda91.zip
app-pda/iripdb: Fix building (#656342)
Package-Manager: Portage-2.3.38, Repoman-2.3.9
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/iripdb/iripdb-0.1.3b.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/app-pda/iripdb/iripdb-0.1.3b.ebuild b/app-pda/iripdb/iripdb-0.1.3b.ebuild
index f2d2e3a24e2e..959d4997dc63 100644
--- a/app-pda/iripdb/iripdb-0.1.3b.ebuild
+++ b/app-pda/iripdb/iripdb-0.1.3b.ebuild
@@ -2,10 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-
inherit toolchain-funcs
-MY_P=${P/iripdb/iRipDB}
+MY_P="${P/iripdb/iRipDB}"
DESCRIPTION="Allows generating the DB files necessary for the iRiver iHP-1xx"
HOMEPAGE="http://www.fataltourist.com/iripdb/"
@@ -13,15 +12,18 @@ SRC_URI="http://www.fataltourist.com/iripdb/${MY_P}.zip"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~amd64"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
-RDEPEND="media-libs/taglib
- sys-libs/zlib"
+RDEPEND="
+ media-libs/taglib
+ sys-libs/zlib
+"
DEPEND="${RDEPEND}
- app-arch/unzip"
+ app-arch/unzip
+"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${PN}"
src_compile() {
echo "$(tc-getCXX) ${CXXFLAGS} -c -o main.o main.cpp"