summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2020-05-08 11:08:43 -0700
committerBrian Dolbec <dolsen@gentoo.org>2020-05-08 11:11:43 -0700
commit0f701efbb429b24be5e5ef4945bafe55238f760a (patch)
tree85dee52a9599b22042732fb002c3792a2ff3ae86 /app-portage/layman/layman-2.4.2-r1.ebuild
parentdev-python/python-distutils-extra: Fix test failure due to LINGUAS (diff)
downloadgentoo-0f701efbb429b24be5e5ef4945bafe55238f760a.tar.gz
gentoo-0f701efbb429b24be5e5ef4945bafe55238f760a.tar.bz2
gentoo-0f701efbb429b24be5e5ef4945bafe55238f760a.zip
app-portage/layman: amd64 x86 stable wrt #720934
Clean out remaining deprecated eapi/python version Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'app-portage/layman/layman-2.4.2-r1.ebuild')
-rw-r--r--app-portage/layman/layman-2.4.2-r1.ebuild82
1 files changed, 0 insertions, 82 deletions
diff --git a/app-portage/layman/layman-2.4.2-r1.ebuild b/app-portage/layman/layman-2.4.2-r1.ebuild
deleted file mode 100644
index db47d4e416b3..000000000000
--- a/app-portage/layman/layman-2.4.2-r1.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-PYTHON_COMPAT=( python3_6 )
-PYTHON_REQ_USE="xml(+),sqlite?"
-
-inherit eutils distutils-r1 linux-info prefix
-
-DESCRIPTION="Tool to manage Gentoo overlays"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Layman"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="cvs darcs +git gpg g-sorcery mercurial sqlite squashfs subversion sync-plugin-portage test"
-RESTRICT="!test? ( test )"
-
-DEPEND="test? ( dev-vcs/subversion )
- "
-
-RDEPEND="
- cvs? ( dev-vcs/cvs )
- darcs? ( dev-vcs/darcs )
- git? ( dev-vcs/git )
- mercurial? ( dev-vcs/mercurial )
- g-sorcery? ( app-portage/g-sorcery )
- subversion? ( >=dev-vcs/subversion-1.5.4[http] )
- gpg? ( >=dev-python/pyGPG-0.2 )
- sync-plugin-portage? ( >=sys-apps/portage-2.2.16[${PYTHON_USEDEP}] )
- !sync-plugin-portage? ( sys-apps/portage[${PYTHON_USEDEP}] )
- >=dev-python/ssl-fetch-0.4[${PYTHON_USEDEP}]
- "
-
-layman_check_kernel_config() {
- local CONFIG_CHECK
- use squashfs && CONFIG_CHECK+=" ~BLK_DEV_LOOP ~SQUASHFS"
- [[ -n ${CONFIG_CHECK} ]] && check_extra_config
-}
-
-pkg_pretend() {
- layman_check_kernel_config
-}
-
-pkg_setup() {
- layman_check_kernel_config
-}
-
-python_prepare_all() {
- python_setup
- esetup.py setup_plugins
- distutils-r1_python_prepare_all
- eprefixify etc/layman.cfg layman/config.py
-}
-
-python_test() {
- suite=layman/tests/external.py
- PYTHONPATH="." "${PYTHON}" ${suite} || die "test suite '${suite}' failed"
- unset suite
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- insinto /etc/layman
- doins etc/layman.cfg
-
- doman doc/layman.8
- dohtml doc/layman.8.html
-
- keepdir /var/lib/layman
- keepdir /etc/layman/overlays
-}
-
-pkg_postinst() {
- # now run layman's update utility
- einfo "Running layman-updater..."
- "${EROOT}"/usr/bin/layman-updater
- einfo
-}