summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-02-20 23:31:13 +0000
committerSam James <sam@gentoo.org>2022-02-20 23:31:13 +0000
commitb227f966da1ea4bec531ad5efbcd099baa3e7b28 (patch)
tree3a31ceb26bcad7c9dd1fb3cdc8e1efc852fdbb5c /app-text/asciidoc
parentapp-office/texstudio: add 4.2.2 (diff)
downloadgentoo-b227f966da1ea4bec531ad5efbcd099baa3e7b28.tar.gz
gentoo-b227f966da1ea4bec531ad5efbcd099baa3e7b28.tar.bz2
gentoo-b227f966da1ea4bec531ad5efbcd099baa3e7b28.zip
app-text/asciidoc: add 10.1.3
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/asciidoc')
-rw-r--r--app-text/asciidoc/Manifest1
-rw-r--r--app-text/asciidoc/asciidoc-10.1.3.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-text/asciidoc/Manifest b/app-text/asciidoc/Manifest
index 53b283e93809..9f8df36dc7ed 100644
--- a/app-text/asciidoc/Manifest
+++ b/app-text/asciidoc/Manifest
@@ -1,4 +1,5 @@
DIST asciidoc-10.1.1.tar.gz 214619 BLAKE2B b7dc12d57cc3ad72301335ea84aea45db1a1e98f13aebf17fac6cf86657c509daa48ce1755817076c1c82f0a61c68fa7b178bc78bc6fda7274708bfde619491a SHA512 7b2b1ed9ea32b7336c271faf1e40e3a24d3b3af803c87f9d5d32c2b40cadaed682fbbedc6ec67bbe5a51377812d18180128c27779d7190898446266adee92842
+DIST asciidoc-10.1.3.tar.gz 215537 BLAKE2B 61613ded3f0b6b08b097534d88a14ff4b3820077dac14d9136462fe01727ea3134f05b0ddd3d81b31f9a6c2654cc8b775d6e4eb85b9edf8812a16191a43f587f SHA512 b060cb547e008dc2d4ca4646826c0968a0907ac0a2c13d8503e68be69e0ecef12d9a2f742e4614411202b6ea5fff6975bed0dbc07931b0b07a1462841d19c9ab
DIST asciidoc-9.0.5.new.tar.gz 1225334 BLAKE2B c3e428098dc4d71704ed13b54fd5f640b9de81d12939facb5faaf38a3123794e57201ecd9c312a22c220a2ec6b06c88a76ab47f05ffa972fc8751089b3471cfc SHA512 9125631fdee464f96f7e3c76a60fe37331905e9e55a81db27aece4065b246dc05a35db4c157dc7dbb2345eb95c153b474251d6a447d65774bf1b3f57e1883895
DIST asciidoc-9.1.0.new.tar.gz 1249958 BLAKE2B 0a98f58f7604f84d704092313c38563634bad5d697d60d02760f3be1d2a78a97ee2488dda3a9918b02e0062710175c6513d600f3fbd850fe700bf3fa917a3980 SHA512 c30854a936228fe5bcf2f9305741fbc4b17ef088b2fa637d5f3b19c7803306085634fb71146f0b089c2fad01f986da71a4fae364139f520c0906525317c0c4a6
DIST asciidoc-9.1.1.new.tar.gz 1259206 BLAKE2B da274d3a9389ee2e42ad1be70467f11d0164df3e6f9102e6ef1be6a802dbeb12898786fa1fe37a95755d0db8c9df5d5dd3faf000dfb73b701a83af3cc0261606 SHA512 74b83e8c8904fd761783c2f572d353656fc0794c6cb427f61e9179c9f80b6fc3b3ee8d028baba4e25eafe5f8cf5318f9984a5828849a793a7520f83e6fe50d66
diff --git a/app-text/asciidoc/asciidoc-10.1.3.ebuild b/app-text/asciidoc/asciidoc-10.1.3.ebuild
new file mode 100644
index 000000000000..705aa07cc25d
--- /dev/null
+++ b/app-text/asciidoc/asciidoc-10.1.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1 optfeature readme.gentoo-r1
+
+DESCRIPTION="A plain text human readable/writable document format"
+HOMEPAGE="https://asciidoc.org/ https://github.com/asciidoc-py/asciidoc-py/"
+# Could use the github tarball but we need autotools then
+#SRC_URI="https://github.com/asciidoc-py/asciidoc-py/releases/download/${PV}/${P}.tar.gz"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="app-text/docbook-xml-dtd:4.5
+ >=app-text/docbook-xsl-stylesheets-1.75
+ dev-libs/libxslt
+ dev-libs/libxml2:2"
+
+DOC_CONTENTS="
+If you are going to use a2x, please also look at a2x(1) under
+REQUISITES for a list of runtime dependencies.
+"
+
+src_install() {
+ distutils-r1_src_install
+
+ # TODO: Consider using Debian patch to allow /usr/share?
+ insinto /usr/share/asciidoc
+ doins -r asciidoc/resources/.
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+
+ optfeature "music filter support" "media-sound/lilypond virtual/imagemagick-tools"
+ optfeature "source filter support" "dev-util/source-highlight dev-python/pygments app-text/highlight"
+ optfeature "latex filter support" "dev-texlive/texlive-latex app-text/dvipng" "dev-texlive/texlive-latex app-text/dvisvgm"
+ optfeature "graphviz filter support" "media-gfx/graphviz"
+}