summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-12 12:50:43 +0000
committerSam James <sam@gentoo.org>2021-01-12 12:51:07 +0000
commitf344ba337727c9a2cacd0ac7b66002749e1451d2 (patch)
tree5959450fe2c228189e39f9d5a3de5ef0e0dd1c63 /app-text/bibclean
parentapp-text/teckit: bump to 2.5.10 (diff)
downloadgentoo-f344ba337727c9a2cacd0ac7b66002749e1451d2.tar.gz
gentoo-f344ba337727c9a2cacd0ac7b66002749e1451d2.tar.bz2
gentoo-f344ba337727c9a2cacd0ac7b66002749e1451d2.zip
app-text/bibclean: bump to 3.04
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/bibclean')
-rw-r--r--app-text/bibclean/Manifest1
-rw-r--r--app-text/bibclean/bibclean-3.04.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/app-text/bibclean/Manifest b/app-text/bibclean/Manifest
index c2646ad9b744..03fc45bbd3fd 100644
--- a/app-text/bibclean/Manifest
+++ b/app-text/bibclean/Manifest
@@ -1 +1,2 @@
DIST bibclean-2.17.tar.bz2 2253830 BLAKE2B 4d707f8d07f04c45c44fbea2b12bfffc7636cef2a847d90e62f339cb8fdadbb416cd89c2ba1cb04b0fc9c736dd7ca8480a2cbd4dab9c27b1f6804ddd18fc5419 SHA512 5f0d6b315ecc98c47f48c1e5fe7bcbd374cf97dec5cc97ce4438300a7419e6b2f1efae313efdf9d21211e9cd658c1f4bac10aa3b0d55dfa8a5783d982b1dde0f
+DIST bibclean-3.04.tar.gz 2712015 BLAKE2B 80d2fccb3b453dfda935bedd73ea2173b6ba1416c425a094c6ca915e86a886fe269b2f0e392274775228b03578ccf19da03291ed644f589edec1692120456a99 SHA512 7cdd22d07f627944d90e04ca73c3c82529e2fa9a011469f8d5b418f7651332b4e8c29aceda32b966bb1778151505d7f135ead6a12db8975ff46f650c4c43b4f3
diff --git a/app-text/bibclean/bibclean-3.04.ebuild b/app-text/bibclean/bibclean-3.04.ebuild
new file mode 100644
index 000000000000..d7f1a69fa5e6
--- /dev/null
+++ b/app-text/bibclean/bibclean-3.04.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="BibTeX bibliography prettyprinter and syntax checker"
+SRC_URI="ftp://ftp.math.utah.edu/pub/bibclean/${P}.tar.gz"
+HOMEPAGE="http://www.math.utah.edu/pub/bibclean/"
+
+# http://packages.debian.org/changelogs/pool/main/b/bibclean/bibclean_2.11.4-5/bibclean.copyright
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+SLOT="0"
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin bibclean
+ newman bibclean.man bibclean.1
+}