summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/bibletime
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/bibletime')
-rw-r--r--app-text/bibletime/Manifest2
-rw-r--r--app-text/bibletime/bibletime-2.10.1.ebuild69
-rw-r--r--app-text/bibletime/bibletime-2.9.1.ebuild48
-rw-r--r--app-text/bibletime/files/bibletime-2.10.1-qt5-printsupport.patch21
-rw-r--r--app-text/bibletime/metadata.xml14
5 files changed, 154 insertions, 0 deletions
diff --git a/app-text/bibletime/Manifest b/app-text/bibletime/Manifest
new file mode 100644
index 000000000000..aa37b262db44
--- /dev/null
+++ b/app-text/bibletime/Manifest
@@ -0,0 +1,2 @@
+DIST bibletime-2.10.1.tar.xz 3252680 SHA256 86d2d53913c08bce9f67c0d897639091d84e9d330527636cecd2b9008bf7ca91 SHA512 50f84eb1aefe911f1336ec7a23ea34ade1628383f35dca25330984787221214c0bc0cbc9f88f9540336949df02e76e769b7998d2eef3a15862e3038541564cc9 WHIRLPOOL 2ffc1b1b516d7fa94e842c957dc0be47be5e29ea015fcee2ff291093d0afc201af59d70b055193b420ff3acbc62386980b540eeb63ed92dbd1a741fb68b5be54
+DIST bibletime-2.9.1.tar.bz2 5968979 SHA256 308a86d4a1f63203e01438e75be8306377927498b5d0ae8769a4df3c828013b5 SHA512 6099e48fc3d54cb8362ec1a3965b372e60fd136d036dfd8d94b5e443ee5f27eb092162b653160bfc71d5366f79af35e22ee40d64ecd681f184bc4e90c1cd9e0a WHIRLPOOL 0677646ce099297321c4a519364b41254544f6d8660d72f9e76b6a8eafd08205915f40aef5bbc6463199ca0d272e28b926b13b0637ecdef1bc822256363cecf2
diff --git a/app-text/bibletime/bibletime-2.10.1.ebuild b/app-text/bibletime/bibletime-2.10.1.ebuild
new file mode 100644
index 000000000000..3ab39bff1aa5
--- /dev/null
+++ b/app-text/bibletime/bibletime-2.10.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="Qt Bible study application using the SWORD library"
+HOMEPAGE="http://www.bibletime.info/"
+SRC_URI="mirror://sourceforge/project/bibletime/BibleTime%202/BibleTime%202%20source%20code/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug qt5"
+
+# bug 313657
+# RESTRICT="test"
+
+RDEPEND="
+ >=app-text/sword-1.6.0
+ >=dev-cpp/clucene-2.3.3.4
+ qt5? (
+ dev-qt/linguist-tools:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwebkit:5
+ dev-qt/qtwidgets:5
+ )
+ !qt5? (
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ dev-qt/qtwebkit:4
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/boost
+ dev-libs/icu:=
+ net-misc/curl
+ sys-libs/zlib
+ qt5? (
+ dev-qt/qttest:5
+ )
+ !qt5? (
+ dev-qt/qttest:4
+ )
+"
+
+DOCS=( ChangeLog README )
+
+src_prepare() {
+ sed -e "s:Dictionary;Qt:Dictionary;Office;TextTools;Utility;Qt:" \
+ -i cmake/platforms/linux/bibletime.desktop.cmake || die "fixing .desktop file failed"
+ epatch "${FILESDIR}/${PN}-2.10.1-qt5-printsupport.patch"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT_WEBKIT=ON
+ )
+ if use !qt5; then
+ mycmakeargs+=(-DBT_FORCE_USE_QT4=)
+ fi
+
+ cmake-utils_src_configure
+}
diff --git a/app-text/bibletime/bibletime-2.9.1.ebuild b/app-text/bibletime/bibletime-2.9.1.ebuild
new file mode 100644
index 000000000000..a71f27691952
--- /dev/null
+++ b/app-text/bibletime/bibletime-2.9.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="Qt4 Bible study application using the SWORD library"
+HOMEPAGE="http://www.bibletime.info/"
+SRC_URI="mirror://sourceforge/project/bibletime/BibleTime%202/BibleTime%202%20source%20code/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="debug"
+
+# bug 313657
+# RESTRICT="test"
+
+RDEPEND="
+ >=app-text/sword-1.6.0
+ >=dev-cpp/clucene-2.3.3.4
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ dev-qt/qtwebkit:4"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/boost
+ dev-libs/icu:=
+ net-misc/curl
+ sys-libs/zlib
+ dev-qt/qttest:4"
+
+DOCS=( ChangeLog README )
+
+src_prepare() {
+ sed -e "s:Dictionary;Qt:Dictionary;Office;TextTools;Utility;Qt;:" \
+ -i cmake/platforms/linux/bibletime.desktop.cmake || die "fixing .desktop file failed"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT_WEBKIT=ON
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/app-text/bibletime/files/bibletime-2.10.1-qt5-printsupport.patch b/app-text/bibletime/files/bibletime-2.10.1-qt5-printsupport.patch
new file mode 100644
index 000000000000..203705485409
--- /dev/null
+++ b/app-text/bibletime/files/bibletime-2.10.1-qt5-printsupport.patch
@@ -0,0 +1,21 @@
+diff -ruN bibletime-2.10.1-orig/CMakeLists.txt bibletime-2.10.1/CMakeLists.txt
+--- bibletime-2.10.1-orig/CMakeLists.txt 2014-10-14 21:20:59.068697225 -0400
++++ bibletime-2.10.1/CMakeLists.txt 2014-10-14 21:23:20.045693427 -0400
+@@ -172,12 +172,14 @@
+ )
+
+ IF(${BIBLETIME_FRONTEND} STREQUAL "MOBILE")
+- qt5_use_modules("bibletime" Widgets Qml Quick Network)
++ qt5_use_modules("bibletime" Widgets Qml Quick Network PrintSupport)
+ ELSE()
+ IF(BT_Use_DBus)
+- qt5_use_modules("bibletime" DBus Widgets WebKit WebKitWidgets Xml Network)
++ qt5_use_modules("bibletime" DBus Widgets WebKit WebKitWidgets Xml
++ Network PrintSupport)
+ ELSE()
+- qt5_use_modules("bibletime" Widgets WebKit WebKitWidgets Xml Network)
++ qt5_use_modules("bibletime" Widgets WebKit WebKitWidgets Xml Network
++ PrintSupport)
+ ENDIF()
+ ENDIF()
+ ELSE()
diff --git a/app-text/bibletime/metadata.xml b/app-text/bibletime/metadata.xml
new file mode 100644
index 000000000000..9d025d57a4a1
--- /dev/null
+++ b/app-text/bibletime/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>theology</herd>
+ <longdescription>
+BibleTime is a Bible study application for Linux. It is based on the
+K Desktop Environment and uses the SWORD programming library to work
+with Bible texts, commentaries, dictionaries and books provided by
+the Crosswire Bible Society.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">bibletime</remote-id>
+ </upstream>
+</pkgmetadata>