summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-12-28 04:53:39 +1100
committerMichael Palimaka <kensington@gentoo.org>2015-12-28 04:53:53 +1100
commite3f1a50281a8983e74f8f6da1f0ee1836f61eb4b (patch)
tree4c6aa61e07ba7797942f1a0d50788478bc8416eb /app-text/bibletime
parentapp-text/bibletime: raise dependency required to build (diff)
downloadgentoo-e3f1a50281a8983e74f8f6da1f0ee1836f61eb4b.tar.gz
gentoo-e3f1a50281a8983e74f8f6da1f0ee1836f61eb4b.tar.bz2
gentoo-e3f1a50281a8983e74f8f6da1f0ee1836f61eb4b.zip
app-text/bibletime: backport patch from upstream solving build with Qt 5.5
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-text/bibletime')
-rw-r--r--app-text/bibletime/bibletime-2.10.1-r1.ebuild1
-rw-r--r--app-text/bibletime/files/bibletime-2.10.1-qt55.patch32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-text/bibletime/bibletime-2.10.1-r1.ebuild b/app-text/bibletime/bibletime-2.10.1-r1.ebuild
index 38cf72242537..7caac5080b1e 100644
--- a/app-text/bibletime/bibletime-2.10.1-r1.ebuild
+++ b/app-text/bibletime/bibletime-2.10.1-r1.ebuild
@@ -55,6 +55,7 @@ src_prepare() {
sed -e "s:Dictionary;Qt:Dictionary;Office;TextTools;Utility;Qt:" \
-i cmake/platforms/linux/bibletime.desktop.cmake || die "fixing .desktop file failed"
epatch "${FILESDIR}/${PN}-2.10.1-qt5-printsupport.patch"
+ epatch "${FILESDIR}/${PN}-2.10.1-qt55.patch"
}
src_configure() {
diff --git a/app-text/bibletime/files/bibletime-2.10.1-qt55.patch b/app-text/bibletime/files/bibletime-2.10.1-qt55.patch
new file mode 100644
index 000000000000..715792035039
--- /dev/null
+++ b/app-text/bibletime/files/bibletime-2.10.1-qt55.patch
@@ -0,0 +1,32 @@
+From: Gary Holmlund <gary.holmlund@gmail.com>
+Date: Fri, 3 Jul 2015 21:32:26 -0700
+Subject: [PATCH] backend: Fix Qt 5.5 compile error with Q_ASSERT.
+
+---
+ src/backend/drivers/cswordmoduleinfo.cpp | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/src/backend/drivers/cswordmoduleinfo.cpp b/src/backend/drivers/cswordmoduleinfo.cpp
+index f86f9ac..ae7444f 100644
+--- a/src/backend/drivers/cswordmoduleinfo.cpp
++++ b/src/backend/drivers/cswordmoduleinfo.cpp
+@@ -54,7 +54,7 @@ const unsigned long BT_MAX_LUCENE_FIELD_LENGTH = 1024 * 1024;
+ CSwordModuleInfo::CSwordModuleInfo(sword::SWModule * module,
+ CSwordBackend & backend,
+ ModuleType type)
+- : m_module((Q_ASSERT(module), module)),
++ : m_module(module),
+ m_backend(backend),
+ m_type(type),
+ m_cancelIndexing(false),
+@@ -63,6 +63,7 @@ CSwordModuleInfo::CSwordModuleInfo(sword::SWModule * module,
+ {
+ initCachedCategory();
+ initCachedLanguage();
++ Q_ASSERT(module);
+
+ m_hidden = btConfig().value<QStringList>("state/hiddenModules",
+ QStringList()).contains(m_cachedName);
+--
+2.4.10
+