summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Chren <dev.rindeal@gmail.com>2016-06-22 20:48:06 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-07-01 06:57:11 +0000
commit562c33b09723e25c816bc12bc77b5ad054c9fb17 (patch)
treea14012acef8085a55b08d750ff4f4751fe7c23d0 /app-text/cherrytree
parentapp-i18n/fcitx: Mark ~ppc64 (bug #568972). (diff)
downloadgentoo-562c33b09723e25c816bc12bc77b5ad054c9fb17.tar.gz
gentoo-562c33b09723e25c816bc12bc77b5ad054c9fb17.tar.bz2
gentoo-562c33b09723e25c816bc12bc77b5ad054c9fb17.zip
app-text/cherrytree: bump to v0.37.0
Closes: https://github.com/gentoo/gentoo/pull/1722 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-text/cherrytree')
-rw-r--r--app-text/cherrytree/Manifest1
-rw-r--r--app-text/cherrytree/cherrytree-0.37.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/app-text/cherrytree/Manifest b/app-text/cherrytree/Manifest
index 6b782004a4a2..c6fd3357bf20 100644
--- a/app-text/cherrytree/Manifest
+++ b/app-text/cherrytree/Manifest
@@ -1 +1,2 @@
DIST cherrytree-0.36.9.tar.gz 8725402 SHA256 37314cd9ba3e9bb87fb8ef9384da95db583543f2421f5243f7470d9903b3d8bf SHA512 fca9679dc1508b5db1fea9b10f3434f24b4545a53c9a586f1b21298e134242705e4ecc050e0ebffc972caca63c5f2803245b1e65191eed19b82a9cbdec3a40aa WHIRLPOOL edec306131fc09bde6f470c7e8bb1f795d7e54e3d1d0093c421bf515724f8f7d48fc3d024569279ee6db2e46b270db68d41fa4a1f816dfb1f8c9df40380d350d
+DIST cherrytree-0.37.0.tar.gz 8888703 SHA256 fa51071c8060fe337bf3092ab75188ce0bbd2ab1b34092607806787b116e54ed SHA512 a1aaf92657c58c70430a45adaa771050b43476bc2a33dc929b108842d5ef46aa83c4fa4cfe8c4f54a9a3656fc0d30046fae34cbac5aa9fe3f32aa539058636f5 WHIRLPOOL 59a8e68c9f2c031bf2acbee827dc73923f0e8f49ab9bf3a40f8b89683f0f2c343466783575b70a13821fc7409f47710fe089bbfcc4bc310a64cd78e68a25c319
diff --git a/app-text/cherrytree/cherrytree-0.37.0.ebuild b/app-text/cherrytree/cherrytree-0.37.0.ebuild
new file mode 100644
index 000000000000..3d8fa897cf6b
--- /dev/null
+++ b/app-text/cherrytree/cherrytree-0.37.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=true
+
+inherit fdo-mime distutils-r1
+
+DESCRIPTION='A hierarchical note taking application'
+HOMEPAGE='http://www.giuspen.com/cherrytree'
+LICENSE='GPL-3'
+
+SLOT='0'
+SRC_URI="https://github.com/giuspen/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS='~amd64 ~x86'
+IUSE='nls'
+
+RDEPEND="
+ x11-libs/libX11
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ >=dev-python/pygtk-2.16:2[${PYTHON_USEDEP}]
+ dev-python/pygtksourceview:2[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+"
+
+PLOCALES='cs de es fr hy it ja lt nl pl pt_BR ru sl tr uk zh_CN'
+inherit l10n
+
+python_prepare_all() {
+ if use nls ; then
+ l10n_find_plocales_changes 'locale' '' '.po'
+
+ rm_loc() {
+ rm -v -f "locale/${1}.po" || return 1
+ }
+ l10n_for_each_disabled_locale_do rm_loc
+ fi
+
+ sed -i '\|update-desktop-database|d' 'setup.py' || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ use nls || mydistutilsargs+=( '--without-gettext' )
+ distutils-r1_python_configure_all
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}