summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYury Martynov <email@linxon.ru>2019-11-19 14:46:27 +0300
committerJoonas Niilola <juippis@gentoo.org>2019-11-20 08:03:25 +0200
commita3cbfceb71db4831649a4d23566435f6065c27ec (patch)
tree791b4af617218097f9e552af4fc237216ebd9aaf /app-text/cherrytree
parentapp-text/cherrytree: 0.37.0 EAPI bump and other minor changes (diff)
downloadgentoo-a3cbfceb71db4831649a4d23566435f6065c27ec.tar.gz
gentoo-a3cbfceb71db4831649a4d23566435f6065c27ec.tar.bz2
gentoo-a3cbfceb71db4831649a4d23566435f6065c27ec.zip
app-text/cherrytree: bump to 0.38.9
Closes: https://bugs.gentoo.org/645662 Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Yury Martynov <email@linxon.ru> Closes: https://github.com/gentoo/gentoo/pull/13688 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-text/cherrytree')
-rw-r--r--app-text/cherrytree/Manifest1
-rw-r--r--app-text/cherrytree/cherrytree-0.38.9.ebuild54
-rw-r--r--app-text/cherrytree/files/cherrytree-0.38.9_update_setup_py.patch17
-rw-r--r--app-text/cherrytree/metadata.xml9
4 files changed, 80 insertions, 1 deletions
diff --git a/app-text/cherrytree/Manifest b/app-text/cherrytree/Manifest
index 56eb10b44076..171b610299ab 100644
--- a/app-text/cherrytree/Manifest
+++ b/app-text/cherrytree/Manifest
@@ -1 +1,2 @@
DIST cherrytree-0.37.0.tar.gz 8888703 BLAKE2B 737c0c247c581086e23e4c3e5fba0b18459788b385078ec8092af8b7352d77c8b273c939f702178d0ae59c8633bf996a7a7e5223e22da703ced3c8bf1d7cbde3 SHA512 a1aaf92657c58c70430a45adaa771050b43476bc2a33dc929b108842d5ef46aa83c4fa4cfe8c4f54a9a3656fc0d30046fae34cbac5aa9fe3f32aa539058636f5
+DIST cherrytree-0.38.9.tar.gz 9928805 BLAKE2B 4de4187ae7e650090d82de5e8b1b7f85c4af6dbb2c9b2bc67f10b074db4c08c4b4593c4769708bfaf584958eefe083a3626f7e9c4d7736bc53d143528c754e09 SHA512 40c1c26fa1a6868b447d31625c14b10cf712185289cf97b71881c253d2f72c58f51b974a1615fca5b532099c4741c56f8419df2d02e4ca821b2a1b909152e56b
diff --git a/app-text/cherrytree/cherrytree-0.38.9.ebuild b/app-text/cherrytree/cherrytree-0.38.9.ebuild
new file mode 100644
index 000000000000..80af20d9208c
--- /dev/null
+++ b/app-text/cherrytree/cherrytree-0.38.9.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+DISTUTILS_SINGLE_IMPL=true
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="A hierarchical note taking application"
+HOMEPAGE="https://www.giuspen.com/cherrytree"
+SRC_URI="https://github.com/giuspen/cherrytree/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="nls"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ dev-python/pygtksourceview:2[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )"
+
+PATCHES=( "${FILESDIR}"/${P}_update_setup_py.patch )
+
+python_configure_all() {
+ use nls || mydistutilsargs+=( --without-gettext )
+}
+
+src_install() {
+ distutils-r1_src_install
+ python_optimize "${D}/usr/share/${PN}/modules"
+
+ dodoc README.md changelog.txt
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}
diff --git a/app-text/cherrytree/files/cherrytree-0.38.9_update_setup_py.patch b/app-text/cherrytree/files/cherrytree-0.38.9_update_setup_py.patch
new file mode 100644
index 000000000000..aad93f93a154
--- /dev/null
+++ b/app-text/cherrytree/files/cherrytree-0.38.9_update_setup_py.patch
@@ -0,0 +1,17 @@
+diff -ur a/setup.py b/setup.py
+--- a/setup.py 2019-08-17 14:23:16.000000000 +0300
++++ b/setup.py 2019-11-17 15:33:44.243070851 +0300
+@@ -195,7 +195,7 @@
+ ("share/mime-info", ["linux/cherrytree.mime", "linux/cherrytree.keys"]),
+ ("share/application-registry", ["linux/cherrytree.applications"]),
+ ("share/metainfo", ["linux/cherrytree.appdata.xml"]),
+- ("share/man/man1", ["linux/cherrytree.1.gz"])
++ ("share/man/man1", ["linux/cherrytree.1"])
+ ],
+ cmdclass={
+ 'build': BuildData,
+@@ -205,4 +205,3 @@
+ },
+ distclass=CherryTreeDist
+ )
+- subprocess.call("update-desktop-database")
diff --git a/app-text/cherrytree/metadata.xml b/app-text/cherrytree/metadata.xml
index e69a8d811bcb..92aea49ad5a3 100644
--- a/app-text/cherrytree/metadata.xml
+++ b/app-text/cherrytree/metadata.xml
@@ -1,7 +1,14 @@
<?xml version='1.0' encoding='UTF-8'?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>email@linxon.ru</email>
+ <name>Yury Martynov</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<upstream>
<remote-id type="github">giuspen/cherrytree</remote-id>
</upstream>