summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Huettel <dilfridge@gentoo.org>2017-04-10 13:08:23 +0200
committerAndreas K. Huettel <dilfridge@gentoo.org>2017-04-10 13:08:23 +0200
commit240e67f593ca47dba51a6ddb950db9d03237e306 (patch)
tree2d6f9ec19c8cf8fc814d5cf4cc9d995afe8873bb /app-text/docbook-dsssl-stylesheets
parentapp-shells/tcsh: Remove old, bug 605728 (diff)
downloadgentoo-240e67f593ca47dba51a6ddb950db9d03237e306.tar.gz
gentoo-240e67f593ca47dba51a6ddb950db9d03237e306.tar.bz2
gentoo-240e67f593ca47dba51a6ddb950db9d03237e306.zip
app-text/docbook-dsssl-stylesheets: EAPI bump
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'app-text/docbook-dsssl-stylesheets')
-rw-r--r--app-text/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-1.79-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/app-text/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-1.79-r1.ebuild b/app-text/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-1.79-r1.ebuild
new file mode 100644
index 000000000000..83e19e3281a2
--- /dev/null
+++ b/app-text/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-1.79-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit sgml-catalog
+
+MY_P=${P/-stylesheets/}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="DSSSL Stylesheets for DocBook"
+HOMEPAGE="http://wiki.docbook.org/topic/DocBookDssslStylesheets"
+SRC_URI="mirror://sourceforge/docbook/${MY_P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE=""
+
+RDEPEND="app-text/sgml-common"
+
+sgml-catalog_cat_include "/etc/sgml/dsssl-docbook-stylesheets.cat" \
+ "/usr/share/sgml/docbook/dsssl-stylesheets-${PV}/catalog"
+sgml-catalog_cat_include "/etc/sgml/sgml-docbook.cat" \
+ "/etc/sgml/dsssl-docbook-stylesheets.cat"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ cp "${FILESDIR}/${PN}-1.77.Makefile" Makefile
+}
+
+src_compile() {
+ return 0
+}
+
+src_install() {
+ make \
+ BINDIR="${ED}/usr/bin" \
+ DESTDIR="${ED}/usr/share/sgml/docbook/dsssl-stylesheets-${PV}" \
+ install || die
+
+ dodir /usr/share/sgml/stylesheets/dsssl/
+
+ if [ -d "${EPREFIX}"/usr/share/sgml/stylesheets/dsssl/docbook ] &&
+ [ ! -L "${EPREFIX}"/usr/share/sgml/stylesheets/dsssl/docbook ]
+ then
+ ewarn "Not linking /usr/share/sgml/stylesheets/dsssl/docbook to"
+ ewarn "/usr/share/sgml/docbook/dsssl-stylesheets-${PV}"
+ ewarn "as directory already exists there. Will assume you know"
+ ewarn "what you're doing."
+ else
+ dosym /usr/share/sgml/docbook/dsssl-stylesheets-${PV} \
+ /usr/share/sgml/stylesheets/dsssl/docbook
+ fi
+
+ dodoc BUGS ChangeLog README RELEASE-NOTES.txt WhatsNew
+}