summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-06 02:20:22 +0100
committerSam James <sam@gentoo.org>2022-06-06 02:20:22 +0100
commit7b2394d840807c6c06bbd25b16b91953a82d864b (patch)
tree225ed2d9ad2cb307fce3b8749b4c28e57f0cc2d7 /app-text/dos2unix
parentmedia-libs/openimageio: add 2.3.16.0 (diff)
downloadgentoo-7b2394d840807c6c06bbd25b16b91953a82d864b.tar.gz
gentoo-7b2394d840807c6c06bbd25b16b91953a82d864b.tar.bz2
gentoo-7b2394d840807c6c06bbd25b16b91953a82d864b.zip
app-text/dos2unix: add 7.4.3
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/dos2unix')
-rw-r--r--app-text/dos2unix/Manifest1
-rw-r--r--app-text/dos2unix/dos2unix-7.4.3.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/app-text/dos2unix/Manifest b/app-text/dos2unix/Manifest
index 72471086c178..a7860f087875 100644
--- a/app-text/dos2unix/Manifest
+++ b/app-text/dos2unix/Manifest
@@ -1 +1,2 @@
DIST dos2unix-7.4.2.tar.gz 727429 BLAKE2B 5ba8aecfe3a79dfe9f4d7d69453fdcdd573c8889b41240c6bce5fea1b7e9e8213454af98f768cb2d199c85684a7d48192ba4bf856a92b867594b52a2209d5e04 SHA512 3fb77561596bafd83f3f7807ce967e58d5a96e5235afe3a4074ae7112297445690b2586bf652eb0b5bd1984fd41a79478355f6df8244561b4167a8a09593110d
+DIST dos2unix-7.4.3.tar.gz 788278 BLAKE2B da959b06e583bbf27a2cb2ce5b1f1a41380722aa09ac75b3d31260e92fd6f1203d87266d3a12201b036a69796b4aa4f23718741036e20fe686801bb368fbde22 SHA512 1c6d81348de8aca451174794141d0802685487cf6847fa91f7de745d89bcf2af864fc2ec549b9af72031891d4efcb9731fe823ce05da36d1f9e9890ff2cb60fb
diff --git a/app-text/dos2unix/dos2unix-7.4.3.ebuild b/app-text/dos2unix/dos2unix-7.4.3.ebuild
new file mode 100644
index 000000000000..65a984556454
--- /dev/null
+++ b/app-text/dos2unix/dos2unix-7.4.3.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PLOCALES="da de eo es fr fur hu ja nb nl pl pt_BR ru sr sv uk vi zh_CN zh_TW"
+
+inherit plocale toolchain-funcs
+
+DESCRIPTION="Convert DOS or MAC text files to UNIX format or vice versa"
+HOMEPAGE="http://www.xs4all.nl/~waterlan/dos2unix.html https://sourceforge.net/projects/dos2unix/"
+SRC_URI="
+ http://www.xs4all.nl/~waterlan/${PN}/${P/_/-}.tar.gz
+ mirror://sourceforge/${PN}/${P/_/-}.tar.gz"
+S="${WORKDIR}/${P/_/-}"
+
+LICENSE="BSD-2"
+SLOT="0"
+[[ "${PV}" == *_beta* ]] || \
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris"
+IUSE="debug nls test"
+
+RDEPEND="
+ !app-text/hd2u
+ virtual/libintl"
+
+DEPEND="
+ ${RDEPEND}
+ test? ( virtual/perl-Test-Simple )
+"
+BDEPEND="
+ dev-lang/perl
+ nls? ( sys-devel/gettext )
+"
+
+RESTRICT="!test? ( test )"
+
+handle_locales() {
+ # Make sure locale list is kept up-to-date.
+ local detected sorted
+ detected=$(echo $(printf '%s\n' */*.po | sed -e 's:.*/::' -e 's:.po$::' | sort -u))
+ sorted=$(echo $(printf '%s\n' ${PLOCALES} | sort -u))
+ if [[ ${sorted} != "${detected}" ]] ; then
+ eerror "The ebuild needs to be kept in sync."
+ eerror "PLOCALES: ${sorted}"
+ eerror "po*/*.po: ${detected}"
+ die "sync PLOCALES"
+ fi
+
+ # Deal with selective install of locales.
+ rm_loc() { rm po*/$1.po || die; }
+ plocale_for_each_disabled_locale rm_loc
+}
+
+src_prepare() {
+ default
+
+ handle_locales
+
+ sed \
+ -e '/^LDFLAGS/s|=|+=|' \
+ -e '/CFLAGS_OS \+=/d' \
+ -e '/LDFLAGS_EXTRA \+=/d' \
+ -e "/^CFLAGS/s|-O2|${CFLAGS}|" \
+ -i Makefile || die
+
+ if use debug ; then
+ sed -e "/^DEBUG/s:0:1:" \
+ -e "/EXTRA_CFLAGS +=/s:-g::" \
+ -i Makefile || die
+ fi
+
+ tc-export CC
+}
+
+lintl() {
+ # same logic as from virtual/libintl
+ use !elibc_glibc && use !elibc_musl && echo "-lintl"
+}
+
+src_compile() {
+ emake prefix="${EPREFIX}/usr" \
+ $(usex nls "LDFLAGS_EXTRA=$(lintl)" "ENABLE_NLS=")
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" \
+ $(usex nls "" "ENABLE_NLS=") install
+}