summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/fbreader
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/fbreader')
-rw-r--r--app-text/fbreader/Manifest1
-rw-r--r--app-text/fbreader/fbreader-0.99.4-r1.ebuild76
-rw-r--r--app-text/fbreader/fbreader-0.99.4-r2.ebuild85
-rw-r--r--app-text/fbreader/files/fbreader-0.99.4-mimetypes.patch6
-rw-r--r--app-text/fbreader/files/fbreader-0.99.4-qreal-cast.patch13
-rw-r--r--app-text/fbreader/files/fbreader-0.99.4.patch8
-rw-r--r--app-text/fbreader/metadata.xml10
7 files changed, 199 insertions, 0 deletions
diff --git a/app-text/fbreader/Manifest b/app-text/fbreader/Manifest
new file mode 100644
index 000000000000..21a3b474c290
--- /dev/null
+++ b/app-text/fbreader/Manifest
@@ -0,0 +1 @@
+DIST fbreader-sources-0.99.4.tgz 2345664 SHA256 3d7c31d5ea314589d2a963290ad16f4d3d631a41e802b8b39f8be0c9f71eb8e9 SHA512 d4b11d7ab03df002ad4212db805b10b80a24ea4384e92122b12c25a3f817a0eb343509ae30e31d68417fd4ce27f77e043235436f0081ff2c785a2830d6211dc7 WHIRLPOOL 1d25ff39bcd93d3b0445abc76d3bbaf5e376385303fd71c98e3844123c85b9edd413f18c8d89a95807391ee2fb9c044d4dfc4b5898484548a011ecc22993e3d9
diff --git a/app-text/fbreader/fbreader-0.99.4-r1.ebuild b/app-text/fbreader/fbreader-0.99.4-r1.ebuild
new file mode 100644
index 000000000000..5b86080e93a3
--- /dev/null
+++ b/app-text/fbreader/fbreader-0.99.4-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib
+
+DESCRIPTION="E-Book Reader. Supports many e-book formats"
+HOMEPAGE="http://www.fbreader.org/"
+SRC_URI="http://www.fbreader.org/files/desktop/${PN}-sources-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc x86"
+IUSE="debug"
+
+RDEPEND="
+ app-arch/bzip2
+ dev-libs/expat
+ dev-libs/liblinebreak
+ dev-libs/fribidi
+ dev-db/sqlite
+ net-misc/curl
+ sys-libs/zlib
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Still use linebreak instead of new unibreak
+ sed -e "s:-lunibreak:-llinebreak:" \
+ -i makefiles/config.mk zlibrary/text/Makefile || die "fixing libunibreak failed"
+
+ # Let portage decide about the compiler
+ sed -e "/^CC = /d" \
+ -i makefiles/arch/desktop.mk || die "removing CC line failed"
+
+ # let portage strip the binary
+ sed -e '/@strip/d' \
+ -i fbreader/desktop/Makefile || die
+
+ # Respect *FLAGS
+ sed -e "s/^CFLAGS = -pipe/CFLAGS +=/" \
+ -i makefiles/arch/desktop.mk || die "CFLAGS sed failed"
+ sed -e "/^ CFLAGS +=/ d" \
+ -i makefiles/config.mk || die "CFLAGS sed failed"
+ sed -e "/^ LDFLAGS += -s$/ d" \
+ -i makefiles/config.mk || die "sed failed"
+ sed -e "/^LDFLAGS =$/ d" \
+ -i makefiles/arch/desktop.mk || die "sed failed"
+
+ echo "TARGET_ARCH = desktop" > makefiles/target.mk
+ echo "LIBDIR = /usr/$(get_libdir)" >> makefiles/target.mk
+
+ echo "UI_TYPE = qt4" >> makefiles/target.mk
+ sed -e 's:MOC = moc-qt4:MOC = /usr/bin/moc:' \
+ -i makefiles/arch/desktop.mk || die "updating desktop.mk failed"
+
+ if use debug; then
+ echo "TARGET_STATUS = debug" >> makefiles/target.mk
+ else
+ echo "TARGET_STATUS = release" >> makefiles/target.mk
+ fi
+
+ # bug #452636
+ epatch "${FILESDIR}"/${P}.patch
+}
+
+src_install() {
+ default
+ dosym /usr/bin/FBReader /usr/bin/fbreader
+}
diff --git a/app-text/fbreader/fbreader-0.99.4-r2.ebuild b/app-text/fbreader/fbreader-0.99.4-r2.ebuild
new file mode 100644
index 000000000000..8741fcdae6e6
--- /dev/null
+++ b/app-text/fbreader/fbreader-0.99.4-r2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib
+
+DESCRIPTION="E-Book Reader. Supports many e-book formats"
+HOMEPAGE="http://www.fbreader.org/"
+SRC_URI="http://www.fbreader.org/files/desktop/${PN}-sources-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc x86"
+IUSE="debug"
+
+RDEPEND="
+ app-arch/bzip2
+ dev-libs/expat
+ dev-libs/liblinebreak
+ dev-libs/fribidi
+ dev-db/sqlite
+ net-misc/curl
+ sys-libs/zlib
+ dev-qt/qtcore:4[ssl]
+ dev-qt/qtgui:4
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Still use linebreak instead of new unibreak
+ sed -e "s:-lunibreak:-llinebreak:" \
+ -i makefiles/config.mk zlibrary/text/Makefile || die "fixing libunibreak failed"
+
+ # Let portage decide about the compiler
+ sed -e "/^CC = /d" \
+ -i makefiles/arch/desktop.mk || die "removing CC line failed"
+
+ # let portage strip the binary
+ sed -e '/@strip/d' \
+ -i fbreader/desktop/Makefile || die
+
+ # Respect *FLAGS
+ sed -e "s/^CFLAGS = -pipe/CFLAGS +=/" \
+ -i makefiles/arch/desktop.mk || die "CFLAGS sed failed"
+ sed -e "/^ CFLAGS +=/ d" \
+ -i makefiles/config.mk || die "CFLAGS sed failed"
+ sed -e "/^ LDFLAGS += -s$/ d" \
+ -i makefiles/config.mk || die "sed failed"
+ sed -e "/^LDFLAGS =$/ d" \
+ -i makefiles/arch/desktop.mk || die "sed failed"
+
+ echo "TARGET_ARCH = desktop" > makefiles/target.mk
+ echo "LIBDIR = /usr/$(get_libdir)" >> makefiles/target.mk
+
+ echo "UI_TYPE = qt4" >> makefiles/target.mk
+ sed -e 's:MOC = moc-qt4:MOC = /usr/bin/moc:' \
+ -i makefiles/arch/desktop.mk || die "updating desktop.mk failed"
+
+ if use debug; then
+ echo "TARGET_STATUS = debug" >> makefiles/target.mk
+ else
+ echo "TARGET_STATUS = release" >> makefiles/target.mk
+ fi
+
+ # bug #452636
+ epatch "${FILESDIR}"/${P}.patch
+ # bug #515698
+ epatch "${FILESDIR}"/${P}-qreal-cast.patch
+ # bug #516794
+ epatch "${FILESDIR}"/${P}-mimetypes.patch
+}
+
+src_compile() {
+ # bug #484516
+ emake -j1
+}
+
+src_install() {
+ default
+ dosym /usr/bin/FBReader /usr/bin/fbreader
+}
diff --git a/app-text/fbreader/files/fbreader-0.99.4-mimetypes.patch b/app-text/fbreader/files/fbreader-0.99.4-mimetypes.patch
new file mode 100644
index 000000000000..0e4a2935d442
--- /dev/null
+++ b/app-text/fbreader/files/fbreader-0.99.4-mimetypes.patch
@@ -0,0 +1,6 @@
+diff -r -U1 fbreader-0.99.4.orig/fbreader/desktop/desktop fbreader-0.99.4/fbreader/desktop/desktop
+--- fbreader-0.99.4.orig/fbreader/desktop/desktop 2012-11-30 19:41:25.000000000 +0700
++++ fbreader-0.99.4/fbreader/desktop/desktop 2014-07-10 20:56:33.527638562 +0700
+@@ -23 +23,2 @@
+ Categories=Office;Viewer;Literature;
++MimeType=application/epub+zip;application/rtf;application/x-fictionbook+xml;application/x-zip-compressed-fb2;application/x-mobipocket-ebook;application/xhtml+xml;text/html;text/plain;
diff --git a/app-text/fbreader/files/fbreader-0.99.4-qreal-cast.patch b/app-text/fbreader/files/fbreader-0.99.4-qreal-cast.patch
new file mode 100644
index 000000000000..ffd21b2924f7
--- /dev/null
+++ b/app-text/fbreader/files/fbreader-0.99.4-qreal-cast.patch
@@ -0,0 +1,13 @@
+diff -r -U1 fbreader-0.99.4.orig/zlibrary/ui/src/qt4/tree/QtWaitingSpinner.cpp fbreader-0.99.4/zlibrary/ui/src/qt4/tree/QtWaitingSpinner.cpp
+--- fbreader-0.99.4.orig/zlibrary/ui/src/qt4/tree/QtWaitingSpinner.cpp 2012-11-30 19:41:25.000000000 +0700
++++ fbreader-0.99.4/zlibrary/ui/src/qt4/tree/QtWaitingSpinner.cpp 2014-07-10 19:18:17.002886537 +0700
+@@ -88,3 +88,3 @@
+ void QtWaitingSpinner::setRoundness(qreal roundness) {
+- myRoundness = std::max(0.0, std::min(100.0, roundness));
++ myRoundness = std::max(static_cast<qreal>(0.0), std::min(static_cast<qreal>(100.0), roundness));
+ }
+@@ -150,3 +150,3 @@
+ qreal resultAlpha = color.alphaF() - gradation * distance;
+- resultAlpha = std::min(1.0, std::max(0.0, resultAlpha)); //if alpha is out of bound, force it to bounds
++ resultAlpha = std::min(static_cast<qreal>(1.0), std::max(static_cast<qreal>(0.0), resultAlpha)); //if alpha is out of bound, force it to bounds
+ color.setAlphaF(resultAlpha);
diff --git a/app-text/fbreader/files/fbreader-0.99.4.patch b/app-text/fbreader/files/fbreader-0.99.4.patch
new file mode 100644
index 000000000000..deb90228301d
--- /dev/null
+++ b/app-text/fbreader/files/fbreader-0.99.4.patch
@@ -0,0 +1,8 @@
+diff -r -U2 fbreader-0.99.4.orig/zlibrary/ui/src/qt4/filesystem/ZLQtFSManager.cpp fbreader-0.99.4/zlibrary/ui/src/qt4/filesystem/ZLQtFSManager.cpp
+--- fbreader-0.99.4.orig/zlibrary/ui/src/qt4/filesystem/ZLQtFSManager.cpp 2012-11-30 19:41:25.000000000 +0700
++++ fbreader-0.99.4/zlibrary/ui/src/qt4/filesystem/ZLQtFSManager.cpp 2013-02-21 13:30:31.000000000 +0700
+@@ -49,3 +49,4 @@
+ path = replacement + path.substr(1);
+ }
++ ZLUnixFSManager::normalizeRealPath(path);
+ }
diff --git a/app-text/fbreader/metadata.xml b/app-text/fbreader/metadata.xml
new file mode 100644
index 000000000000..2525aa08b3de
--- /dev/null
+++ b/app-text/fbreader/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>grozin@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ FBReader is an e-book reader for various platforms.
+ </longdescription>
+</pkgmetadata>