summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/groonga-normalizer-mysql
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/groonga-normalizer-mysql')
-rw-r--r--app-text/groonga-normalizer-mysql/Manifest2
-rw-r--r--app-text/groonga-normalizer-mysql/groonga-normalizer-mysql-1.0.6.ebuild38
-rw-r--r--app-text/groonga-normalizer-mysql/groonga-normalizer-mysql-1.0.9.ebuild38
-rw-r--r--app-text/groonga-normalizer-mysql/metadata.xml8
4 files changed, 86 insertions, 0 deletions
diff --git a/app-text/groonga-normalizer-mysql/Manifest b/app-text/groonga-normalizer-mysql/Manifest
new file mode 100644
index 000000000000..cd980310ad5d
--- /dev/null
+++ b/app-text/groonga-normalizer-mysql/Manifest
@@ -0,0 +1,2 @@
+DIST groonga-normalizer-mysql-1.0.6.tar.gz 430461 SHA256 7e037aa42b7a3212140674d39a8dc0d722670d744f99e019bde308db91eb4d85 SHA512 36ef0344ba73633669d12dd13b08cd336b2b77a7c76e11b52b5ce17fcf20b17a0ea8a3f68be1be91d07e3fe5a87b667664d7a503a54ba1cace3bd6c252286821 WHIRLPOOL 7e36266b5bade8bd1bb288f3936b059f57b24ea3662610999d5b9667688076b1de21d99ea21b774af43793fbef4feeb605eb4051bd95a5d0e0d36c49507307f7
+DIST groonga-normalizer-mysql-1.0.9.tar.gz 527908 SHA256 bb1dc59939464f833e94de64e33b2a643f5bee03cad28d92af70af9820519e70 SHA512 878d10dc6f7280c62e9563db19a61450a0181c19d47b2a5afe3bef4bfa157abfe3de726f0d61b6b7040b3b37abd78f63cd257f48fe779ff6a1ea0ed262b70a97 WHIRLPOOL 1ef11b150934d532a97be1ac8b43280989763e76d9bbadf1faeb0a99b6a68f0066ebac8bb66f8fdfe6fcfc94f9a127d5159119746c69307305b8a3ae160d88d9
diff --git a/app-text/groonga-normalizer-mysql/groonga-normalizer-mysql-1.0.6.ebuild b/app-text/groonga-normalizer-mysql/groonga-normalizer-mysql-1.0.6.ebuild
new file mode 100644
index 000000000000..a07d562eec6c
--- /dev/null
+++ b/app-text/groonga-normalizer-mysql/groonga-normalizer-mysql-1.0.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils autotools
+
+DESCRIPTION="Groonga plugin that provides MySQL compatible normalizers"
+HOMEPAGE="http://groonga.org/"
+SRC_URI="http://packages.groonga.org/source/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-text/groonga"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+DOCS=( README.md )
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --without-ruby19 \
+ --docdir="${EROOT}usr/share/doc/${P}"
+}
+
+src_install() {
+ default
+
+ prune_libtool_files
+ # Dont install README twice nor license
+ rm -r "${D}usr/share/doc/${PN}" || die
+}
diff --git a/app-text/groonga-normalizer-mysql/groonga-normalizer-mysql-1.0.9.ebuild b/app-text/groonga-normalizer-mysql/groonga-normalizer-mysql-1.0.9.ebuild
new file mode 100644
index 000000000000..554a7c22a685
--- /dev/null
+++ b/app-text/groonga-normalizer-mysql/groonga-normalizer-mysql-1.0.9.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils autotools
+
+DESCRIPTION="Groonga plugin that provides MySQL compatible normalizers"
+HOMEPAGE="http://groonga.org/"
+SRC_URI="http://packages.groonga.org/source/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-text/groonga"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+DOCS=( README.md )
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ # ruby is only uses for tests
+ econf \
+ --without-ruby \
+ --docdir="${EROOT}usr/share/doc/${P}"
+}
+
+src_install() {
+ default
+
+ prune_libtool_files
+ rm -r "${D}usr/share/doc/${PN}" || die
+}
diff --git a/app-text/groonga-normalizer-mysql/metadata.xml b/app-text/groonga-normalizer-mysql/metadata.xml
new file mode 100644
index 000000000000..c4773445434b
--- /dev/null
+++ b/app-text/groonga-normalizer-mysql/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>grknight@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
+