summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-07-31 04:26:45 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-07-31 04:26:45 +0200
commit95e1523009afb0c9985754b2d3a892ab3c2e96e7 (patch)
tree27a344dd775c1ba03f283216c0501310f8b824bf /app-text/krop
parentsys-kernel/git-sources: Linux patch 4.13-rc3 (diff)
downloadgentoo-95e1523009afb0c9985754b2d3a892ab3c2e96e7.tar.gz
gentoo-95e1523009afb0c9985754b2d3a892ab3c2e96e7.tar.bz2
gentoo-95e1523009afb0c9985754b2d3a892ab3c2e96e7.zip
app-text/krop: Version bump
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'app-text/krop')
-rw-r--r--app-text/krop/Manifest1
-rw-r--r--app-text/krop/krop-0.4.13.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/app-text/krop/Manifest b/app-text/krop/Manifest
index 852f089af494..8a98e7c71ca1 100644
--- a/app-text/krop/Manifest
+++ b/app-text/krop/Manifest
@@ -1,2 +1,3 @@
DIST krop-0.4.11.tar.gz 35450 SHA256 5dc069afdad722e030037f7cc54bfd8b4ff3990c5600947722303053d2519d0f SHA512 785ac432f7e906ebee167791751b164a0ec30087caef0916bcd95494d7db310949aa4e44569ddaa181daca9c5834b743d3fdc64183093a41e23bb58cbe0d6cae WHIRLPOOL 5c09ddfb50055dc5a5a27e3f21bff1d1a8d7759e60cd488c54538438f83d43cb8254bf4fe0c633a9d7852a27906f3049e5a15c1d6e6ca025d161ac6de7fee778
+DIST krop-0.4.13.tar.gz 36654 SHA256 46aad911c6c5d46201e5e8c21b85bcbf6f1d8f5d9889e96e7bcab2cb6dd26966 SHA512 2d2af25124b45108715eb90344a5683adbda4c788bd419360b641e9f47553fe143a40205a44af9b3e4db6df4148b3328547e774f24b5c7c0fd23c9206e8a14b2 WHIRLPOOL 5d1e39a16e9e985ba7a78f1384578ff7d2dfc818218d02bdae06d694a833c3839e8373ef02f56abdded053bdde2d9d0c433bb8f227d2163953c0a17d222e1c53
DIST krop-0.4.9.tar.gz 35149 SHA256 725d42358cc367e6ca4ad82d50fd9bd0bb8ad1e24094ff68880d06f675d59b0f SHA512 39e1d269fb59bbbba45e820ead482a6ac049e47e7d06459a2c63826dc134ada12e49e77468bfb6870f31747084bc8dea1653109232fe6e6808726a8903124565 WHIRLPOOL d4fbada0020ef08381f300faf470e9b1d239c7386999e3a6688c22cbb747f2a721445f7469c6a12918dd3c7711fc45bc00a8792011369f656a44806b1eaa508c
diff --git a/app-text/krop/krop-0.4.13.ebuild b/app-text/krop/krop-0.4.13.ebuild
new file mode 100644
index 000000000000..a4a95ac16ae7
--- /dev/null
+++ b/app-text/krop/krop-0.4.13.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit eutils distutils-r1
+
+DESCRIPTION="A tool to crop PDF files"
+HOMEPAGE="http://arminstraub.com/software/krop"
+SRC_URI="http://arminstraub.com/downloads/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/python-poppler-qt4[${PYTHON_USEDEP}]
+ dev-python/PyPDF2[${PYTHON_USEDEP}]
+ dev-python/PyQt4[${PYTHON_USEDEP}]"
+
+src_install() {
+ distutils-r1_src_install
+ domenu "${WORKDIR}/${P}/${PN}.desktop"
+}