summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/lcdf-typetools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/lcdf-typetools')
-rw-r--r--app-text/lcdf-typetools/Manifest2
-rw-r--r--app-text/lcdf-typetools/lcdf-typetools-2.104.ebuild29
-rw-r--r--app-text/lcdf-typetools/lcdf-typetools-2.97.ebuild25
-rw-r--r--app-text/lcdf-typetools/metadata.xml19
4 files changed, 75 insertions, 0 deletions
diff --git a/app-text/lcdf-typetools/Manifest b/app-text/lcdf-typetools/Manifest
new file mode 100644
index 000000000000..26c6b67eff1a
--- /dev/null
+++ b/app-text/lcdf-typetools/Manifest
@@ -0,0 +1,2 @@
+DIST lcdf-typetools-2.104.tar.gz 636875 SHA256 d7985458ead0850cb9549ff1d619ffc18da5d7be892be5e1fce6048d510f0fff SHA512 0d41386787aa18e5a7a85158ebba2046480c2320cbdfeaad75092962335f8f97a0ceede1aa301197d6c971bd6be729960c636fb14a8ce21e4c7f3f0e57257388 WHIRLPOOL 327e88a89cedb4a66fe93878c68dff11cb2b1d8d189eb3107f1782e67a70444ccee2b1ee6362f189441695f5e02a334311f9458a4a3f1d752fe22d863a2f3d20
+DIST lcdf-typetools-2.97.tar.gz 616431 SHA256 761746041c669fa3673a3e90ec7a247abd0e2782bdddf0fc5d7ab70b33b6f975 SHA512 8812436843721b7134ec796549092854050d1e9017fef048a62e7aa0e866d20e9757b246dbad738cdf8d8583afada3a2db9c6c7dc2546154cafd4dcd0f27f7f2 WHIRLPOOL 767a2a74a9f9b7a0c29407178b96a1455da39239b835f59def2ae77db068655a8953362c6f8d48a8a31fb6fc40dea405c0e6eb276fe60750e9dfbb11954bd972
diff --git a/app-text/lcdf-typetools/lcdf-typetools-2.104.ebuild b/app-text/lcdf-typetools/lcdf-typetools-2.104.ebuild
new file mode 100644
index 000000000000..393241d349e5
--- /dev/null
+++ b/app-text/lcdf-typetools/lcdf-typetools-2.104.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="Font utilities for eg manipulating OTF"
+SRC_URI="http://www.lcdf.org/type/${P}.tar.gz"
+HOMEPAGE="http://www.lcdf.org/type/#typetools"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="+kpathsea"
+
+RDEPEND="kpathsea? ( virtual/tex-base dev-libs/kpathsea )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ use kpathsea && has_version '>=dev-libs/kpathsea-6.2.1' && append-cppflags "$($(tc-getPKG_CONFIG) --cflags kpathsea)"
+ econf $(use_with kpathsea)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc NEWS README ONEWS
+}
diff --git a/app-text/lcdf-typetools/lcdf-typetools-2.97.ebuild b/app-text/lcdf-typetools/lcdf-typetools-2.97.ebuild
new file mode 100644
index 000000000000..ea522741bd7d
--- /dev/null
+++ b/app-text/lcdf-typetools/lcdf-typetools-2.97.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+DESCRIPTION="Font utilities for eg manipulating OTF"
+SRC_URI="http://www.lcdf.org/type/${P}.tar.gz"
+HOMEPAGE="http://www.lcdf.org/type/#typetools"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="+kpathsea"
+
+DEPEND="kpathsea? ( virtual/tex-base )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf $(use_with kpathsea)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc NEWS README ONEWS
+}
diff --git a/app-text/lcdf-typetools/metadata.xml b/app-text/lcdf-typetools/metadata.xml
new file mode 100644
index 000000000000..6ea4b725c435
--- /dev/null
+++ b/app-text/lcdf-typetools/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>fonts</herd>
+<maintainer>
+ <email>aballier@gentoo.org</email>
+ <name>Alexis Ballier</name>
+</maintainer>
+<longdescription lang="en">
+ The LCDF Typetools package contains several programs for manipulating
+ PostScript Type 1, Type 1 multiple master, and PostScript-flavored OpenType
+ fonts. LCDF Typetools includes the mmafm and mmpfb programs, which were
+ formerly distributed as part of a different package (mminstance).
+</longdescription>
+<use>
+ <flag name='kpathsea'>Enable integration with kpathsea search library
+ (TeX related)</flag>
+</use>
+</pkgmetadata>