summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-02-19 19:17:19 +0100
committerDavid Seifert <soap@gentoo.org>2018-02-19 20:40:02 +0100
commit06111229ebf32f3b305a5c02c8278d68bf2e7cc2 (patch)
tree21a271f7bcd9a2c49572937eedec8e523acb200e /app-text/libebook
parentapp-text/libabw: Always build in C++14 mode (diff)
downloadgentoo-06111229ebf32f3b305a5c02c8278d68bf2e7cc2.tar.gz
gentoo-06111229ebf32f3b305a5c02c8278d68bf2e7cc2.tar.bz2
gentoo-06111229ebf32f3b305a5c02c8278d68bf2e7cc2.zip
app-text/libebook: Always build in C++14 mode
Closes: https://bugs.gentoo.org/618854 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-text/libebook')
-rw-r--r--app-text/libebook/libebook-0.1.2-r1.ebuild7
-rw-r--r--app-text/libebook/libebook-0.1.3.ebuild5
2 files changed, 9 insertions, 3 deletions
diff --git a/app-text/libebook/libebook-0.1.2-r1.ebuild b/app-text/libebook/libebook-0.1.2-r1.ebuild
index 53975fc2cc1e..f7039345c935 100644
--- a/app-text/libebook/libebook-0.1.2-r1.ebuild
+++ b/app-text/libebook/libebook-0.1.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -6,7 +6,7 @@ EAPI=6
MY_PN="libe-book"
MY_P="${MY_PN}-${PV}"
-inherit autotools
+inherit autotools flag-o-matic
DESCRIPTION="Library parsing various ebook formats"
HOMEPAGE="http://www.sourceforge.net/projects/libebook/"
@@ -45,6 +45,9 @@ src_prepare() {
}
src_configure() {
+ # bug 618854
+ append-cxxflags -std=c++14
+
econf \
--disable-static \
--disable-werror \
diff --git a/app-text/libebook/libebook-0.1.3.ebuild b/app-text/libebook/libebook-0.1.3.ebuild
index e58db48faea1..381b4866c424 100644
--- a/app-text/libebook/libebook-0.1.3.ebuild
+++ b/app-text/libebook/libebook-0.1.3.ebuild
@@ -6,7 +6,7 @@ EAPI=6
MY_PN="libe-book"
MY_P="${MY_PN}-${PV}"
-inherit autotools
+inherit autotools flag-o-matic
DESCRIPTION="Library parsing various ebook formats"
HOMEPAGE="http://www.sourceforge.net/projects/libebook/"
@@ -41,6 +41,9 @@ src_prepare() {
}
src_configure() {
+ # bug 618854
+ append-cxxflags -std=c++14
+
econf \
--disable-static \
--disable-werror \