summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/libebook
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/libebook')
-rw-r--r--app-text/libebook/Manifest3
-rw-r--r--app-text/libebook/libebook-0.0.2.ebuild50
-rw-r--r--app-text/libebook/libebook-0.1.1.ebuild50
-rw-r--r--app-text/libebook/libebook-0.1.2.ebuild50
-rw-r--r--app-text/libebook/metadata.xml8
5 files changed, 161 insertions, 0 deletions
diff --git a/app-text/libebook/Manifest b/app-text/libebook/Manifest
new file mode 100644
index 000000000000..ceaa0d462cf2
--- /dev/null
+++ b/app-text/libebook/Manifest
@@ -0,0 +1,3 @@
+DIST libe-book-0.0.2.tar.bz2 409605 SHA256 c6f10ca827a2060e1a64497fbf43c5c113a07d4673f17a7c2c3da4ac6e2677ae SHA512 843fb7c92e7bedb3f7747e3baa547b14845718075c6fc5f12fdc0af91ca976014b651b8cc5960e7ae2bf7c89dcad99b9fd60712c68faccbcbd84fd0f54683e78 WHIRLPOOL 357fbac27c16d0e4cc2fb97561e8af817de65223099c6e1824a33b90a58b473aa2d379dc715c4dfd33aab168bdafa6be61b0076ad443ddb79d6be14322653591
+DIST libe-book-0.1.1.tar.bz2 466712 SHA256 90353fc60827a33b391d0b63ecfe5239229d489af99ff6ea014ede3b39fa32b5 SHA512 5d952cac33ece4481057686f89f5a953508e6d5b8ddfdb45c745f79c881cd4429ec0a8024144bfc9cc3a53f7a201f25e831f9125f7cc4fc8591563df09d1feec WHIRLPOOL ff702630f2b8e05edaba25bc2f003f21f2ba838a7876aaa03777146083cd4539479f74785a02b41e166e448de2b27e83e9816cfd8dd2d8fc7b314716929a4d8b
+DIST libe-book-0.1.2.tar.bz2 465922 SHA256 b710a57c633205b933015474d0ac0862253d1c52114d535dd09b20939a0d1850 SHA512 82982874f9c0f5e400166e9367a4b6017cf11bbd69e2e79240137385a5d68ddea08f13676f8c5d0e983f441de17cda9f4b5f7c90c5cb3515e319de638edf3a38 WHIRLPOOL 068e8ed47ea5ad231c47d8848157db6c0bdd03425f87f181c2b3ce23c8006a9d7e6848d9dee960d3ad0fd5dbc24f8e7a4d15249056a0ae58debbb653d10a8228
diff --git a/app-text/libebook/libebook-0.0.2.ebuild b/app-text/libebook/libebook-0.0.2.ebuild
new file mode 100644
index 000000000000..2797c91bf6c2
--- /dev/null
+++ b/app-text/libebook/libebook-0.0.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PN="libe-book"
+MY_P="${MY_PN}-${PV}"
+
+inherit eutils
+
+DESCRIPTION="Library parsing various ebook formats"
+HOMEPAGE="http://www.sourceforge.net/projects/libebook/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
+IUSE="doc test"
+
+RDEPEND="
+ >=app-text/libwpd-0.9.5:0.9
+ dev-libs/icu:=
+ dev-libs/libxml2
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost:=
+ dev-util/gperf
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? ( dev-util/cppunit )
+"
+RDEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ econf \
+ --disable-static \
+ --disable-werror \
+ $(use_with doc docs) \
+ $(use_enable test tests) \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
diff --git a/app-text/libebook/libebook-0.1.1.ebuild b/app-text/libebook/libebook-0.1.1.ebuild
new file mode 100644
index 000000000000..3f385d930dba
--- /dev/null
+++ b/app-text/libebook/libebook-0.1.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PN="libe-book"
+MY_P="${MY_PN}-${PV}"
+
+inherit eutils
+
+DESCRIPTION="Library parsing various ebook formats"
+HOMEPAGE="http://www.sourceforge.net/projects/libebook/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-libs/icu:=
+ dev-libs/librevenge
+ dev-libs/libxml2
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost:=
+ dev-util/gperf
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? ( dev-util/cppunit )
+"
+RDEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ econf \
+ --disable-static \
+ --disable-werror \
+ $(use_with doc docs) \
+ $(use_enable test tests) \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
diff --git a/app-text/libebook/libebook-0.1.2.ebuild b/app-text/libebook/libebook-0.1.2.ebuild
new file mode 100644
index 000000000000..34c586e4bf45
--- /dev/null
+++ b/app-text/libebook/libebook-0.1.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PN="libe-book"
+MY_P="${MY_PN}-${PV}"
+
+inherit eutils
+
+DESCRIPTION="Library parsing various ebook formats"
+HOMEPAGE="http://www.sourceforge.net/projects/libebook/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-libs/icu:=
+ dev-libs/librevenge
+ dev-libs/libxml2
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost:=
+ dev-util/gperf
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? ( dev-util/cppunit )
+"
+RDEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ econf \
+ --disable-static \
+ --disable-werror \
+ $(use_with doc docs) \
+ $(use_enable test tests) \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
diff --git a/app-text/libebook/metadata.xml b/app-text/libebook/metadata.xml
new file mode 100644
index 000000000000..b1538fa10966
--- /dev/null
+++ b/app-text/libebook/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>openoffice</herd>
+ <upstream>
+ <remote-id type="sourceforge">libebook</remote-id>
+ </upstream>
+</pkgmetadata>