summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatoro Mahri <matoro@users.noreply.github.com>2023-06-29 12:11:41 -0400
committerSam James <sam@gentoo.org>2023-07-09 05:46:52 +0100
commitee4823852ddac938004852416e907069beb8cdc3 (patch)
treeebf54de7ae14a5ecf03c45d0d89ac1b97df92244 /app-text/mandoc
parentsys-block/tgt: Keyword 1.0.86 alpha, #909352 (diff)
downloadgentoo-ee4823852ddac938004852416e907069beb8cdc3.tar.gz
gentoo-ee4823852ddac938004852416e907069beb8cdc3.tar.bz2
gentoo-ee4823852ddac938004852416e907069beb8cdc3.zip
app-text/mandoc: wire up tests
Bug: https://bugs.gentoo.org/908743 Signed-off-by: Matoro Mahri <matoro@users.noreply.github.com> Closes: https://github.com/gentoo/gentoo/pull/31668 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/mandoc')
-rw-r--r--app-text/mandoc/mandoc-1.14.6.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/app-text/mandoc/mandoc-1.14.6.ebuild b/app-text/mandoc/mandoc-1.14.6.ebuild
index 9af875d1eed0..a4127ae75473 100644
--- a/app-text/mandoc/mandoc-1.14.6.ebuild
+++ b/app-text/mandoc/mandoc-1.14.6.ebuild
@@ -12,7 +12,8 @@ SRC_URI="https://mdocml.bsd.lv/snapshots/${P}.tar.gz"
LICENSE="ISC"
SLOT="0"
KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~loong ~ppc ppc64 ~riscv ~s390 ~sparc x86"
-IUSE="cgi selinux system-man"
+IUSE="cgi selinux system-man test"
+RESTRICT="!test? ( test )"
RDEPEND="sys-libs/zlib
system-man? ( !sys-apps/man-db )
@@ -22,6 +23,7 @@ DEPEND="${RDEPEND}
"
BDEPEND="
cgi? ( app-text/highlight )
+ test? ( dev-lang/perl )
"
RDEPEND+=" selinux? ( sec-policy/selinux-makewhatis )"
@@ -107,6 +109,10 @@ src_compile() {
use cgi && emake man.cgi
}
+src_test() {
+ emake regress
+}
+
src_install() {
emake DESTDIR="${D}" install
use cgi && emake DESTDIR="${D}" cgi-install www-install