summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoao Santos <joaompssantos@gmail.com>2018-02-08 21:58:43 +0000
committerMichał Górny <mgorny@gentoo.org>2018-02-09 15:51:35 +0100
commit36cbdc6da74049a40b93992134ba85a5424dab38 (patch)
tree70fa6452ced39cef6f43a5fa361a01e8dfa29eed /app-text/master-pdf-editor
parentapp-emulation/flannel: Add myself as co-maintainer (diff)
downloadgentoo-36cbdc6da74049a40b93992134ba85a5424dab38.tar.gz
gentoo-36cbdc6da74049a40b93992134ba85a5424dab38.tar.bz2
gentoo-36cbdc6da74049a40b93992134ba85a5424dab38.zip
app-text/master-pdf-editor: version bump to 4.3.82
Closes: https://github.com/gentoo/gentoo/pull/7125 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-text/master-pdf-editor')
-rw-r--r--app-text/master-pdf-editor/Manifest1
-rw-r--r--app-text/master-pdf-editor/master-pdf-editor-4.3.82.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/app-text/master-pdf-editor/Manifest b/app-text/master-pdf-editor/Manifest
index 58d1600f5fce..df61f66a4abf 100644
--- a/app-text/master-pdf-editor/Manifest
+++ b/app-text/master-pdf-editor/Manifest
@@ -1 +1,2 @@
DIST master-pdf-editor-4.3.61_qt5.amd64.tar.gz 14950654 BLAKE2B a9dabeecde4a4f8657d29bca61f9ffbc1cb3f4e5f5002afba965a9a444572791a27316257768f3f2b793215f49d538b4ac68b4ae5271e5c1500557ab5cd9a192 SHA512 0c416df191a2796fdafa6014c258166d47037039fcc9205398138a46d59b1f771d9ffe38eb16f22f4300c3e965435300037d7413a86efb997395e6e974baecb5
+DIST master-pdf-editor-4.3.82_qt5.amd64.tar.gz 14934502 BLAKE2B f93c756f9270b2857af02047c6ebd242d35ddaf23b70118d440c21cc7a0718937aa9945bb24adad6544e984f9390e9f49bfce5298bb8bc54f3c705372aff0fd4 SHA512 9bc6b056bdc8ce349dbab139f64c90948f3e0498918f07df6249fee2fad98a35b133aa7913e375366d062e134878feed0fadd097ab1d5504e97884ffa2c37b24
diff --git a/app-text/master-pdf-editor/master-pdf-editor-4.3.82.ebuild b/app-text/master-pdf-editor/master-pdf-editor-4.3.82.ebuild
new file mode 100644
index 000000000000..2af6159261c6
--- /dev/null
+++ b/app-text/master-pdf-editor/master-pdf-editor-4.3.82.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit xdg-utils desktop
+
+DESCRIPTION="Master PDF Editor is a complete solution for viewing and editing PDF files"
+HOMEPAGE="https://code-industry.net/free-pdf-editor/"
+SRC_URI="http://get.code-industry.net/public/${P}_qt5.amd64.tar.gz"
+
+LICENSE="master-pdf-editor"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror"
+
+COMMON_DEPEND="
+ app-arch/bzip2
+ dev-libs/double-conversion
+ dev-libs/glib
+ dev-libs/icu
+ dev-libs/openssl
+ media-gfx/graphite2
+ media-gfx/sane-backends
+ media-libs/freetype
+ media-libs/harfbuzz
+ media-libs/libjpeg-turbo
+ media-libs/libpng
+ media-libs/tiff
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libxcb
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ >=dev-qt/qtsvg-5.4:5
+ >=dev-qt/qtnetwork-5.4:5
+ >=dev-qt/qtgui-5.4:5
+ >=dev-qt/qtprintsupport-5.4:5
+"
+
+RDEPEND="${COMMON_DEPEND}"
+
+S="${WORKDIR}/${PN}-${PV%%.*}"
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r fonts lang stamps templates masterpdfeditor4.png
+
+ exeinto /opt/${PN}
+ doexe masterpdfeditor4
+
+ dosym ../${PN}/masterpdfeditor4 /opt/bin/masterpdfeditor4
+ make_desktop_entry "masterpdfeditor4 %f" \
+ "Master PDF Editor ${PV}" /opt/${PN}/masterpdfeditor4.png \
+ "Office;Graphics;Viewer" \
+ "MimeType=application/pdf;application/x-bzpdf;application/x-gzpdf;\nTerminal=false"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}