summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/nfoview
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/nfoview')
-rw-r--r--app-text/nfoview/Manifest2
-rw-r--r--app-text/nfoview/metadata.xml7
-rw-r--r--app-text/nfoview/nfoview-1.10.ebuild48
-rw-r--r--app-text/nfoview/nfoview-1.15.1.ebuild44
-rw-r--r--app-text/nfoview/nfoview-9999.ebuild44
5 files changed, 145 insertions, 0 deletions
diff --git a/app-text/nfoview/Manifest b/app-text/nfoview/Manifest
new file mode 100644
index 000000000000..aa2741da5ade
--- /dev/null
+++ b/app-text/nfoview/Manifest
@@ -0,0 +1,2 @@
+DIST nfoview-1.10.tar.gz 102058 SHA256 49e771c059824563aa518e163c68da0c08b04bc174521d2ecff7934a550d4b49 SHA512 6114a6944b7886a6def01cd47649109d5e16921128cd8be122cb3395831038037b45160c3f0449e31fbb2bec88ac1e2c07294a5aaceea51a4fea93b7ea4440af WHIRLPOOL 348eb59e68320591f6a6713ca3ce20e44b0c9d07d35edf791619a66c85fec811b6d12951c0690ed5b6650b5a6e8491612a1d426cdbe6121d5e5d29b8c861feb1
+DIST nfoview-1.15.1.tar.xz 88400 SHA256 ed7643a781e9a96a904b1165dbefd0440fa029d25819233f0543925bb7067b1e SHA512 e4cf86003b03ae57b8a4e76990df77c7e9e441abd8ab0440385405b0f600a85539a152de5893ebe75797bd96ecb811086c48b1439b9f8719050eb12315f67426 WHIRLPOOL da47cc6275fec9a8d01d2bd38eabbf66188eec7c7e6cd657f3ebfbe4b51f010a3dcbd29faad7978aa504a8faa191959d8a3d36b0f54c301c84d3a2b089a4309a
diff --git a/app-text/nfoview/metadata.xml b/app-text/nfoview/metadata.xml
new file mode 100644
index 000000000000..7123fa8f9ece
--- /dev/null
+++ b/app-text/nfoview/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>vapier@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/app-text/nfoview/nfoview-1.10.ebuild b/app-text/nfoview/nfoview-1.10.ebuild
new file mode 100644
index 000000000000..824ed221ddef
--- /dev/null
+++ b/app-text/nfoview/nfoview-1.10.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+PYTHON_DEPEND="3:3.2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.*"
+
+inherit distutils fdo-mime gnome2-utils
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/otsaloma/nfoview.git
+ http://github.com/otsaloma/nfoview.git"
+ inherit git-2
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ SRC_URI="http://download.gna.org/nfoview/1.10/${P}.tar.gz"
+ KEYWORDS="amd64 x86"
+fi
+
+DESCRIPTION="simple viewer for NFO files, which are ASCII art in the CP437 codepage"
+HOMEPAGE="http://home.gna.org/nfoview/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/pygobject:3"
+RDEPEND="${DEPEND}
+ media-fonts/terminus-font"
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+ distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+ distutils_pkg_postrm
+}
diff --git a/app-text/nfoview/nfoview-1.15.1.ebuild b/app-text/nfoview/nfoview-1.15.1.ebuild
new file mode 100644
index 000000000000..809881c5aae5
--- /dev/null
+++ b/app-text/nfoview/nfoview-1.15.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{3_3,3_4} )
+
+inherit distutils-r1 fdo-mime gnome2-utils
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/otsaloma/nfoview.git
+ http://github.com/otsaloma/nfoview.git"
+ inherit git-2
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ SRC_URI="http://download.gna.org/nfoview/${PV:0:4}/${P}.tar.xz"
+ KEYWORDS="amd64 x86"
+fi
+
+DESCRIPTION="simple viewer for NFO files, which are ASCII art in the CP437 codepage"
+HOMEPAGE="http://home.gna.org/nfoview/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/pygobject:3"
+RDEPEND="${DEPEND}
+ media-fonts/terminus-font"
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}
diff --git a/app-text/nfoview/nfoview-9999.ebuild b/app-text/nfoview/nfoview-9999.ebuild
new file mode 100644
index 000000000000..e7a3f0d204a3
--- /dev/null
+++ b/app-text/nfoview/nfoview-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{3_3,3_4} )
+
+inherit distutils-r1 fdo-mime gnome2-utils
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/otsaloma/nfoview.git
+ http://github.com/otsaloma/nfoview.git"
+ inherit git-2
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ SRC_URI="http://download.gna.org/nfoview/${PV:0:4}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="simple viewer for NFO files, which are ASCII art in the CP437 codepage"
+HOMEPAGE="http://home.gna.org/nfoview/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/pygobject:3"
+RDEPEND="${DEPEND}
+ media-fonts/terminus-font"
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}