summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTill Schäfer <till2.schaefer@uni-dortmund.de>2019-01-04 22:54:02 +0100
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-01-07 13:05:27 -0800
commit9ac727d83f9a2ea4aece3e76dc0f4a465e133f3f (patch)
tree90cd22ef4b03ce8288a9a74b0a6e247bb0b02478 /app-text/nfoview
parentdev-python/lxml: remove old (diff)
downloadgentoo-9ac727d83f9a2ea4aece3e76dc0f4a465e133f3f.tar.gz
gentoo-9ac727d83f9a2ea4aece3e76dc0f4a465e133f3f.tar.bz2
gentoo-9ac727d83f9a2ea4aece3e76dc0f4a465e133f3f.zip
app-text/nfoview: bump to version 1.26
* remove pkg_preinst * fix license * capitalize description * add python_targets_python3_7 Signed-off-by: Till Schäfer <till2.schaefer@uni-dortmund.de> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/10669 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'app-text/nfoview')
-rw-r--r--app-text/nfoview/Manifest1
-rw-r--r--app-text/nfoview/nfoview-1.26.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-text/nfoview/Manifest b/app-text/nfoview/Manifest
index c529440fbf62..0db66da8ac03 100644
--- a/app-text/nfoview/Manifest
+++ b/app-text/nfoview/Manifest
@@ -1,2 +1,3 @@
DIST nfoview-1.23.tar.gz 83337 BLAKE2B d73cd6987bf7929c57e8acf0a24278272ea199bf980756ddb5da9a5eddf7760a8c05f0e48a287ee760d4bf4d2594fb08b43a77cef46d371a746629bf76955e91 SHA512 b94724e130cdf58b911634496c52361d008ebfafab3ac40a76612c4891737d4145596a6badc15fe4228c90c1cd7261e5a892e3e462070ebb55f71332b36345d7
DIST nfoview-1.24.tar.gz 86037 BLAKE2B 5d565680864f1a73a64d9557e69eda0771dc164f12018ac8964fb1c2225005c1bb881c7b9035c7baed2021838e3a291e52fb5af84cf9c271c046cfddd684270c SHA512 91ad1f9f972b7681655b429c0910475012bd2231e51c6db5659b19fb869779d1de10dadc1d6461fa7d577c051af9b74f1d463543a429e1dca438a4ff17ac2293
+DIST nfoview-1.26.tar.gz 117468 BLAKE2B 7fec761774ee66f1f5845d2d49cf99644d522c6fe402bdfd578e12371b58b3ac5a80b77959c92531ff54362c2234d043fa219b50730158c91310ba67b491f729 SHA512 2e697e3a49aa85fe0865ad9f281ea830e692335682658061f2aaaa1c5ed6ccb3dbd822dab244190ae0521ce237fbc3d91480da4c1229548f0fd5a74df712e336
diff --git a/app-text/nfoview/nfoview-1.26.ebuild b/app-text/nfoview/nfoview-1.26.ebuild
new file mode 100644
index 000000000000..fd688874d731
--- /dev/null
+++ b/app-text/nfoview/nfoview-1.26.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6,7} )
+
+inherit distutils-r1 gnome2-utils xdg-utils
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/otsaloma/nfoview.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/otsaloma/nfoview/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Simple viewer for NFO files, which are ASCII art in the CP437 codepage"
+HOMEPAGE="https://otsaloma.io/nfoview/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/pygobject:3[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ media-fonts/terminus-font"
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}